Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Jakub Panek
aports
Commits
572709d3
Commit
572709d3
authored
11 years ago
by
Leonardo Arena
Browse files
Options
Downloads
Patches
Plain Diff
main/roundcubemail: upgrade to 0.9.0
parent
b7bd8951
Loading
Loading
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/roundcubemail/APKBUILD
+7
-7
7 additions, 7 deletions
main/roundcubemail/APKBUILD
main/roundcubemail/fix-dirs.patch
+7
-37
7 additions, 37 deletions
main/roundcubemail/fix-dirs.patch
with
14 additions
and
44 deletions
main/roundcubemail/APKBUILD
+
7
−
7
View file @
572709d3
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
roundcubemail
pkgver
=
0.
8.6
pkgver
=
0.
9.0
pkgrel
=
0
pkgdesc
=
"A PHP web-based mail client"
url
=
"http://www.roundcube.net"
...
...
@@ -73,9 +73,9 @@ installer() {
"
$subpkgdir
"
/usr/share/webapps/roundcube
}
md5sums
=
"
d8fc9958e45dccea0b016e84fde288aa
roundcubemail-0.
8.6
.tar.gz
987406fd8f12719544aeb057973b368e
fix-dirs.patch"
sha256sums
=
"
88128db0dc57651e08beb3c4811bc9e33aca1c39a50cfc9efb5d14b0baa17704
roundcubemail-0.
8.6
.tar.gz
dcc49f9e43d443477244448ed746f86b56bbacb942adf9ca5613e8b3fb50c1a7
fix-dirs.patch"
sha512sums
=
"
b49956ab923bee773aeaa140c24c6ca012a6fae05bb2cb664e874f4bb
1443
6d9aaedee6c2d82638f1a1db6ab58dfd8cc3b9d0144d256d07f662565c4fa287d6
3 roundcubemail-0.
8.6
.tar.gz
cfd169b3e15bc5ffd98179cf295311c24188e4d94278d9b8020508648abb96088fe511599bd7e2be3c3ca5948c29f4f35491e67244821c2752ddcdfe4cd20959
fix-dirs.patch"
md5sums
=
"
843de3439886c2dddb0f09e9bb6a4d04
roundcubemail-0.
9.0
.tar.gz
0cfce0716e174c27c49e1c62aa30f67c
fix-dirs.patch"
sha256sums
=
"
7edab9579cd2a6353c30de3fcfc86da231f0a46f7ad4ce707090813173f662c2
roundcubemail-0.
9.0
.tar.gz
9185719a389b6cca64fc4aa73a5565858572651a71f66da0230ab180bf61e05a
fix-dirs.patch"
sha512sums
=
"
33a2026027e20f3ed8915806e0d8dcfd1f
14
1
43
761b22c9bf452e7520c0b15304e74d34c524a3811a7c85e8f69bdfe40f44f0a92ff8993c94c68dfe56585da7
3 roundcubemail-0.
9.0
.tar.gz
5c645ab7f130f8f3b17b7821e2cd0be88b6d7999da38876bde36c9b116bf7d34bcf52e2d8939d9359649e3fc5ddfb1cab7798ffb9e649be11bebd1d2c4ee006b
fix-dirs.patch"
This diff is collapsed.
Click to expand it.
main/roundcubemail/fix-dirs.patch
+
7
−
37
View file @
572709d3
diff --git a/installer/index.php b/installer/index.php
index 7ed5224..f9f8241 100644
--- a/installer/index.php
+++ b/installer/index.php
@@ -43,7 +43,7 @@
ini_set('display_errors', 1);
@@ -41,7 +41,7 @@
define('INSTALL_PATH', realpath(dirname(__FILE__) . '/../').'/');
-
define('RC
MAIL_CONFIG_DIR
', INSTALL_PATH
. 'config'
);
+
define('RC
MAIL
_CONFIG_DIR',
'/etc/roundcube
');
define('RC
MAIL_CHARSET', 'UTF-8
');
define('RC
UBE_INSTALL_PATH
', INSTALL_PATH);
-
define('RC
UBE
_CONFIG_DIR',
INSTALL_PATH . 'config/
');
+
define('RC
UBE_CONFIG_DIR', '/etc/roundcube
');
$include_path = INSTALL_PATH . 'program/lib' . PATH_SEPARATOR;
diff --git a/program/include/iniset.php b/program/include/iniset.php
index 10ae11e..f9d3d92 100755
$include_path .= INSTALL_PATH . 'program/include' . PATH_SEPARATOR;
--- a/program/include/iniset.php
+++ b/program/include/iniset.php
@@ -4
7
,7 +4
7
,7 @@
if (!defined('INSTALL_PATH')) {
@@ -4
4
,7 +4
4
,7 @@
}
if (!defined('RCMAIL_CONFIG_DIR')) {
...
...
@@ -23,30 +19,4 @@ index 10ae11e..f9d3d92 100755
+ define('RCMAIL_CONFIG_DIR', '/etc/roundcube');
}
// make sure path_separator is defined
diff --git a/program/include/main.inc b/program/include/main.inc
index 30d9099..8400395 100644
--- a/program/include/main.inc
+++ b/program/include/main.inc
@@ -2101,7 +2101,7 @@
function write_log($name, $line)
// log_driver == 'file' is assumed here
if (empty($CONFIG['log_dir']))
- $CONFIG['log_dir'] = INSTALL_PATH.'logs';
+ $CONFIG['log_dir'] = '/var/log/roundcube';
// try to open specific log file for writing
$logfile = $CONFIG['log_dir'].'/'.$name;
diff --git a/program/include/rcube_config.php b/program/include/rcube_config.php
index 7d46df0..d9990c4 100644
--- a/program/include/rcube_config.php
+++ b/program/include/rcube_config.php
@@ -66,7 +66,7 @@
class rcube_config
// fix paths
$this->prop['log_dir'] = $this->prop['log_dir'] ? realpath(unslashify($this->prop['log_dir'])) : INSTALL_PATH . 'logs';
- $this->prop['temp_dir'] = $this->prop['temp_dir'] ? realpath(unslashify($this->prop['temp_dir'])) : INSTALL_PATH . 'temp';
+ $this->prop['temp_dir'] = $this->prop['temp_dir'] ? realpath(unslashify($this->prop['temp_dir'])) : '/tmp';
// fix default imap folders encoding
foreach (array('drafts_mbox', 'junk_mbox', 'sent_mbox', 'trash_mbox') as $folder)
if (!defined('RCUBE_LOCALIZATION_DIR')) {
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment