Skip to content
Snippets Groups Projects
Commit 4ef8b328 authored by Natanael Copa's avatar Natanael Copa
Browse files

main/xulrunner: upgrade to 16.0

parent 73761cf3
No related branches found
No related tags found
No related merge requests found
......@@ -9,8 +9,8 @@ Subject: [PATCH 3/4] xulrunner: jemalloc aslr
diff --git a/memory/jemalloc/jemalloc.c b/memory/jemalloc/jemalloc.c
index ad7c450..91de92c 100644
--- a/memory/jemalloc/jemalloc.c
+++ b/memory/jemalloc/jemalloc.c
--- a/memory/mozjemalloc/jemalloc.c
+++ b/memory/mozjemalloc/jemalloc.c
@@ -410,7 +410,7 @@ void *_mmap(void *addr, size_t length, int prot, int flags,
static const bool __isthreaded = true;
#endif
......
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=xulrunner
pkgver=15.0.1
pkgver=16.0
_ffoxver=$pkgver
pkgrel=0
pkgdesc="runtime environment for xul-based applications"
......@@ -14,12 +14,15 @@ depends_dev="nspr-dev
gtk+-dev
dbus-glib-dev
alsa-lib-dev
gstreamer-dev
gst-plugins-base-dev
libvorbis-dev
libogg-dev
libtheora-dev
wireless-tools-dev
libnotify-dev
libevent-dev
libvpx-dev
libxt-dev
jpeg-dev
bzip2-dev
......@@ -106,9 +109,9 @@ dev() {
mv "${pkgdir}"/usr/include "${subpkgdir}"/usr/include
}
md5sums="743ba71fbce7b32023405db02d44143f firefox-15.0.1.source.tar.bz2
b0f7d491bc800b69ec718667a4b08acb mozconfig
md5sums="04cbefaebaf77693bacd11145ece104f firefox-16.0.source.tar.bz2
36d8d42ae4375f1190c9558bb0d10fa7 mozconfig
f43c1f0ae57aa8289b130c6de8caf3ce 0002-Use-C99-math-isfinite.patch
7faa279d64c9ec2e7abc7c0497c7e07e 0003-xulrunner-jemalloc-aslr.patch
48b7d0404b45b15b8ae4a7d08ac95db3 uclibc-malloc_usable_size.patch
e8b3a22d670241bb5c038729ac49a975 0003-xulrunner-jemalloc-aslr.patch
1ce894c4f6a4541fdccf0b4a8b1dd95b uclibc-malloc_usable_size.patch
6a3942d96c7ce3c63251761cc12c8349 cairo.patch"
......@@ -8,9 +8,12 @@ ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
ac_add_options --with-system-bz2
ac_add_options --with-system-libevent
ac_add_options --with-system-libvpx
ac_add_options --with-system-pixman
ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-cairo
ac_add_options --enable-system-ffi
ac_add_options --with-pthreads
ac_add_options --enable-strip
ac_add_options --disable-tests
......@@ -29,10 +32,12 @@ ac_add_options --enable-startup-notification
ac_add_options --enable-extensions=default
ac_add_options --enable-jemalloc
ac_add_options --disable-elf-hack
ac_add_options --enable-gio
# export LIBS="-lubacktrace"
export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
export MOZ_JEMALLOC=1
mk_add_options BUILD_OFFICIAL=1
mk_add_options MOZILLA_OFFICIAL=1
......@@ -29,7 +29,7 @@
include $(DEPTH)/config/autoconf.mk
+ifdef MOZ_MEMORY
+SHARED_LIBRARY_LIBS = $(call EXPAND_LIBNAME_PATH,jemalloc,../jemalloc)
+SHARED_LIBRARY_LIBS = $(call EXPAND_LIBNAME_PATH,jemalloc,../jemalloc) $(call EXPAND_LIBNAME_PATH,memory,../build)
+endif
+
VISIBILITY_FLAGS=
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment