Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Jakub Panek
aports
Commits
2419e502
Commit
2419e502
authored
13 years ago
by
Natanael Copa
Browse files
Options
Downloads
Patches
Plain Diff
devbuild: removed. has not been used for many years
parent
bdace10a
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
Makefile
+2
-3
2 additions, 3 deletions
Makefile
devbuild.in
+0
-61
0 additions, 61 deletions
devbuild.in
with
2 additions
and
64 deletions
Makefile
+
2
−
3
View file @
2419e502
...
@@ -10,9 +10,8 @@ abuildrepo ?= ~/.cache/abuild
...
@@ -10,9 +10,8 @@ abuildrepo ?= ~/.cache/abuild
LUA_VERSION
=
5.1
LUA_VERSION
=
5.1
LUA_SHAREDIR
?=
$(
prefix
)
/share/lua/
$(
LUA_VERSION
)
/
LUA_SHAREDIR
?=
$(
prefix
)
/share/lua/
$(
LUA_VERSION
)
/
SCRIPTS
:=
abuild devbuild buildrepo abuild-keygen
\
SCRIPTS
:=
abuild buildrepo abuild-keygen abuild-sign newapkbuild
\
abuild-sign newapkbuild abump apkgrel ap buildlab
\
abump apkgrel ap buildlab apkbuild-cpan
apkbuild-cpan
USR_BIN_FILES
:=
$(
SCRIPTS
)
abuild-tar
USR_BIN_FILES
:=
$(
SCRIPTS
)
abuild-tar
SAMPLES
:=
sample.APKBUILD sample.initd sample.confd
\
SAMPLES
:=
sample.APKBUILD sample.initd sample.confd
\
sample.pre-install sample.post-install
sample.pre-install sample.post-install
...
...
This diff is collapsed.
Click to expand it.
devbuild.in
deleted
100755 → 0
+
0
−
61
View file @
bdace10a
#!/bin/sh
# This scripts will:
# 1. create a dist package for current subproject
# 2. update the APKBUILD and build the package
# 3. build the alpine iso
#
# The following is assumed from the subproject:
# * that PACKAGE and VERSION is set in Makefile or defined in a local
# devbuild.conf file
# * that 'make dist' will generate a valid dist package
#
program
=
${
0
##*/
}
# rebuild env. Those values can be overridden in either
# /etc/devbuildrc or $HOME/.devbuildrc
DISTFILES
=
/var/cache/distfiles
APORTS_DIR
=
$HOME
/aports
ALPINE_DIR
=
$HOME
/abuild
# for the local project. Those values can be overridden by
# a .devbuildrc in the subprojects dir
PACKAGE
=
$(
grep
'^PACKAGE'
Makefile |
sed
's/.*=[[:blank:]]*//'
)
VERSION
=
$(
grep
'^VERSION'
Makefile |
sed
's/.*=[[:blank:]]*//'
)
SUFFIX
=
.tar.bz2
REPO
=
core
# let user override the above defaults
for
i
in
/etc/
${
program
}
rc
$HOME
/.
${
program
}
rc ./.
${
program
}
rc
;
do
if
[
-f
$i
]
;
then
.
$i
fi
done
# generate a new dist package
tarball
=
${
PACKAGE
}
-
${
VERSION
}${
SUFFIX
}
make dist
||
exit
1
cp
$tarball
"
$DISTFILES
/"
||
exit
1
# update the APKBUILD, in a subshell
(
cd
$APORTS_DIR
/
$REPO
/
$PACKAGE
||
exit
1
.
./APKBUILD
if
[
"
$pkgver
"
=
"
$VERSION
"
]
;
then
pkgrel
=
$((
$pkgrel
+
1
))
else
pkgrel
=
"0"
fi
sed
-i
-e
" s/^pkgver=.*/pkgver=
$VERSION
/;
s/^pkgrel=.*/pkgrel=
$pkgrel
/;
/^md5sums=
\"
/,/
\"\$
/d"
APKBUILD
||
exit
1
export
SRCDEST
=
"
$DISTFILES
"
abuild checksum
abuild
abuild cleanoldpkg
)
||
exit
1
# rebuild the iso
cd
"
$ALPINE_DIR
"
&&
fakeroot ./mkalpine
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment