Skip to content
Snippets Groups Projects
Commit 9059702a authored by Sören Tempel's avatar Sören Tempel
Browse files

testing/vis: new aport

parent 70af635d
No related branches found
No related tags found
No related merge requests found
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=vis
pkgver=0.1
pkgrel=0
pkgdesc="A vim like text editor"
url="https://github.com/martanne/vis"
arch="all"
license="ISC"
depends="!outils lua5.2-lpeg"
depends_dev=""
makedepends="libtermkey-dev ncurses-dev lua5.2-dev"
install=""
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/martanne/$pkgname/archive/v$pkgver.tar.gz
fortify-source.patch"
_builddir="$srcdir"/$pkgname-$pkgver
build() {
make -C "$_builddir" || return 1
}
package() {
make -C "$_builddir" \
PREFIX=/usr \
DESTDIR="$pkgdir" \
install || return 1
}
md5sums="1e4a2b14cce65dee1458c6c4bd47b28e vis-0.1.tar.gz
4cdc22b04428fc837feb78cc4cedbe2f fortify-source.patch"
sha256sums="c695b095f85f4360590865b0b7007aa019463b24c1026c0e624a78b31f3ac54b vis-0.1.tar.gz
71928d8b7408e52c396aca154e0fefc0aa07b1da744afc2d486b1f8b0984f89b fortify-source.patch"
sha512sums="f2647971660ceb14a16371129e01027264c80818e1143684dffd19a7b99df5ee83978751b497b5678bb36a910203f9546366db335ccaf721b906b8e5b1bb9100 vis-0.1.tar.gz
46a0220123a1878cd2f96fe69009ce14fea4c2362e6c285d63237faf140062125a4132668dc01124723ac0f697ae3ad625c5ea242330e427b0496436fe300d5b fortify-source.patch"
-D_FORTIFY_SOURCE=2 is enable in gcc by default on alpine. See the
010_all_default-fortify-source.patch patch in main/gcc. Disabling
it here silences a bunch of compiler warnings.
diff -upr vis-0.1.orig/config.mk vis-0.1/config.mk
--- vis-0.1.orig/config.mk 2016-02-27 17:42:14.812754756 +0100
+++ vis-0.1/config.mk 2016-02-27 17:42:23.349390641 +0100
@@ -64,7 +64,7 @@ STRIP ?= strip
# Hardening
ifeq (${CC},gcc)
- CFLAGS += -fPIC -fstack-protector-all -D_FORTIFY_SOURCE=2
+ CFLAGS += -fPIC -fstack-protector-all
LDFLAGS += -z now -z relro -pie
else ifeq (${CC},clang)
CFLAGS += -fPIE -fstack-protector-all -D_FORTIFY_SOURCE=2
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment