Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Maxim Karasev
aports
Commits
61ab8cc4
Commit
61ab8cc4
authored
8 years ago
by
Natanael Copa
Browse files
Options
Downloads
Patches
Plain Diff
main/lua-sql: upgrade to 2.3.1
parent
85b40a98
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/lua-sql/APKBUILD
+10
-14
10 additions, 14 deletions
main/lua-sql/APKBUILD
main/lua-sql/sqlite_v2_api.patch
+0
-26
0 additions, 26 deletions
main/lua-sql/sqlite_v2_api.patch
with
10 additions
and
40 deletions
main/lua-sql/APKBUILD
+
10
−
14
View file @
61ab8cc4
...
...
@@ -4,8 +4,8 @@ _luaversions="5.1 5.2 5.3"
_drivers
=
"mysql postgres sqlite3 odbc"
pkgname
=
lua-sql
pkgver
=
2.3.
0
pkgrel
=
3
pkgver
=
2.3.
1
pkgrel
=
0
pkgdesc
=
"Lua SQL drivers"
url
=
"http://keplerproject.github.io/luasql/doc/us/"
arch
=
"all"
...
...
@@ -24,8 +24,7 @@ for _j in $_drivers; do
subpackages
=
"
$subpackages
lua-sql-
$_j
:split_
${
_j
}
"
done
source
=
"luasql-
$pkgver
.tar.gz::https://github.com/keplerproject/luasql/archive/v
$pkgver
.tar.gz
sqlite_v2_api.patch"
source
=
"luasql-
$pkgver
.tar.gz::https://github.com/keplerproject/luasql/archive/v
$pkgver
.tar.gz"
_sdir
=
"
$srcdir
"
/luasql-
$pkgver
prepare
()
{
...
...
@@ -55,19 +54,19 @@ build() {
cd
"
$srcdir
"
/build-
$_i
make
CFLAGS
=
"
$CFLAGS
$(
pkg-config lua
$_i
--cflags
)
-fPIC"
\
DRIVER_LIBS
=
"-lmysqlclient"
\
T
=
mysql
||
return
1
mysql
||
return
1
make
CFLAGS
=
"
$CFLAGS
$(
pkg-config lua
$_i
--cflags
)
-fPIC"
\
DRIVER_LIBS
=
"
$(
pkg-config
--libs
libpq
)
"
\
T
=
postgres
||
return
1
postgres
||
return
1
make
CFLAGS
=
"
$CFLAGS
$(
pkg-config lua
$_i
--cflags
)
-fPIC"
\
DRIVER_LIBS
=
"
$(
pkg-config
--libs
sqlite3
)
"
\
T
=
sqlite3
||
return
1
sqlite3
||
return
1
make
CFLAGS
=
"
$CFLAGS
$(
pkg-config lua
$_i
--cflags
)
-fPIC -DUNIXODBC"
\
DRIVER_LIBS
=
"-lodbc"
\
T
=
odbc
||
return
1
odbc
||
return
1
done
}
...
...
@@ -107,9 +106,6 @@ for _j in $_drivers; do
}"
done
md5sums
=
"af9f0f3a2313a1fcf88c40700092048d luasql-2.3.0.tar.gz
656699a57b5529aa9594f0fe6bad1dd4 sqlite_v2_api.patch"
sha256sums
=
"e173ff7b17a2757951b4b2f67d3b1bfe04caad7185b68cffa7758ce822e25e9f luasql-2.3.0.tar.gz
74fb0ad9161346a29dc133508b5b444084a46d792a9a4e987766fc3989dd0435 sqlite_v2_api.patch"
sha512sums
=
"62309cf6241ffab1ed32e718536a5c986168a7bb6fcf2cf55e884db5043d5ec473bbbb7c93b399dfc0a19f282e850f742452583ad0d973661a7f672b0f8da2d5 luasql-2.3.0.tar.gz
7ea3eb63d4e121875033dd8b7a027eb8fd7784831f9999c880a22d64cf8d50a9ef2cde804b86b416d39262e1f7185054bac1e7fb4fb560320c0a53cce52f80cc sqlite_v2_api.patch"
md5sums
=
"ddf721412aa55904f9e61f54d124e563 luasql-2.3.1.tar.gz"
sha256sums
=
"281f4d2c7d563551145169e2da41b5942a7aa15f4aedbcd73d53a8f8589c49e8 luasql-2.3.1.tar.gz"
sha512sums
=
"e4fbdaa8a0bc206773f616bdb8701d0b9af7f0c13daa4f41656a1937ee30bf8315a0afc079658f7b8cc29f41c9c9339c4d8cb66395a6137479f97a68cb43f95e luasql-2.3.1.tar.gz"
This diff is collapsed.
Click to expand it.
main/lua-sql/sqlite_v2_api.patch
deleted
100644 → 0
+
0
−
26
View file @
85b40a98
--- a/src/ls_sqlite3.c
+++ b/src/ls_sqlite3.c
@@ -382,7 +382,11 @@
static int conn_execute(lua_State *L)
int numcols;
const char *tail;
+#if SQLITE_VERSION_NUMBER > 3006013
+ res = sqlite3_prepare_v2(conn->sql_conn, statement, -1, &vm, &tail);
+#else
res = sqlite3_prepare(conn->sql_conn, statement, -1, &vm, &tail);
+#endif
if (res != SQLITE_OK)
{
errmsg = sqlite3_errmsg(conn->sql_conn);
@@ -544,7 +548,11 @@ static int env_connect(lua_State *L)
sourcename = luaL_checkstring(L, 2);
+#if SQLITE_VERSION_NUMBER > 3006013
+ res = sqlite3_open_v2(sourcename, &conn, SQLITE_OPEN_READWRITE | SQLITE_OPEN_CREATE, NULL);
+#else
res = sqlite3_open(sourcename, &conn);
+#endif
if (res != SQLITE_OK)
{
errmsg = sqlite3_errmsg(conn);
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment