Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Maxim Karasev
aports
Commits
4b7d2799
Commit
4b7d2799
authored
8 years ago
by
Timo Teräs
Browse files
Options
Downloads
Patches
Plain Diff
main/apk-tools: upgrade to 2.6.8
parent
889002af
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
main/apk-tools/APKBUILD
+5
-13
5 additions, 13 deletions
main/apk-tools/APKBUILD
main/apk-tools/add-aarch64.patch
+0
-29
0 additions, 29 deletions
main/apk-tools/add-aarch64.patch
main/apk-tools/fix-crossbuild.patch
+0
-14
0 additions, 14 deletions
main/apk-tools/fix-crossbuild.patch
with
5 additions
and
56 deletions
main/apk-tools/APKBUILD
+
5
−
13
View file @
4b7d2799
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
apk-tools
pkgver
=
2.6.
7
pkgrel
=
2
pkgver
=
2.6.
8
pkgrel
=
0
pkgdesc
=
"Alpine Package Keeper - package manager for alpine"
subpackages
=
"
$pkgname
-static"
depends
=
...
...
@@ -13,8 +13,6 @@ if [ "$CBUILD" = "$CHOST" ]; then
makedepends
=
"
$makedepends
lua5.2-dev"
fi
source
=
"http://dev.alpinelinux.org/archive/
$pkgname
/
$pkgname
-
$pkgver
.tar.xz
fix-crossbuild.patch
add-aarch64.patch
"
url
=
"http://git.alpinelinux.org/cgit/apk-tools/"
...
...
@@ -84,12 +82,6 @@ luaapk() {
mv
"
$pkgdir
"
/usr/lib
"
$subpkgdir
"
/usr/lib/
}
md5sums
=
"cfa2a6414174fdf360ced631a48ec018 apk-tools-2.6.7.tar.xz
8c76a52a7865560cf9f5dc53cc8a769b fix-crossbuild.patch
5e419d9ffadb3fa3993a36e45502705b add-aarch64.patch"
sha256sums
=
"0ce0c9d20b526a40d8a1ad5a2ee16645239c256f634305e74419f1335b5acfdf apk-tools-2.6.7.tar.xz
daceb53e5b8abf7277630980c6bf3b5e9d7117c5cf50a233bcafb42f0f290941 fix-crossbuild.patch
05805f88b53fe954b3d4520afb8e0b454b5cfc20370c3f3c0cd3d09235a8bbbb add-aarch64.patch"
sha512sums
=
"ad27c2b0eeb66917abbfa229f5fb7b533c36c0393ba954fffce5c8a47ca030dfe8af30aa6dec95d323c51e8e0fd5b2efc59d6242b1ff592c561b5b178c0ee9fa apk-tools-2.6.7.tar.xz
b739b94fba70e0dcb6ffd16627934ce636a4dd400c001ad27bbcb98aa40022942d62bc070eecdbeb8a1b777cd6bc14f89dea9f2806832e479e761e4ede6b8f35 fix-crossbuild.patch
3aca8e04375bbb3f33dec6b60dcd011d7ff26d9cf326315b0f4b91ada3892ecb0599e32f9294cade6bdc8cbc36cc9fda68e19c522fe923998f3c8538c6a7b997 add-aarch64.patch"
md5sums
=
"cc3efedf3047c256f13549ba58df3291 apk-tools-2.6.8.tar.xz"
sha256sums
=
"83f5cf9f0e75c19004a67150819eae2d4c859236b6c9c04d34d5b6968925f0d3 apk-tools-2.6.8.tar.xz"
sha512sums
=
"03fb42616335de9edaf3e44fd64a8d1c5dd8b0f25b7f3b176940b751a6547b8be153549f0cee9a5d65491025f6747799b6f5ba22b15d850593d499c07b5cc4c6 apk-tools-2.6.8.tar.xz"
This diff is collapsed.
Click to expand it.
main/apk-tools/add-aarch64.patch
deleted
100644 → 0
+
0
−
29
View file @
889002af
From 06ae5fdfdccd0c8e6d5501d93666bd915d2604d1 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
Date: Fri, 8 Jul 2016 11:09:00 +0300
Subject: [PATCH] detect aarch64 architecture and assign default name for it
---
src/apk_defines.h | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/src/apk_defines.h b/src/apk_defines.h
index 2aca364..9b2e904 100644
--- a/src/apk_defines.h
+++ b/src/apk_defines.h
@@ -93,9 +93,10 @@
extern char **apk_argv;
#define APK_DEFAULT_ARCH "armhf"
#elif defined(__arm__) && __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
#define APK_DEFAULT_ARCH "armel"
+#elif defined(__aarch64__) && __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
+#define APK_DEFAULT_ARCH "aarch64"
#else
-#warning APK_DEFAULT_ARCH is not set for this architecture
-#define APK_DEFAULT_ARCH "noarch"
+#error APK_DEFAULT_ARCH not detected for this architecture
#endif
#define APK_MAX_REPOS 32 /* see struct apk_package */
--
2.9.0
This diff is collapsed.
Click to expand it.
main/apk-tools/fix-crossbuild.patch
deleted
100644 → 0
+
0
−
14
View file @
889002af
diff --git a/src/Makefile b/src/Makefile
index 250d2f0..0e0525a 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -66,7 +66,7 @@
LDFLAGS_apk += -L$(obj)
LDFLAGS_apk-test += -L$(obj)
CFLAGS_ALL += $(shell $(PKG_CONFIG) --cflags $(PKGDEPS))
-LIBS := /usr/lib/libfetch.a \
+LIBS := $(shell $(CC) -print-file-name=libfetch.a) \
-Wl,--as-needed \
$(shell $(PKG_CONFIG) --libs $(PKGDEPS)) \
-Wl,--no-as-needed
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment