Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Maxim Karasev
aports
Commits
0df72bd5
Commit
0df72bd5
authored
10 years ago
by
Ted Trask
Browse files
Options
Downloads
Patches
Plain Diff
main/haserl: upgrade to 0.9.33 and create subpackages for Lua 5.1 and 5.2 support
parent
b7de3042
Loading
Loading
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
main/haserl/APKBUILD
+51
-19
51 additions, 19 deletions
main/haserl/APKBUILD
with
51 additions
and
19 deletions
main/haserl/APKBUILD
+
51
−
19
View file @
0df72bd5
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
_luaversions
=
"5.1 5.2"
_defaultlua
=
"5.1"
pkgname
=
haserl
pkgver
=
0.9.3
2
pkgrel
=
2
pkgver
=
0.9.3
3
pkgrel
=
0
pkgdesc
=
"Html And Shell Embedded Report Language"
url
=
"http://haserl.sourceforge.net/"
arch
=
"all"
license
=
"GPL2"
depends
=
""
makedepends
=
"
lua-dev
automake autoconf"
makedepends
=
"automake autoconf"
subpackages
=
"
$pkgname
-doc"
for
_i
in
$_luaversions
;
do
depends
=
"
$depends
haserl-lua
$_i
"
makedepends
=
"
$makedepends
lua
$_i
-dev"
subpackages
=
"
$subpackages
haserl-lua
$_i
:split_
${
_i
/./_
}
"
done
options
=
"suid"
source
=
"http://downloads.sourceforge.net/
$pkgname
/
$pkgname
-
$pkgver
.tar.gz"
_
build
dir
=
"
$srcdir
"
/
$pkgname
-
$pkgver
_
s
dir
=
"
$srcdir
"
/
$pkgname
-
$pkgver
prepare
()
{
cd
"
$_
build
dir
"
cd
"
$_
s
dir
"
for
i
in
$source
;
do
case
$i
in
*
.patch
)
msg
$i
;
patch
-p1
-i
"
$srcdir
"
/
$i
||
return
1
;;
...
...
@@ -24,25 +31,50 @@ prepare() {
rm
-f
src/haserl_lualib.inc
aclocal
&&
autoconf
&&
autoheader
&&
automake
--add-missing
||
return
1
for
_i
in
$_luaversions
;
do
cp
-r
"
$_sdir
"
"
$srcdir
"
/build-
$_i
done
}
build
()
{
cd
"
$_builddir
"
./configure
\
--build
=
$CBUILD
\
--host
=
$CHOST
\
--prefix
=
/usr
\
--with-lua
\
||
return
1
make
||
return
1
for
_i
in
$_luaversions
;
do
cd
"
$srcdir
"
/build-
$_i
./configure
\
--build
=
$CBUILD
\
--host
=
$CHOST
\
--prefix
=
/usr
\
--with-lua
=
lua
$_i
\
||
return
1
make
||
return
1
done
}
package
()
{
cd
"
$_builddir
"
make
DESTDIR
=
"
$pkgdir
/"
install
||
return
1
chmod
4111
"
$pkgdir
"
/usr/bin/haserl
for
_i
in
$_luaversions
;
do
cd
"
$srcdir
"
/build-
$_i
make
DESTDIR
=
"
$pkgdir
/"
install
||
return
1
chmod
4111
"
$pkgdir
"
/usr/bin/haserl
mv
"
$pkgdir
"
/usr/bin/haserl
"
$pkgdir
"
/usr/bin/haserl-lua
$_i
done
ln
-s
haserl-lua
$_defaultlua
"
$pkgdir
"
/usr/bin/haserl
}
md5sums
=
"18e2208aea6d772d1670c1a648bb6b77 haserl-0.9.32.tar.gz"
sha256sums
=
"c93aea462cddce1cda5a712f50bcad2197d987bdc01477ddb79347c0d4fae26f haserl-0.9.32.tar.gz"
sha512sums
=
"9ccd9037abade1f4654ea42c594218bac19668ad1485b6e40e1c50af76db69861ade4a80f420bc97b4a722047f239970297c52317f3071a31eaadba88a4f57b2 haserl-0.9.32.tar.gz"
_split
()
{
local
d
=
_ver
=
$1
pkgdesc
=
"Html And Shell Embedded Report Language with Lua
$_ver
support"
replaces
=
"
$pkgname
"
depends
=
if
[
-f
"
$pkgdir
"
/usr/bin/haserl-lua
$_ver
]
;
then
mkdir
-p
"
$subpkgdir
"
/usr/bin
mv
"
$pkgdir
"
/usr/bin/haserl-lua
$_ver
"
$subpkgdir
"
/usr/bin/
||
return
1
fi
}
for
_i
in
$_luaversions
;
do
eval
"split_
${
_i
/./_
}
() { _split
$_i
; }"
done
md5sums
=
"a9decddb508944d56f71dd2f821e2ec5 haserl-0.9.33.tar.gz"
sha256sums
=
"9a65b14dc721643fc5b85c79117cb6d824bd3683b246744137bb5d978df7621b haserl-0.9.33.tar.gz"
sha512sums
=
"8a285f43daee95a9dc8bbda1166323ab65ccad16ec13e61efaea0fbf88b1920d1af3e7efe7aade0025c8fd1368dcb5262b63f4848ab2fb7b0976ba8751d03886 haserl-0.9.33.tar.gz"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment