Skip to content
Snippets Groups Projects
Forked from alpine / aports
180183 commits behind the upstream repository.
  • Jakub Jirutka's avatar
    92dfc369
    testing/clsync: build only for x86 and x86_64 · 92dfc369
    Jakub Jirutka authored
    Build failed on armhf and aarch64 with:
    
    In file included from privileged.c:64:0:
    privileged.c:88:34: error: '__NR_alarm' undeclared here (not in a function)
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:94:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(alarm),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:142:2: note: in expansion of macro 'FILTER_TABLE_NONPRIV'
      FILTER_TABLE_NONPRIV
      ^~~~~~~~~~~~~~~~~~~~
    privileged.c:88:34: error: '__NR_select' undeclared here (not in a function)
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:107:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(select),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:142:2: note: in expansion of macro 'FILTER_TABLE_NONPRIV'
      FILTER_TABLE_NONPRIV
      ^~~~~~~~~~~~~~~~~~~~
    privileged.c:88:34: error: '__NR_mmap' undeclared here (not in a function)
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:134:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(mmap),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:143:2: note: in expansion of macro 'FILTER_TABLE_ARCHDEPENDED'
      FILTER_TABLE_ARCHDEPENDED
      ^~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:88:34: error: initializer element is not constant
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:94:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(alarm),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:148:2: note: in expansion of macro 'FILTER_TABLE_NONPRIV'
      FILTER_TABLE_NONPRIV
      ^~~~~~~~~~~~~~~~~~~~
    privileged.c:88:34: note: (near initialization for 'filter_w_mprotect_table[5].k')
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:94:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(alarm),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:148:2: note: in expansion of macro 'FILTER_TABLE_NONPRIV'
      FILTER_TABLE_NONPRIV
      ^~~~~~~~~~~~~~~~~~~~
    privileged.c:88:34: error: initializer element is not constant
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:107:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(select),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:148:2: note: in expansion of macro 'FILTER_TABLE_NONPRIV'
      FILTER_TABLE_NONPRIV
      ^~~~~~~~~~~~~~~~~~~~
    privileged.c:88:34: note: (near initialization for 'filter_w_mprotect_table[31].k')
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:107:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(select),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:148:2: note: in expansion of macro 'FILTER_TABLE_NONPRIV'
      FILTER_TABLE_NONPRIV
      ^~~~~~~~~~~~~~~~~~~~
    privileged.c:88:34: error: initializer element is not constant
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:134:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(mmap),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:149:2: note: in expansion of macro 'FILTER_TABLE_ARCHDEPENDED'
      FILTER_TABLE_ARCHDEPENDED
      ^~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:88:34: note: (near initialization for 'filter_w_mprotect_table[59].k')
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:134:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(mmap),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:149:2: note: in expansion of macro 'FILTER_TABLE_ARCHDEPENDED'
      FILTER_TABLE_ARCHDEPENDED
      ^~~~~~~~~~~~~~~~~~~~~~~~~
    92dfc369
    History
    testing/clsync: build only for x86 and x86_64
    Jakub Jirutka authored
    Build failed on armhf and aarch64 with:
    
    In file included from privileged.c:64:0:
    privileged.c:88:34: error: '__NR_alarm' undeclared here (not in a function)
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:94:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(alarm),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:142:2: note: in expansion of macro 'FILTER_TABLE_NONPRIV'
      FILTER_TABLE_NONPRIV
      ^~~~~~~~~~~~~~~~~~~~
    privileged.c:88:34: error: '__NR_select' undeclared here (not in a function)
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:107:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(select),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:142:2: note: in expansion of macro 'FILTER_TABLE_NONPRIV'
      FILTER_TABLE_NONPRIV
      ^~~~~~~~~~~~~~~~~~~~
    privileged.c:88:34: error: '__NR_mmap' undeclared here (not in a function)
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:134:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(mmap),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:143:2: note: in expansion of macro 'FILTER_TABLE_ARCHDEPENDED'
      FILTER_TABLE_ARCHDEPENDED
      ^~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:88:34: error: initializer element is not constant
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:94:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(alarm),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:148:2: note: in expansion of macro 'FILTER_TABLE_NONPRIV'
      FILTER_TABLE_NONPRIV
      ^~~~~~~~~~~~~~~~~~~~
    privileged.c:88:34: note: (near initialization for 'filter_w_mprotect_table[5].k')
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:94:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(alarm),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:148:2: note: in expansion of macro 'FILTER_TABLE_NONPRIV'
      FILTER_TABLE_NONPRIV
      ^~~~~~~~~~~~~~~~~~~~
    privileged.c:88:34: error: initializer element is not constant
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:107:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(select),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:148:2: note: in expansion of macro 'FILTER_TABLE_NONPRIV'
      FILTER_TABLE_NONPRIV
      ^~~~~~~~~~~~~~~~~~~~
    privileged.c:88:34: note: (near initialization for 'filter_w_mprotect_table[31].k')
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:107:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(select),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:148:2: note: in expansion of macro 'FILTER_TABLE_NONPRIV'
      FILTER_TABLE_NONPRIV
      ^~~~~~~~~~~~~~~~~~~~
    privileged.c:88:34: error: initializer element is not constant
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:134:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(mmap),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:149:2: note: in expansion of macro 'FILTER_TABLE_ARCHDEPENDED'
      FILTER_TABLE_ARCHDEPENDED
      ^~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:88:34: note: (near initialization for 'filter_w_mprotect_table[59].k')
      BPF_JUMP(BPF_JMP+BPF_JEQ+BPF_K, __NR_##syscall, 0, 1), \
                                      ^
    privileged.c:134:2: note: in expansion of macro 'SECCOMP_ALLOW_ACCUM_SYSCALL'
      SECCOMP_ALLOW_ACCUM_SYSCALL(mmap),    \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~
    privileged.c:149:2: note: in expansion of macro 'FILTER_TABLE_ARCHDEPENDED'
      FILTER_TABLE_ARCHDEPENDED
      ^~~~~~~~~~~~~~~~~~~~~~~~~
APKBUILD 2.00 KiB