Forked from
alpine / aports
178611 commits behind the upstream repository.
-
Carlo Landmeter authored
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Carlo Landmeter authoredThis moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
APKBUILD 1.12 KiB
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=eet
pkgver=1.7.9
pkgrel=0
pkgdesc="Enlightenment's file chunk reading/writing library"
url="http://trac.enlightenment.org/e/wiki/Eet"
arch="all"
license="BSD"
depends=
depends_dev="eina-dev openssl-dev zlib-dev libjpeg-turbo-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev"
source="http://download.enlightenment.org/releases/eet-$pkgver.tar.gz"
_builddir="$srcdir"/eet-$pkgver
prepare() {
local i
cd "$_builddir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
}
build() {
cd "$_builddir"
./configure --prefix=/usr \
|| return 1
make || return 1
}
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}
md5sums="225eadf514465be321a44a003d687a55 eet-1.7.9.tar.gz"
sha256sums="3345e0889bbc29536dbe0f6236ed1ae6a9d685b8e39877d5404fa6217bd12ec6 eet-1.7.9.tar.gz"
sha512sums="5afdba1b9382a91786233d460de6d7e423307668fd8023a6e611ceb55c0bab1041f6dfa625004e00105c00c77d99f1a3c04a58868d2f3c83b5df17bc32ee660d eet-1.7.9.tar.gz"