Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
knuxify
aports
Commits
cec73eed
Commit
cec73eed
authored
7 years ago
by
Ariadne Conill
Browse files
Options
Downloads
Patches
Plain Diff
main/bash: fix applying vendor patches
parent
46285f60
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
main/bash/APKBUILD
+19
-3
19 additions, 3 deletions
main/bash/APKBUILD
with
19 additions
and
3 deletions
main/bash/APKBUILD
+
19
−
3
View file @
cec73eed
...
@@ -6,7 +6,7 @@ pkgver=4.4.12
...
@@ -6,7 +6,7 @@ pkgver=4.4.12
_patchlevel
=
${
pkgver
##*.
}
_patchlevel
=
${
pkgver
##*.
}
_myver
=
${
pkgver
%.*
}
_myver
=
${
pkgver
%.*
}
_patchbase
=
${
_myver
/./
}
_patchbase
=
${
_myver
/./
}
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"The GNU Bourne Again shell"
pkgdesc
=
"The GNU Bourne Again shell"
url
=
"http://www.gnu.org/software/bash/bash.html"
url
=
"http://www.gnu.org/software/bash/bash.html"
arch
=
"all"
arch
=
"all"
...
@@ -30,13 +30,29 @@ while [ $_i -le $_patchlevel ]; do
...
@@ -30,13 +30,29 @@ while [ $_i -le $_patchlevel ]; do
done
done
# secfixes:
# secfixes:
# 4.4.12-r
0
:
# 4.4.12-r
1
:
# -
C
CVE-2016-0634
# - CVE-2016-0634
builddir
=
"
$srcdir
"
/
$pkgname
-
$_myver
builddir
=
"
$srcdir
"
/
$pkgname
-
$_myver
prepare
()
{
prepare
()
{
cd
"
$builddir
"
cd
"
$builddir
"
# NOTE: This section is for applying the vendor patches, which are required to fix
# security holes. `default_prepare` does *not* apply vendor patches in the format
# shipped with bash. We also need to make sure vendor patches are applied before
# our own.
# If you disagree, please request an experimental rebuild with bash as /bin/sh,
# before removing this section.
for
p
in
$source
;
do
case
$p
in
*
/bash[0-9][0-9]-[0-9]
*
)
msg
"
$p
(vendor)"
patch
-p0
-i
"
$srcdir
"
/
${
p
##*/
}
||
return
1
;;
esac
done
default_prepare
default_prepare
update_config_sub
update_config_sub
}
}
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment