Skip to content
Snippets Groups Projects
Commit abea57f8 authored by Sören Tempel's avatar Sören Tempel
Browse files

community/notmuch: enable testsuite partially

Also modernize the APKBUILD
parent 2c6790a8
No related branches found
No related tags found
No related merge requests found
...@@ -2,19 +2,22 @@ ...@@ -2,19 +2,22 @@
# Maintainer: Stefan Wagner <stw@bit-strickerei.de> # Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=notmuch pkgname=notmuch
pkgver=0.24.1 pkgver=0.24.1
pkgrel=0 pkgrel=1
pkgdesc="E-Mail index, search and tagging" pkgdesc="E-Mail index, search and tagging"
url="https://notmuchmail.org/" url="https://notmuchmail.org/"
arch="all" arch="all"
license="GPL3" license="GPL3"
makedepends="gzip xapian-core-dev gmime-dev talloc-dev makedepends="gzip xapian-core-dev gmime-dev talloc-dev
py-sphinx py-requests bash-completion" py-sphinx py-requests bash-completion"
checkdepends="sed coreutils diffutils bash tar gdb
gnupg mdocml grep"
subpackages=" subpackages="
$pkgname-dev $pkgname-dev
$pkgname-doc $pkgname-doc
$pkgname-zsh-completion:zshcomp:noarch $pkgname-zsh-completion:zshcomp:noarch
$pkgname-bash-completion:bashcomp:noarch" $pkgname-bash-completion:bashcomp:noarch"
source="https://notmuchmail.org/releases/$pkgname-$pkgver.tar.gz" source="https://notmuchmail.org/releases/$pkgname-$pkgver.tar.gz
fix-tests.patch"
builddir="$srcdir/$pkgname-$pkgver" builddir="$srcdir/$pkgname-$pkgver"
build() { build() {
...@@ -27,14 +30,38 @@ build() { ...@@ -27,14 +30,38 @@ build() {
--mandir=/usr/share/man \ --mandir=/usr/share/man \
--localstatedir=/var \ --localstatedir=/var \
--bashcompletiondir=/usr/share/bash-completion/completions \ --bashcompletiondir=/usr/share/bash-completion/completions \
--zshcompletiondir=/usr/share/zsh/site-functions \ --zshcompletiondir=/usr/share/zsh/site-functions
|| return 1 make PREFIX=/usr DESTDIR="$pkgdir"
make PREFIX=/usr DESTDIR="$pkgdir" || return 1
} }
package() { package() {
make PREFIX=/usr DESTDIR="$pkgdir" \ make PREFIX=/usr DESTDIR="$pkgdir" \
-C "$builddir" install || return 1 -C "$builddir" install
}
check() {
cd "$builddir"/test
make test-binaries
local test=
for test in T*.sh; do
name="$(basename "$test")"
case "${name%%.*}" in
# Requires dtach ↦ doesn't work on the builders
*emacs*) continue ;;
# FIXME xapian fuckup
T050-new|T060-count|T150-tagging) continue ;;
# FIXME gdb fuckup
T070-insert) continue ;;
# FIXME uknown fuckup
T170-sexp|T350-crypto|T355-smime) continue ;;
esac
./${test}
done
} }
bashcomp() { bashcomp() {
...@@ -44,7 +71,7 @@ bashcomp() { ...@@ -44,7 +71,7 @@ bashcomp() {
mkdir -p "$subpkgdir"/usr/share/bash-completion/completions/ mkdir -p "$subpkgdir"/usr/share/bash-completion/completions/
mv "$pkgdir"/usr/share/bash-completion/completions/$pkgname \ mv "$pkgdir"/usr/share/bash-completion/completions/$pkgname \
"$subpkgdir"/usr/share/bash-completion/completions/ || return 1 "$subpkgdir"/usr/share/bash-completion/completions/
} }
zshcomp() { zshcomp() {
...@@ -54,7 +81,8 @@ zshcomp() { ...@@ -54,7 +81,8 @@ zshcomp() {
mkdir -p "$subpkgdir"/usr/share/zsh/site-functions/ mkdir -p "$subpkgdir"/usr/share/zsh/site-functions/
mv "$pkgdir"/usr/share/zsh/site-functions/_${pkgname} \ mv "$pkgdir"/usr/share/zsh/site-functions/_${pkgname} \
"$subpkgdir"/usr/share/zsh/site-functions/ || return 1 "$subpkgdir"/usr/share/zsh/site-functions/
} }
sha512sums="e2014380de68de3e1a3fd3058a441c6771a92bfffe07c0bd2b374802dd8b2539eddbbb91074738f58f48452a936f2f9427fadca825a165c61a27fe0c3e1fe7fc notmuch-0.24.1.tar.gz" sha512sums="e2014380de68de3e1a3fd3058a441c6771a92bfffe07c0bd2b374802dd8b2539eddbbb91074738f58f48452a936f2f9427fadca825a165c61a27fe0c3e1fe7fc notmuch-0.24.1.tar.gz
586b046d12c73c2f53451f3dfcfe1917aaba5557709ecf41ec8a4a3b5f174b8f1b641141d3059d67c67dad97a760e54285e8a683e3a2f0d17d4c0df6bc342a58 fix-tests.patch"
diff -upr notmuch-0.24.1.orig/test/T030-config.sh notmuch-0.24.1/test/T030-config.sh
--- notmuch-0.24.1.orig/test/T030-config.sh 2017-08-17 19:19:19.245017863 +0200
+++ notmuch-0.24.1/test/T030-config.sh 2017-08-17 19:19:35.725123923 +0200
@@ -45,8 +45,8 @@ test_expect_equal "$(notmuch config get
test_begin_subtest "List all items"
notmuch config list 2>&1 | notmuch_config_sanitize > OUTPUT
cat <<EOF > EXPECTED
-Error opening database at MAIL_DIR/.notmuch: No such file or directory
database.path=MAIL_DIR
+Error opening database at MAIL_DIR/.notmuch: No such file or directory
user.name=Notmuch Test Suite
user.primary_email=test_suite@notmuchmail.org
user.other_email=test_suite_other@notmuchmail.org;test_suite@otherdomain.org
diff -upr notmuch-0.24.1.orig/test/T650-regexp-query.sh notmuch-0.24.1/test/T650-regexp-query.sh
--- notmuch-0.24.1.orig/test/T650-regexp-query.sh 2017-08-17 20:27:35.577369368 +0200
+++ notmuch-0.24.1/test/T650-regexp-query.sh 2017-08-17 20:28:06.570896484 +0200
@@ -99,7 +99,7 @@ test_begin_subtest "regexp error reporti
notmuch search 'from:/unbalanced[/' 1>OUTPUT 2>&1
cat <<EOF > EXPECTED
notmuch search: A Xapian exception occurred
-A Xapian exception occurred parsing query: Invalid regular expression
+A Xapian exception occurred parsing query: Missing ']'
Query string was: from:/unbalanced[/
EOF
test_expect_equal_file EXPECTED OUTPUT
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment