Skip to content
Snippets Groups Projects
Commit a8d7a02b authored by Milan P. Stanić's avatar Milan P. Stanić
Browse files

testing/setserial: new aport

http://setserial.sourceforge.net/
tool for change various attributes of a serial device
parent babd636c
No related merge requests found
# Contributor: Milan P. Stanić <mps@arvanta.net>
# Maintainer: Milan P. Stanić <mps@arvanta.net>
pkgname="setserial"
pkgver=2.17
pkgrel=0
pkgdesc="tool for change various attributes of a serial device"
url="http://setserial.sourceforge.net/"
arch="all"
license="GPL-2.0-only"
makedepends="groff"
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/sourceforge/setserial/setserial-$pkgver.tar.gz
ioctls.patch
setserial.patch"
build() {
./configure \
--prefix=/usr \
--mandir=/usr/share/man \
--bindir=/bin
make
}
package() {
install -d $pkgdir/bin
install -d $pkgdir/usr/share/man/man8
make DESTDIR=$pkgdir install
}
sha512sums="27b4918d303302dfdbca2f8c4fe500685068cfbf3de70b4907bac5a9cdb2e643656c1d821e714c08723abcfbaf99129866002117450bef731a0a09cd38138645 setserial-2.17.tar.gz
17e4ec065d5f51c80f3358c749b7c6b0257b380f4b81cb9af14312202098b045a0ea833e88a663d3b090f19a09430ee7c96e7046b794166263617cb859b1b3d9 ioctls.patch
4c5f5bddb3f66aac51c1550d85726930221e995dd695f628bec37cf2f05c1db0c7b1c59ba745c32a9d8a91374a4491479f7786a58cfd0096157b2b22c764ac7f setserial.patch"
--- a/setserial.c 2000-01-27 16:40:52.000000000 +0100
+++ b/setserial.c 2014-03-26 18:53:04.720749160 +0100
@@ -15,10 +15,8 @@
#include <termios.h>
#include <string.h>
#include <errno.h>
-
-#ifdef HAVE_ASM_IOCTLS_H
#include <asm/ioctls.h>
-#endif
+
#ifdef HAVE_LINUX_HAYESESP_H
#include <linux/hayesesp.h>
#endif
diff -ur setserial-2.17/Makefile.in setserial-2.17-new/Makefile.in
--- setserial-2.17/Makefile.in 2000-01-27 16:39:07.000000000 +0100
+++ setserial-2.17-new/Makefile.in 2005-03-09 20:53:31.000000000 +0100
@@ -17,6 +17,11 @@
INCS = -I.
TAR = tar
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+bindir=@bindir@
+mandir=@mandir@
+
all: setserial setserial.cat
setserial: setserial.c
@@ -26,9 +31,9 @@
nroff -man setserial.8 > setserial.cat
install: setserial setserial.8
- $(INSTALL_PROGRAM) setserial $(DESTDIR)/bin
- $(STRIP) $(DESTDIR)/bin/setserial
- $(INSTALL_DATA) setserial.8 $(DESTDIR)/usr/man/man8
+ $(INSTALL_PROGRAM) setserial $(DESTDIR)$(bindir)
+ $(STRIP) $(DESTDIR)$(bindir)/setserial
+ $(INSTALL_DATA) setserial.8 $(DESTDIR)$(mandir)/man8
clean:
$(RM) setserial setserial.o setserial.cat *~
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment