Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
knuxify
aports
Commits
407d9671
Commit
407d9671
authored
7 years ago
by
A. Klitzing
Committed by
Natanael Copa
7 years ago
Browse files
Options
Downloads
Patches
Plain Diff
testing/rippled: new aport
parent
f48eea92
Loading
Loading
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/rippled/APKBUILD
+38
-0
38 additions, 0 deletions
testing/rippled/APKBUILD
testing/rippled/musl-fixes.patch
+100
-0
100 additions, 0 deletions
testing/rippled/musl-fixes.patch
with
138 additions
and
0 deletions
testing/rippled/APKBUILD
0 → 100644
+
38
−
0
View file @
407d9671
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname
=
rippled
pkgver
=
0.70.1
pkgrel
=
0
pkgdesc
=
"Blockchain daemon implementing the Ripple Consensus Ledger"
url
=
"https://ripple.com/"
arch
=
"all"
license
=
"ISC"
makedepends
=
"cmake libressl-dev boost-dev protobuf-dev"
subpackages
=
"
$pkgname
-doc"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/ripple/
$pkgname
/archive/
$pkgver
.tar.gz
musl-fixes.patch
"
builddir
=
"
$srcdir
/"
$pkgname
-
$pkgver
build
()
{
cd
"
$builddir
"
mkdir
build
&&
cd
build
cmake ..
-DCMAKE_INSTALL_PREFIX
=
/usr
-DCMAKE_BUILD_TYPE
=
release
make
}
check
()
{
cd
"
$builddir
"
./build/rippled
--unittest
}
package
()
{
cd
"
$builddir
"
install
-D
-m644
LICENSE
"
${
pkgdir
}
/usr/share/licenses/
$pkgname
/LICENSE"
install
-D
build/rippled
"
${
pkgdir
}
/usr/bin/rippled"
install
-D
-m644
doc/rippled-example.cfg
"
${
pkgdir
}
/etc/
$pkgname
/rippled.cfg"
install
-D
-m644
doc/validators-example.txt
"
${
pkgdir
}
/etc/
$pkgname
/validators.txt"
}
sha512sums
=
"783e5abc1d8f1d0fa5ea4abbc9ab1211270a52829fa88aa8d2fdd68c045188186ab732c73326bd2a9ed216a5b23480c5dc0799df61f1df5a3475fe53f2da455a rippled-0.70.1.tar.gz
a26b01f8bf541471f96f3865b99923b267611ece093f8cbc4f35f87002c403b6e558e5ac15cc7599e9a5c1486f3070a4f61a880a2a3b874fc2dab5d8a6d8e82e musl-fixes.patch"
This diff is collapsed.
Click to expand it.
testing/rippled/musl-fixes.patch
0 → 100644
+
100
−
0
View file @
407d9671
diff --git a/src/ripple/basics/StringUtilities.h b/src/ripple/basics/StringUtilities.h
index f4cc83f..d2aa4bd 100644
--- a/src/ripple/basics/StringUtilities.h
+++ b/src/ripple/basics/StringUtilities.h
@@ -26,6 +26,7 @@
#include <boost/format.hpp>
#include <sstream>
#include <string>
+#include <endian.h>
namespace ripple {
diff --git a/src/ripple/basics/base_uint.h b/src/ripple/basics/base_uint.h
index cfa6867..1ce4ec3 100644
--- a/src/ripple/basics/base_uint.h
+++ b/src/ripple/basics/base_uint.h
@@ -31,6 +31,7 @@
#include <ripple/basics/hardened_hash.h>
#include <ripple/beast/utility/Zero.h>
#include <boost/functional/hash.hpp>
+#include <endian.h>
#include <functional>
#include <type_traits>
diff --git a/src/rocksdb2/port/port_posix.cc b/src/rocksdb2/port/port_posix.cc
index c5ea439..b968571 100644
--- a/src/rocksdb2/port/port_posix.cc
+++ b/src/rocksdb2/port/port_posix.cc
@@ -29,7 +29,7 @@
static int PthreadCall(const char* label, int result) {
}
Mutex::Mutex(bool adaptive) {
-#ifdef OS_LINUX
+#ifdef ROCKSDB_PTHREAD_ADAPTIVE_MUTEX
if (!adaptive) {
PthreadCall("init mutex", pthread_mutex_init(&mu_, nullptr));
} else {
@@ -42,9 +42,9 @@
Mutex::Mutex(bool adaptive) {
PthreadCall("destroy mutex attr",
pthread_mutexattr_destroy(&mutex_attr));
}
-#else // ignore adaptive for non-linux platform
+#else
PthreadCall("init mutex", pthread_mutex_init(&mu_, nullptr));
-#endif // OS_LINUX
+#endif // ROCKSDB_PTHREAD_ADAPTIVE_MUTEX
}
Mutex::~Mutex() { PthreadCall("destroy mutex", pthread_mutex_destroy(&mu_)); }
diff --git a/src/rocksdb2/port/stack_trace.cc b/src/rocksdb2/port/stack_trace.cc
index 76866e6..542100c 100644
--- a/src/rocksdb2/port/stack_trace.cc
+++ b/src/rocksdb2/port/stack_trace.cc
@@ -8,7 +8,7 @@
namespace rocksdb {
namespace port {
-#if defined(ROCKSDB_LITE) || !(defined(OS_LINUX) || defined(OS_MACOSX))
+#if defined(ROCKSDB_LITE) || !(defined(__GLIBC__) || defined(OS_MACOSX))
// noop
diff --git a/src/rocksdb2/util/log_buffer.h b/src/rocksdb2/util/log_buffer.h
index 2a24bf8..ddaaa2c 100644
--- a/src/rocksdb2/util/log_buffer.h
+++ b/src/rocksdb2/util/log_buffer.h
@@ -9,6 +9,7 @@
#include "util/arena.h"
#include "util/autovector.h"
#include <ctime>
+#include <sys/time.h>
namespace rocksdb {
diff --git a/src/ripple/beast/core/SystemStats.cpp b/src/ripple/beast/core/SystemStats.cpp
index 74caa79..b238979 100644
--- a/src/ripple/beast/core/SystemStats.cpp
+++ b/src/ripple/beast/core/SystemStats.cpp
@@ -50,7 +50,7 @@
getStackBacktrace()
{
std::vector <std::string> result;
-#if BEAST_ANDROID || BEAST_MINGW || BEAST_BSD
+#if BEAST_ANDROID || BEAST_MINGW || BEAST_BSD || 1
assert(false); // sorry, not implemented yet!
#elif BEAST_WINDOWS
diff --git a/src/ripple/beast/core/core.unity.cpp b/src/ripple/beast/core/core.unity.cpp
index 83dd1df..b374634 100644
--- a/src/ripple/beast/core/core.unity.cpp
+++ b/src/ripple/beast/core/core.unity.cpp
@@ -113,7 +113,7 @@
#include <net/if.h>
#include <sys/ioctl.h>
- #if ! BEAST_ANDROID && ! BEAST_BSD
+ #if ! BEAST_ANDROID && ! BEAST_BSD && 0
#include <execinfo.h>
#endif
#endif
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment