Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
knuxify
aports
Commits
2ba26d73
Commit
2ba26d73
authored
5 years ago
by
Leo
Browse files
Options
Downloads
Patches
Plain Diff
main/dhcp: upgrade to 4.4.2
parent
784c66d4
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
main/dhcp/APKBUILD
+17
-23
17 additions, 23 deletions
main/dhcp/APKBUILD
with
17 additions
and
23 deletions
main/dhcp/APKBUILD
+
17
−
23
View file @
2ba26d73
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname
=
dhcp
pkgname
=
dhcp
pkgver
=
"
4.4.
1"
pkgver
=
4.4.
2
_realver
=
${
pkgver
/_p/-P
}
_realver
=
${
pkgver
/_p/-P
}
pkgrel
=
7
pkgrel
=
0
pkgdesc
=
"ISC Dynamic Host Configuration Protocol (DHCP)"
pkgdesc
=
"ISC Dynamic Host Configuration Protocol (DHCP)"
url
=
"https://www.isc.org/"
url
=
"https://www.isc.org/"
arch
=
"all"
arch
=
"all"
license
=
"MPL-2.0"
license
=
"MPL-2.0"
depends
=
""
_depends_server_ldap
=
"!
$pkgname
-server-vanilla
$pkgname
"
depends_server_ldap
=
"!
$pkgname
-server-vanilla
$pkgname
"
_depends_server_vanilla
=
"!
$pkgname
-server-ldap
$pkgname
"
depends_server_vanilla
=
"!
$pkgname
-server-ldap
$pkgname
"
depends_static
=
"
$pkgname
-dev"
depends_static
=
"
$pkgname
-dev"
# busybox utils are not sufficient
# busybox utils are not sufficient
depends_dhclient
=
"coreutils iproute2 run-parts"
_
depends_dhclient
=
"coreutils iproute2 run-parts"
depends_dhcrelay
=
""
# do not inherit depends from $pkgname
_
depends_dhcrelay
=
""
# do not inherit depends from $pkgname
pkgusers
=
"dhcp"
pkgusers
=
"dhcp"
pkggroups
=
"dhcp"
pkggroups
=
"dhcp"
makedepends
=
"krb5-dev linux-headers openldap-dev perl"
makedepends
=
"krb5-dev linux-headers openldap-dev perl"
...
@@ -42,8 +41,7 @@ source="
...
@@ -42,8 +41,7 @@ source="
dhcpd.initd
dhcpd.initd
"
"
builddir
=
"
$srcdir
/
$pkgname
-
$_realver
"
makedepends
=
"
$makedepends
$_depends_dhclient
$_depends_server_ldap
$_depends_server_vanilla
"
makedepends
=
"
$makedepends
$depends_dhclient
$depends_server_ldap
$depends_server_vanilla
"
# secfixes:
# secfixes:
# 4.4.1-r0:
# 4.4.1-r0:
...
@@ -81,7 +79,6 @@ _configure() {
...
@@ -81,7 +79,6 @@ _configure() {
}
}
build
()
{
build
()
{
cd
"
$builddir
"
cp
-a
"
$builddir
"
"
$builddir
-ldap"
cp
-a
"
$builddir
"
"
$builddir
-ldap"
_configure
_configure
...
@@ -96,7 +93,6 @@ build() {
...
@@ -96,7 +93,6 @@ build() {
}
}
check
()
{
check
()
{
cd
"
$builddir
"
make check
make check
cd
"
$builddir
-ldap"
cd
"
$builddir
-ldap"
...
@@ -104,8 +100,6 @@ check() {
...
@@ -104,8 +100,6 @@ check() {
}
}
package
()
{
package
()
{
cd
"
$builddir
"
make
DESTDIR
=
"
$pkgdir
"
install
make
DESTDIR
=
"
$pkgdir
"
install
#install -m751 -D "$builddir"/client/scripts/linux "$pkgdir"/sbin/dhclient-script
#install -m751 -D "$builddir"/client/scripts/linux "$pkgdir"/sbin/dhclient-script
...
@@ -126,7 +120,7 @@ openrc() {
...
@@ -126,7 +120,7 @@ openrc() {
server_ldap
()
{
server_ldap
()
{
pkgdesc
=
"ISC dhcpd server with LDAP support"
pkgdesc
=
"ISC dhcpd server with LDAP support"
depends
=
"
$depends_server_ldap
"
depends
=
"
$
_
depends_server_ldap
"
provides
=
"dhcp-server"
provides
=
"dhcp-server"
provider_priority
=
100
provider_priority
=
100
...
@@ -136,7 +130,7 @@ server_ldap() {
...
@@ -136,7 +130,7 @@ server_ldap() {
server_vanilla
()
{
server_vanilla
()
{
pkgdesc
=
"ISC dhcpd server"
pkgdesc
=
"ISC dhcpd server"
depends
=
"
$depends_server_vanilla
"
depends
=
"
$
_
depends_server_vanilla
"
install_if
=
"
$pkgname
=
$pkgver
-r
$pkgrel
"
install_if
=
"
$pkgname
=
$pkgver
-r
$pkgrel
"
provides
=
"dhcp-server"
provides
=
"dhcp-server"
provider_priority
=
200
provider_priority
=
200
...
@@ -148,7 +142,7 @@ server_vanilla() {
...
@@ -148,7 +142,7 @@ server_vanilla() {
dhclient
()
{
dhclient
()
{
pkgdesc
=
"ISC dhcp client"
pkgdesc
=
"ISC dhcp client"
depends
=
"
$depends_dhclient
"
depends
=
"
$
_
depends_dhclient
"
install
-d
-o
dhcp
-g
dhcp
"
$subpkgdir
"
/var/lib/dhcp
install
-d
-o
dhcp
-g
dhcp
"
$subpkgdir
"
/var/lib/dhcp
install
-d
-o
dhcp
-g
dhcp
"
$subpkgdir
"
/run/dhcp
install
-d
-o
dhcp
-g
dhcp
"
$subpkgdir
"
/run/dhcp
...
@@ -163,7 +157,7 @@ dhclient() {
...
@@ -163,7 +157,7 @@ dhclient() {
dhcrelay
()
{
dhcrelay
()
{
pkgdesc
=
"ISC dhcp relay server"
pkgdesc
=
"ISC dhcp relay server"
depends
=
"
$depends_dhcrelay
"
depends
=
"
$
_
depends_dhcrelay
"
replaces
=
"dhcp"
replaces
=
"dhcp"
install
-d
"
$subpkgdir
"
/run/dhcp
\
install
-d
"
$subpkgdir
"
/run/dhcp
\
...
@@ -177,13 +171,13 @@ static() {
...
@@ -177,13 +171,13 @@ static() {
}
}
gpg_signature_extensions
=
"sha512.asc"
#
gpg_signature_extensions="sha512.asc"
gpgfingerprints
=
"
#
gpgfingerprints="
good:AE3F AC79 6711 EC59 FC00 7AA4 74BB 6B9A 4CBB 3D38
#
good:AE3F AC79 6711 EC59 FC00 7AA4 74BB 6B9A 4CBB 3D38
BE0E 9748 B718 253A 28BB 89FF F1B1 1BF0 5CF0 2E57
#
BE0E 9748 B718 253A 28BB 89FF F1B1 1BF0 5CF0 2E57
"
#
"
sha512sums
=
"
684ae349f224918c9f8cec7bd6c55cd0b83ad2b5827375b2876ca088eb05b7ff1364e50f6dc24f2485c610d9be94d4ba3020f60a0fa0ef63962349d191b887e7
dhcp-4.4.
1
.tar.gz
sha512sums
=
"
c3dee2cf6e4b43d519d4bc89e9b8b12a6e3747d8c4edc0f83d4a88355a483b91a5f7d2353a3c0a2f37f88704fd2f64478ac5161ca72b10c42cebcb92907afa40
dhcp-4.4.
2
.tar.gz
17e2b9588ee5d1bd9acb9c2e30f7a28308d29c9e797c2be14c1feff52e6e231ce8a94535f18badff1342aff4ae4003aab986e0f0473f0cd280292fdab044b148 01-dhclient-script-fix-bare-ip.patch
17e2b9588ee5d1bd9acb9c2e30f7a28308d29c9e797c2be14c1feff52e6e231ce8a94535f18badff1342aff4ae4003aab986e0f0473f0cd280292fdab044b148 01-dhclient-script-fix-bare-ip.patch
a70e4a7e80ee65c8ced6b61db80f7ccd0f35015b5cccf2e7c51705ae129230aa49ba9926bb88f7418018e7a112c2a40451f24b88e04464b590ff20091e8d8709 02-dhclient-script-remove-bashisms.patch
a70e4a7e80ee65c8ced6b61db80f7ccd0f35015b5cccf2e7c51705ae129230aa49ba9926bb88f7418018e7a112c2a40451f24b88e04464b590ff20091e8d8709 02-dhclient-script-remove-bashisms.patch
d5697a56fbbff25199962608986e7ffb533ed4afd3e344e3c79d2010dda73cc0b088f06c454e9f0c69eb054e09a374455fa71d3f73306e0c98fa76df4dd321b7 dhcp-3.0-fix-perms.patch
d5697a56fbbff25199962608986e7ffb533ed4afd3e344e3c79d2010dda73cc0b088f06c454e9f0c69eb054e09a374455fa71d3f73306e0c98fa76df4dd321b7 dhcp-3.0-fix-perms.patch
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment