Skip to content
Snippets Groups Projects
Forked from alpine / aports
161456 commits behind the upstream repository.
APKBUILD 913 B
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=asio
pkgver=1.12.1
pkgrel=0
pkgdesc="Cross-platform C++ library for network programming"
url="https://think-async.com"
arch="all"
license="BSL-1.0"
depends=""
depends_dev="boost-dev libressl-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev"
source="http://downloads.sourceforge.net/sourceforge/asio/$pkgname-$pkgver.tar.bz2"

builddir="$srcdir/$pkgname-$pkgver"

prepare() {
	default_prepare
	update_config_sub
}

build() {
	cd "$builddir"
	./configure \
		--build=$CBUILD \
		--host=$CHOST \
		--prefix=/usr \
		--mandir=/usr/share/man \
		--enable-shared
	make
}

check() {
	cd "$builddir"
	make check
}

package() {
	cd "$builddir"
	make DESTDIR="$pkgdir" install
}

sha512sums="a994e1ee9a252d9f8cc2ada0915a9866eeebdd2b1d9a8fd50fa8db06d5ee6277f44a0f83c79f46f939adca43e02373ffee78ff6b1d6ae1798dcb1cd6d56dc568  asio-1.12.1.tar.bz2"