Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Model registry
Operate
Terraform modules
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Gil Pedersen
aports
Commits
1f0ef6c6
Commit
1f0ef6c6
authored
3 months ago
by
Gil Pedersen
Browse files
Options
Downloads
Patches
Plain Diff
testing/zvbi: new aport
parent
f38a61bf
Loading
Loading
No related merge requests found
Pipeline
#278650
passed
3 months ago
Stage: verify
Pipeline: aports
#278656
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/zvbi/APKBUILD
+50
-0
50 additions, 0 deletions
testing/zvbi/APKBUILD
testing/zvbi/fix-strptime-input.patch
+12
-0
12 additions, 0 deletions
testing/zvbi/fix-strptime-input.patch
with
62 additions
and
0 deletions
testing/zvbi/APKBUILD
0 → 100644
+
50
−
0
View file @
1f0ef6c6
# Contributor: Gil Pedersen <gpdev@gpost.dk>
# Maintainer: Gil Pedersen <gpdev@gpost.dk>
pkgname
=
zvbi
pkgver
=
0.2.43
pkgrel
=
0
pkgdesc
=
"VBI capture and decoding tools"
url
=
"https://github.com/zapping-vbi/zvbi"
arch
=
"all"
license
=
"GPL-2.0-or-later"
makedepends
=
"automake autoconf libtool gettext-dev linux-headers libpng-dev"
checkdepends
=
"tzdata"
subpackages
=
"lib
$pkgname
-static lib
$pkgname
-dev lib
$pkgname
-lang
$pkgname
-doc lib
$pkgname
:libs"
source
=
"
https://github.com/zapping-vbi/zvbi/archive/v
$pkgver
/zvbi-
$pkgver
.tar.gz
fix-strptime-input.patch
"
prepare
()
{
default_prepare
./autogen.sh
}
build
()
{
CPPFLAGS
=
"
$CPPFLAGS
-D__va_copy=va_copy"
\
./configure
\
--build
=
$CBUILD
\
--host
=
$CHOST
\
--prefix
=
/usr
\
--sysconfdir
=
/etc
\
--mandir
=
/usr/share/man
\
--localstatedir
=
/var
\
--disable-dependency-tracking
make
}
check
()
{
make check
}
package
()
{
make
DESTDIR
=
"
$pkgdir
"
install
install
-Dm644
COPYING
"
$pkgdir
"
/usr/share/licenses/
$pkgname
/COPYING.md
}
sha512sums
=
"
7216e6a3538e4b37d11dd45e5ebaf2b7c0c3b4ba4824e5854d508711f6a048fb9c3bb7b02262c0d91ef3019568ca1119b4b46043a23d1176edfcc78d48f70f48 zvbi-0.2.43.tar.gz
c7d4a79775c7ac7d402bb8b1ccdf04a10e818031d193791856542dc4ee110493f94c63c01792c87ce8119c9485db4581dac697366b48b63960a99c09117dee4c fix-strptime-input.patch
"
This diff is collapsed.
Click to expand it.
testing/zvbi/fix-strptime-input.patch
0 → 100644
+
12
−
0
View file @
1f0ef6c6
--- zvbi-0.2.43/examples/pdc2.c 2024-12-03 15:58:59.000000000 +0100
+++ zvbi-0.2.43-patched/examples/pdc2.c 2024-12-04 15:30:16.732859533 +0100
@@ -1166,6 +1166,9 @@
if (!isspace (*s))
goto invalid;
+ while (isspace (*s))
+ ++s;
+
memset (&tm, 0, sizeof (tm));
tm.tm_isdst = -1; /* unknown */
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment