Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Model registry
Operate
Terraform modules
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Ilya Kheifets
aports
Commits
85fce5ac
Commit
85fce5ac
authored
4 months ago
by
Natanael Copa
Browse files
Options
Downloads
Patches
Plain Diff
main/apk-tools: backport fix for apk cache download
ref:
apk-tools#11048
upstream commit:
apk-tools@f9bb33c8
parent
9fe970a1
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/apk-tools/APKBUILD
+3
-1
3 additions, 1 deletion
main/apk-tools/APKBUILD
main/apk-tools/db-fix-apk_cache_download.patch
+28
-0
28 additions, 0 deletions
main/apk-tools/db-fix-apk_cache_download.patch
with
31 additions
and
1 deletion
main/apk-tools/APKBUILD
+
3
−
1
View file @
85fce5ac
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
apk-tools
pkgname
=
apk-tools
pkgver
=
2.14.6
pkgver
=
2.14.6
pkgrel
=
1
pkgrel
=
2
pkgdesc
=
"Alpine Package Keeper - package manager for alpine"
pkgdesc
=
"Alpine Package Keeper - package manager for alpine"
arch
=
"all"
arch
=
"all"
url
=
"https://gitlab.alpinelinux.org/alpine/apk-tools"
url
=
"https://gitlab.alpinelinux.org/alpine/apk-tools"
...
@@ -28,6 +28,7 @@ if [ "$CBUILD" = "$CHOST" ]; then
...
@@ -28,6 +28,7 @@ if [ "$CBUILD" = "$CHOST" ]; then
depends
=
"
$depends
ca-certificates-bundle"
depends
=
"
$depends
ca-certificates-bundle"
fi
fi
source
=
"https://gitlab.alpinelinux.org/alpine/apk-tools/-/archive/v
$pkgver
/apk-tools-v
$pkgver
.tar.gz
source
=
"https://gitlab.alpinelinux.org/alpine/apk-tools/-/archive/v
$pkgver
/apk-tools-v
$pkgver
.tar.gz
db-fix-apk_cache_download.patch
_apk
_apk
"
"
builddir
=
"
$srcdir
/
$pkgname
-v
$pkgver
"
builddir
=
"
$srcdir
/
$pkgname
-v
$pkgver
"
...
@@ -94,5 +95,6 @@ luaapk() {
...
@@ -94,5 +95,6 @@ luaapk() {
sha512sums
=
"
sha512sums
=
"
5be32716fda98939845c50daae5b9e226c1758f4d43a9b9eb50d7e54e700ff2d300b0b8af672a1dd8dd172e704594d04dcb9c7c487a13362359120600234c97c apk-tools-v2.14.6.tar.gz
5be32716fda98939845c50daae5b9e226c1758f4d43a9b9eb50d7e54e700ff2d300b0b8af672a1dd8dd172e704594d04dcb9c7c487a13362359120600234c97c apk-tools-v2.14.6.tar.gz
e77c04d7e52a72329ffdfa72266485c0d2ebbfad4dd8c95d786e6d992cbcbcc3c13560b8e8c3853c832c256b48cd76d6d6750ba9bfe5289dac4f88c417c6d5fb db-fix-apk_cache_download.patch
92d5ee1edaae8e9bf32938e6b901e2a6f97530fcb6493060acfbb8883bf8bc825462f2e8ce6a6cfeba43acb4dd6d36acd33d060a4bce3907562e60c7cdb65e5f _apk
92d5ee1edaae8e9bf32938e6b901e2a6f97530fcb6493060acfbb8883bf8bc825462f2e8ce6a6cfeba43acb4dd6d36acd33d060a4bce3907562e60c7cdb65e5f _apk
"
"
This diff is collapsed.
Click to expand it.
main/apk-tools/db-fix-apk_cache_download.patch
0 → 100644
+
28
−
0
View file @
85fce5ac
From f9bb33c84b91742fa9de280b622c5cec6a52fefa Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
Date: Tue, 3 Dec 2024 14:09:07 +0200
Subject: [PATCH] db: fix apk_cache_download to work with
APK_SIGN_VERIFY_IDENTITY
fixes #11048
fixes be292bd5 "db: honor 'verify' mode in apk_cache_download"
---
src/database.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/database.c b/src/database.c
index 5fb43668..71b67b08 100644
--- a/src/database.c
+++ b/src/database.c
@@ -661,7 +661,7 @@
int apk_cache_download(struct apk_database *db, struct apk_repository *repo,
if (apk_flags & APK_SIMULATE) return 0;
if (cb) cb(cb_ctx, 0);
- apk_sign_ctx_init(&sctx, verify, NULL, db->keys_fd);
+ apk_sign_ctx_init(&sctx, verify, pkg ? &pkg->csum : NULL, db->keys_fd);
is = apk_istream_from_url_if_modified(url, st.st_mtime);
is = apk_istream_tee(is, db->cache_fd, tmpcacheitem, autoupdate ? 0 : APK_ISTREAM_TEE_COPY_META, cb, cb_ctx);
is = apk_istream_gunzip_mpart(is, apk_sign_ctx_mpart_cb, &sctx);
--
GitLab
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment