Skip to content
Snippets Groups Projects
Commit ebc3b67b authored by Leonardo Arena's avatar Leonardo Arena
Browse files

Revert "testing/vice: new aport"

This reverts commit 8f8a6eb1.
parent 8f8a6eb1
No related branches found
No related tags found
No related merge requests found
# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
pkgname=vice
pkgver=3.0
pkgrel=0
pkgdesc="emulates the C64/DTV, C128, VIC20, almost all PETs, PLUS4 and CBM-II"
url="http://vice-emu.sourceforge.net/"
arch="all"
license="GPL"
depends=""
makedepends="sdl2-dev giflib-dev ffmpeg-dev jpeg-dev alsa-lib-dev
linux-headers texinfo automake autoconf bison flex"
install=""
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/vice-emu/vice-$pkgver.tar.gz
disable-fc-cache.patch
musl-fixes.patch
"
builddir="$srcdir"/$pkgname-$pkgver
prepare() {
default_prepare || return 1
sed -i 's/lib64/lib/g' configure.ac || return 1
autoreconf -fi || return 1
}
build() {
cd "$builddir"
./configure --prefix=/usr \
--libdir=/usr/lib \
--enable-sdlui2 \
--disable-no-pic \
--enable-external-ffmpeg \
|| return 1
make || return 1
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" realdocdir="/usr/share/doc/vice" install || return 1
}
md5sums="c732d76a70ac1232a43456dae540b43a vice-3.0.tar.gz
b1dee4fef59f835534683fabbe1fbbce disable-fc-cache.patch
bdabef5017a68648dbe17ebde5163077 musl-fixes.patch"
sha256sums="bc56811381920d43ab5f2f85a5e08f21ab5bdf6190dd5dfe9f500a745d14972b vice-3.0.tar.gz
8058210e092c4943a55baeff47e6d5f3661aeb3686fd1f75e07f47888da9cc98 disable-fc-cache.patch
0378224bc9a205386a6d9f4d6cee3ab6bcc78d949a6aad8a345084480dcd596a musl-fixes.patch"
sha512sums="60d33e644d9977df81ffbdceff8c4feec750de9597cfa9f37c4aa236eabbf507373e6f936e2cc3b06f3e7298e0390d1e098242bfacd6435e628a13991a6a452b vice-3.0.tar.gz
ed6fee34eefcb04c42b4575591dfeffca8548eae354dee66dabdbc4abac0311cbbedcdc07cdfcb01da4840d57ab331a31583e17160820462a2c064835a75d75d disable-fc-cache.patch
fa9f3ce9322a2bb5475ec703bc9134a6fa23fdffec0b82bb947b848830ecfa8f31f7d5ff195025a57f09be9f99fbbfe368e7293f535068c4d88194f593dc5909 musl-fixes.patch"
--- a/configure.ac.orig 2016-12-15 04:44:32.000000000 +0100
+++ b/configure.ac 2017-01-05 23:24:59.072247182 +0100
@@ -2998,12 +2998,7 @@ if test x"$enable_lame" != "xno" ; then
fi
-AC_PATH_PROGS(FCCACHE, fc-cache, false)
-if test x"$FCCACHE" = "xfalse"; then
- AM_CONDITIONAL(HAVE_FC_CACHE, false)
-else
- AM_CONDITIONAL(HAVE_FC_CACHE, true)
-fi
+AM_CONDITIONAL(HAVE_FC_CACHE, false)
if test x"$is_amigaos4" = "xyes"; then
if test x"$enable_sdlui" != "xyes" -a x"$enable_sdlui2" != "xyes"; then
--- a/src/opencbm.h
+++ b/src/opencbm.h
@@ -129,6 +129,10 @@
typedef unsigned char __u_char;
#endif
+#if (defined(__linux__) && !defined(__GLIBC__))
+typedef unsigned char __u_char;
+#endif
+
#endif
/* specifiers for the IEC bus lines */
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment