community/h2o: fix dependencies and declare no check

Perl is required for the /usr/share/h2o/start_server script, which
execs perl. OpenSSL is required for running h2o as HTTPS server.

Declare the package !check for no since the checks are broken with the
current version of the package. They should work again once upstream
releases a new version.
7 jobs for !7795 with h2o in 1 minute and 35 seconds
detached
Status Job ID Name Coverage
  Lint
passed #116840
docker-alpine x86_64
lint

00:00:25

 
  Build
passed #116845
docker-alpine ci-build aarch64
build-aarch64

00:00:30

passed #116846
docker-alpine ci-build armv7
build-armv7

00:00:25

passed #116844
docker-alpine ci-build ppc64le
build-ppc64le

00:00:38

passed #116843
docker-alpine ci-build s390x
build-s390x

00:00:24

passed #116842
docker-alpine ci-build x86
build-x86

00:00:18

passed #116841
docker-alpine ci-build x86_64
build-x86_64

00:00:20