Skip to content
  • Tuan M. Hoang's avatar
    community/binaryen: disable on s390x · 221cf3af
    Tuan M. Hoang authored and Jakub Jirutka's avatar Jakub Jirutka committed
    Probably bug in endianness detection. Fails in test:
    
      executing:  bin/wasm-merge test/merge/dylib.wasm test/merge/dylib.wasm.toMerge \
        -o a.wast -S --verbose --finalize-memory-base=1024 \
        --finalize-table-base=8incorrect output, diff:
      --- expected
      +++ actual
      @@ -3,7 +3,7 @@
        (import "env" "memory" (memory $0 1))
        (table 2 2 anyfunc)
        (elem (i32.const 0) $__wasm_nullptr $__exit)
      - (data (i32.const 16) "\d2\04\00\00\00\00\00\00)\t\00\00")
      + (data (i32.const 16) "\00\00\04\d2\00\00\00\00\00\00\t)")
    
    Reported to upstream: https://github.com/WebAssembly/binaryen/issues/1012
    221cf3af