Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
fc50f09a
Commit
fc50f09a
authored
5 months ago
by
Holger Jaekel
Committed by
Kevin Daudt
5 months ago
Browse files
Options
Downloads
Patches
Plain Diff
community/kstars: upgrade to 3.7.3
parent
6ffc07e6
No related branches found
No related tags found
1 merge request
!74829
community/cfitsio: upgrade to 4.5.0
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/kstars/APKBUILD
+5
-4
5 additions, 4 deletions
community/kstars/APKBUILD
community/kstars/tests-disable-ngc4535-autofocus3.patch
+12
-2
12 additions, 2 deletions
community/kstars/tests-disable-ngc4535-autofocus3.patch
with
17 additions
and
6 deletions
community/kstars/APKBUILD
+
5
−
4
View file @
fc50f09a
# Contributor: Clayton Craft <clayton@craftyguy.net>
# Contributor: Clayton Craft <clayton@craftyguy.net>
# M
aintainer
:
team/kde <clayton@craftyguy.net>
m
aintainer
=
"
team/kde <clayton@craftyguy.net>
"
pkgname
=
kstars
pkgname
=
kstars
pkgver
=
3.7.
2
pkgver
=
3.7.
3
pkgrel
=
0
pkgrel
=
0
pkgdesc
=
"Astronomy software"
pkgdesc
=
"Astronomy software"
url
=
"https://kde.org/applications/education/kstars"
url
=
"https://kde.org/applications/education/kstars"
...
@@ -12,6 +12,7 @@ license="GPL-2.0-or-later"
...
@@ -12,6 +12,7 @@ license="GPL-2.0-or-later"
makedepends
=
"
makedepends
=
"
cfitsio-dev
cfitsio-dev
cmake
cmake
curl-dev
eigen-dev
eigen-dev
extra-cmake-modules
extra-cmake-modules
gsl-dev
gsl-dev
...
@@ -78,6 +79,6 @@ package() {
...
@@ -78,6 +79,6 @@ package() {
}
}
sha512sums
=
"
sha512sums
=
"
897c7dad54321e8e90372d4b1ec5e33ae0a5d3c6de53ad6faaa2d81b205646efc370a882e2805f55a415acf55c9d46d5d427455728ad678e70688662b744f9
87 kstars-3.7.
2
.tar.xz
981e7040745bfc1e52339a653945ec3283cb4bfa8f5018cf890a1ae8b10a7e860de5c4c99ab7b3f14e6eae856c6ac65e39cf1856263609cf1d6541bd7224e
87
f
kstars-3.7.
3
.tar.xz
16967f51398456e259f351f91307d57885cbe9778199521c6b9c157d6b19477a49a055311d3d75ce10b9b3266211344aee153b4c09881dd553ebd28d2692684c
tests-disable-ngc4535-autofocus3.patch
218371075ce851dd3d0b96731a8360859a60fef83bde1108485b8ea0b84221e77a982185eb74b34c43390e988b3f3ef82864cd4eee91023a904421218d278ae1
tests-disable-ngc4535-autofocus3.patch
"
"
This diff is collapsed.
Click to expand it.
community/kstars/tests-disable-ngc4535-autofocus3.patch
+
12
−
2
View file @
fc50f09a
Author: Kevin Daudt <kdaudt@alpinelinux.org>
Summary: disable ngc4535-autofocus3 test
Upstream-issue: https://bugs.kde.org/show_bug.cgi?id=483577
----
diff --git a/Tests/fitsviewer/testfitsdata.cpp b/Tests/fitsviewer/testfitsdata.cpp
diff --git a/Tests/fitsviewer/testfitsdata.cpp b/Tests/fitsviewer/testfitsdata.cpp
index 0a5a4b4..bb2cc35 100644
index 0a5a4b4..bb2cc35 100644
--- a/Tests/fitsviewer/testfitsdata.cpp
--- a/Tests/fitsviewer/testfitsdata.cpp
+++ b/Tests/fitsviewer/testfitsdata.cpp
+++ b/Tests/fitsviewer/testfitsdata.cpp
@@ -55,
7
+55,
6
@@
void TestFitsData::testComputeHFR_data()
@@ -55,
12
+55,
10
@@
// Normal HFR tests
// Normal HFR tests
QTest::newRow("NGC4535-1-FOCUS") << "ngc4535-autofocus1.fits" << FITS_FOCUS << 11 << 3.92;
QTest::newRow("NGC4535-1-FOCUS") << "ngc4535-autofocus1.fits" << FITS_FOCUS << 11 << 3.92;
QTest::newRow("NGC4535-2-FOCUS") << "ngc4535-autofocus2.fits" << FITS_FOCUS << 17 << 2.13;
QTest::newRow("NGC4535-2-FOCUS") << "ngc4535-autofocus2.fits" << FITS_FOCUS << 17 << 2.13;
- QTest::newRow("NGC4535-3-FOCUS") << "ngc4535-autofocus3.fits" << FITS_FOCUS << 126 << 1.254911;
- QTest::newRow("NGC4535-3-FOCUS") << "ngc4535-autofocus3.fits" << FITS_FOCUS << 126 << 1.254911;
// Focus HFR tests
// Focus HFR tests
QTest::newRow("NGC4535-1-NORMAL") << "ngc4535-autofocus1.fits" << FITS_NORMAL << 3 << 3.17;
QTest::newRow("NGC4535-1-NORMAL") << "ngc4535-autofocus1.fits" << FITS_NORMAL << 3 << 3.17;
QTest::newRow("NGC4535-2-NORMAL") << "ngc4535-autofocus2.fits" << FITS_NORMAL << 4 << 1.99;
- QTest::newRow("NGC4535-3-NORMAL") << "ngc4535-autofocus3.fits" << FITS_NORMAL << 30 << 1.22;
#endif
}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment