Skip to content
Snippets Groups Projects
Commit fa5ad400 authored by Antoni Aloy Torrens's avatar Antoni Aloy Torrens Committed by Michał Polański
Browse files

testing/py3-imageio-ffmpeg: new aport

parent 28367118
1 merge request!20281testing/py3-imageio-ffmpeg: new aport
# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
pkgname=py3-imageio-ffmpeg
pkgver=0.4.3
pkgrel=0
pkgdesc="FFMPEG wrapper for Python"
url="https://github.com/imageio/imageio-ffmpeg"
arch="noarch"
license="BSD-2-Clause"
depends="ffmpeg python3"
makedepends="py3-setuptools"
options="!check" # No test suite
source="$pkgname-$pkgver.tar.gz::https://github.com/imageio/imageio-ffmpeg/archive/v$pkgver.tar.gz
pip-requirement.patch
"
builddir="$srcdir/imageio-ffmpeg-$pkgver"
build() {
python3 setup.py build
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
}
sha512sums="9bf4556438c879bf558a6b497fb75fc9f7b07d970344718af64b303b61fbd70c0eb25231f1cd9bd7bf742e9d6894bf30f597063489f37566d1ab0fba985dab2b py3-imageio-ffmpeg-0.4.3.tar.gz
4a4fd212fc6ac1a7720b65a36ad15927e25c73f84c5f1d970801b122e70e3e63475fc093be7a1009d8ca9f9d629200ffd7b6bc6a8f8bb46c1836100896d1872b pip-requirement.patch"
diff --unified --recursive --text imageio-ffmpeg-0.4.3.orig/setup.py imageio-ffmpeg-0.4.3.new/setup.py
--- a/setup.py 2021-01-04 17:18:12.000000000 +0100
+++ b/setup.py 2021-02-13 09:51:58.744209490 +0100
@@ -57,7 +57,7 @@
platforms="any",
provides=["imageio_ffmpeg"],
python_requires=">=3.4",
- setup_requires=["pip>19"],
+ setup_requires=[],
install_requires=[],
packages=["imageio_ffmpeg"],
package_dir={"imageio_ffmpeg": "imageio_ffmpeg"},
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment