Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
f9ecb821
Unverified
Commit
f9ecb821
authored
2 years ago
by
alice
Browse files
Options
Downloads
Patches
Plain Diff
testing/amule: rebuild against wxwidgets-3.2
parent
dcca2261
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/amule/APKBUILD
+19
-10
19 additions, 10 deletions
testing/amule/APKBUILD
testing/amule/wxwidgets-3.2.patch
+61
-0
61 additions, 0 deletions
testing/amule/wxwidgets-3.2.patch
with
80 additions
and
10 deletions
testing/amule/APKBUILD
+
19
−
10
View file @
f9ecb821
...
...
@@ -3,30 +3,39 @@
pkgname
=
amule
_pkgname
=
aMule
pkgver
=
2.3.3
pkgrel
=
7
pkgrel
=
8
pkgdesc
=
"eMule-like client for the eD2k and Kademlia networks"
url
=
"https://www.amule.org/"
arch
=
"all !x86"
# crypto++
license
=
"GPL-2.0-or-later"
makedepends
=
"bison boost-dev crypto++-dev gd-dev geoip-dev libsm-dev libupnp-dev
wxgtk3-dev"
makedepends
=
"
bison
boost-dev
crypto++-dev
gd-dev
geoip-dev
libsm-dev
libupnp-dev
wxwidgets-dev
"
options
=
"!check"
# unexpected end of file
subpackages
=
"
$pkgname
-lang
$pkgname
-doc"
source
=
"
$_pkgname
-
$pkgver
.tar.xz::https://downloads.sourceforge.net/project/amule/aMule/
2.3.3
/aMule-
$pkgver
.tar.xz
source
=
"
$_pkgname
-
$pkgver
.tar.xz::https://downloads.sourceforge.net/project/amule/aMule/
$pkgver
/aMule-
$pkgver
.tar.xz
fix-gcc11-include.patch
"
builddir
=
"
$srcdir
/
$_pkgname
-
$pkgver
"
build
()
{
export
CFLAGS
=
"
$CFLAGS
-flto=auto -DNDEBUG"
export
CXXFLAGS
=
"
$CXXFLAGS
-flto=auto -DNDEBUG"
./configure
\
CPPFLAGS
=
"
$CPPFLAGS
-Wno-unused-local-typedefs"
\
CFLAGS
=
"
$CFLAGS
-fPIC"
\
CXXFLAGS
=
"
$CXXFLAGS
-fPIC"
\
--build
=
$CBUILD
\
--host
=
$CHOST
\
--prefix
=
/usr
\
--mandir
=
/usr/share/man
\
--disable-debug
\
--enable-alc
\
--enable-alcc
\
--enable-amule-daemon
\
...
...
@@ -37,9 +46,9 @@ build() {
--enable-optimize
\
--enable-upnp
\
--enable-webserver
\
--
dis
able-
debug
\
--with-boost
\
--with-wx-config
=
wx-config-gtk3
--
en
able-
fileview
\
--with-boost
make
}
...
...
This diff is collapsed.
Click to expand it.
testing/amule/wxwidgets-3.2.patch
0 → 100644
+
61
−
0
View file @
f9ecb821
diff --git a/src/muuli_wdr.cpp b/src/muuli_wdr.cpp
index 44f0eb6..64dbade 100644
--- a/src/muuli_wdr.cpp
+++ b/src/muuli_wdr.cpp
@@ -181,10 +181,10 @@
wxSizer *searchDlg( wxWindow *parent, bool call_fit, bool set_sizer )
wxBoxSizer *item3 = new wxBoxSizer( wxHORIZONTAL );
wxStaticText *item4 = new wxStaticText( parent, -1, _("Name:"), wxDefaultPosition, wxDefaultSize, 0 );
- item3->Add( item4, 0, wxALIGN_CENTER|wxALL, 5 );
+ item3->Add( item4, 0, wxALIGN_CENTER_VERTICAL|wxALL, 5 );
CMuleTextCtrl *item5 = new CMuleTextCtrl( parent, IDC_SEARCHNAME, wxT(""), wxDefaultPosition, wxSize(80,-1), wxTE_PROCESS_ENTER );
- item3->Add( item5, 1, wxALIGN_CENTER|wxALL, 5 );
+ item3->Add( item5, 1, wxALIGN_CENTER_VERTICAL|wxALL, 5 );
wxFlexGridSizer *item6 = new wxFlexGridSizer( 1, 0, 0, 0 );
@@ -212,7 +212,7 @@
wxSizer *searchDlg( wxWindow *parent, bool call_fit, bool set_sizer )
wxCheckBox *item12 = new wxCheckBox( parent, IDC_FILTERCHECK, _("Filtering"), wxDefaultPosition, wxDefaultSize, 0 );
item6->Add( item12, 0, wxALIGN_CENTER|wxALL, 5 );
- item3->Add( item6, 0, wxALIGN_CENTER, 0 );
+ item3->Add( item6, 0, wxALIGN_CENTER_VERTICAL, 0 );
item1->Add( item3, 0, wxGROW|wxALIGN_CENTER_VERTICAL, 5 );
@@ -925,17 +925,17 @@
wxSizer *downloadDlg( wxWindow *parent, bool call_fit, bool set_sizer )
item0->Add( item2, 0, wxALIGN_CENTER|wxLEFT|wxRIGHT, 5 );
wxGauge *item3 = new wxGauge( parent, ID_HTTPDOWNLOADPROGRESS, 100, wxDefaultPosition, wxSize(-1,10), wxGA_SMOOTH|wxGA_PROGRESSBAR );
- item0->Add( item3, 0, wxGROW|wxALIGN_CENTER_VERTICAL|wxALL, 5 );
+ item0->Add( item3, 0, wxGROW|wxALIGN_CENTER_HORIZONTAL|wxALL, 5 );
wxStaticText *item4 = new wxStaticText( parent, IDC_DOWNLOADSIZE, _("Unknown size"), wxDefaultPosition, wxDefaultSize, wxALIGN_CENTRE );
- item0->Add( item4, 0, wxGROW|wxALIGN_CENTER_VERTICAL|wxALL, 5 );
+ item0->Add( item4, 0, wxGROW|wxALIGN_CENTER_HORIZONTAL|wxALL, 5 );
wxStaticLine *item5 = new wxStaticLine( parent, -1, wxDefaultPosition, wxSize(20,-1), wxLI_HORIZONTAL );
- item0->Add( item5, 0, wxGROW|wxALIGN_CENTER_VERTICAL|wxALL, 5 );
+ item0->Add( item5, 0, wxGROW|wxALIGN_CENTER_HORIZONTAL|wxALL, 5 );
wxButton *item6 = new wxButton( parent, ID_HTTPCANCEL, _("Cancel"), wxDefaultPosition, wxDefaultSize, 0 );
item6->SetDefault();
- item0->Add( item6, 0, wxALIGN_CENTER|wxALL, 5 );
+ item0->Add( item6, 0, wxALIGN_CENTER_HORIZONTAL|wxALL, 5 );
if (set_sizer)
{
diff --git a/src/utils/wxCas/src/wxcasprefs.cpp b/src/utils/wxCas/src/wxcasprefs.cpp
index d87aad3..c36ac64 100644
--- a/src/utils/wxCas/src/wxcasprefs.cpp
+++ b/src/utils/wxCas/src/wxcasprefs.cpp
@@ -88,7 +88,7 @@
WxCasPrefs::WxCasPrefs ( wxWindow * parent ) : wxDialog ( parent, -1,
WxCasCte::DEFAULT_REFRESH_RATE ) );
m_refreshStaticText =
new wxStaticText ( this, -1, _( "Refresh rate interval in seconds" ), wxDefaultPosition,
- wxDefaultSize, wxALIGN_CENTRE );
+ wxDefaultSize, wxALIGN_CENTER );
m_refreshSBoxSizer->Add ( m_refreshSpinButton, 0, wxALL | wxALIGN_CENTER, 5 );
m_refreshSBoxSizer->Add ( m_refreshStaticText, 1, wxALL | wxALIGN_CENTER, 5 );
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment