Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
f8b8f366
Commit
f8b8f366
authored
10 months ago
by
omni
Browse files
Options
Downloads
Patches
Plain Diff
community/sccache: upgrade to 0.8.0
parent
641aead4
No related branches found
No related tags found
1 merge request
!64620
community/sccache: upgrade to 0.8.0
Pipeline
#228631
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/sccache/APKBUILD
+3
-3
3 additions, 3 deletions
community/sccache/APKBUILD
community/sccache/test_musl_ldd_parse.patch
+11
-9
11 additions, 9 deletions
community/sccache/test_musl_ldd_parse.patch
with
14 additions
and
12 deletions
community/sccache/APKBUILD
+
3
−
3
View file @
f8b8f366
# Maintainer: omni <omni+alpine@hack.org>
pkgname
=
sccache
pkgver
=
0.
7.7
pkgver
=
0.
8.0
pkgrel
=
0
pkgdesc
=
"shared compilation cache for C/C++ and Rust"
url
=
"https://github.com/mozilla/sccache/"
...
...
@@ -61,6 +61,6 @@ dist() {
}
sha512sums
=
"
b1a204e6638e2224af055f290df0c9f3a5cd30f43c720b9ddee194adb0c6290feb20badcdbd8f04a5830088b25b27665a617e6f20a3a60b2849b4ad81d48a25a
sccache-0.
7.7
.tar.gz
41086a95ffa6119e6e9eab14ba5e3e8452121ad357a560928eeba21b76674133f936b4e7b9b4a8ac0e15d87dac7ebcf7e635390692467ca4e0c5b16d50426696
test_musl_ldd_parse.patch
1b0a85ff12e9e17c39b4145adbab8706108691ad924a4dad94ee2cf6a48c4ee6a5fba47c5edd810c6767c04bea9c40e1ca0971fc8fab4af724228979446361bc
sccache-0.
8.0
.tar.gz
e185fc6371bcfd59b5c5243d6d4461327061b26d608680187ec49b3698a459e4dca03a0641553a690b8009bd08413d157cf03697bfad7b7d47e8a31c80f37bac
test_musl_ldd_parse.patch
"
This diff is collapsed.
Click to expand it.
community/sccache/test_musl_ldd_parse.patch
+
11
−
9
View file @
f8b8f366
...
...
@@ -2,7 +2,7 @@ Adjust this test to musl and our output of 'ldd /bin/ls'.
This test will be run on x86_64.
--- a/src/dist/pkg.rs
+++ b/src/dist/pkg.rs
@@ -37
7
,24 +37
7
,2
6
@@
mod toolchain_imp {
@@ -37
8
,24 +37
8
,2
8
@@
mod toolchain_imp {
}
#[test]
...
...
@@ -12,13 +12,14 @@ This test will be run on x86_64.
-\tlibc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f69ca6a1000)
-\tlibc.so.6 => /usr/lib/libc.so.6 (0x00007f49807c2000)
-\t/lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007f49809e9000)
+ fn test_musl_ldd_parse_v1_2_2() {
+ let alpinelinux_ls_output = "\t/lib/ld-musl-x86_64.so.1 (0x7f10902bf000)
+\tlibacl.so.1 => /lib/libacl.so.1 (0x7f108fd98000)
+\tlibattr.so.1 => /lib/libattr.so.1 (0x7f108fd91000)
+\tlibutmps.so.0.1 => /lib/libutmps.so.0.1 (0x7f108fd8c000)
+\tlibc.musl-x86_64.so.1 => /lib/ld-musl-x86_64.so.1 (0x7f10902bf000)
+\tlibskarnet.so.2.13 => /lib/libskarnet.so.2.13 (0x7f108fd53000)
+ fn test_musl_ldd_parse_v1_2_5() {
+ let alpinelinux_ls_output = "\t/lib/ld-musl-x86_64.so.1 (0x7f56f69bc000)
+\tlibcrypto.so.3 => /lib/libcrypto.so.3 (0x7f56f6474000)
+\tlibacl.so.1 => /lib/libacl.so.1 (0x7f56f646b000)
+\tlibattr.so.1 => /lib/libattr.so.1 (0x7f56f6464000)
+\tlibutmps.so.0.1 => /lib/libutmps.so.0.1 (0x7f56f645f000)
+\tlibc.musl-x86_64.so.1 => /lib/ld-musl-x86_64.so.1 (0x7f56f69bc000)
+\tlibskarnet.so.2.14 => /lib/libskarnet.so.2.14 (0x7f56f6427000)
";
assert_eq!(
- parse_ldd_output(archlinux_ls_output)
...
...
@@ -33,11 +34,12 @@ This test will be run on x86_64.
- "/lib64/ld-linux-x86-64.so.2",
- "/usr/lib64/ld-linux-x86-64.so.2",
+ "/lib/ld-musl-x86_64.so.1",
+ "/lib/libcrypto.so.3",
+ "/lib/libacl.so.1",
+ "/lib/libattr.so.1",
+ "/lib/libutmps.so.0.1",
+ "/lib/ld-musl-x86_64.so.1",
+ "/lib/libskarnet.so.2.1
3
",
+ "/lib/libskarnet.so.2.1
4
",
]
)
}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment