Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
f653f0ad
Commit
f653f0ad
authored
6 months ago
by
znley
Committed by
Andy Postnikov
6 months ago
Browse files
Options
Downloads
Patches
Plain Diff
community/certmonger: fix build with gcc14
parent
4ad187d1
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!71506
community/certmonger: fix build with gcc14
Pipeline
#257662
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/certmonger/APKBUILD
+2
-0
2 additions, 0 deletions
community/certmonger/APKBUILD
community/certmonger/gcc14.patch
+26
-0
26 additions, 0 deletions
community/certmonger/gcc14.patch
with
28 additions
and
0 deletions
community/certmonger/APKBUILD
+
2
−
0
View file @
f653f0ad
...
...
@@ -46,6 +46,7 @@ source="$pkgname-$pkgver.tar.gz::https://pagure.io/certmonger/archive/$pkgver/ce
0002-fix-unistd-for-musl.patch
0003-tests-fix-addition-of-test-40.patch
0004-tests-use-better-Makefile-integration-of-test-runnin.patch
gcc14.patch
certmonger.initd
certmonger.confd
"
...
...
@@ -93,6 +94,7 @@ d14e2bb583869687f3a107df9cd58071a98567267a3726b4082061c7b988bcf831090aeb8d087488
a603e056f91604943f55da577f8991ea33e6a890c75913a66dfcf4d64447ebc65715e7b0f9eac45246af3827dd2cd658ed9e291f20c5fa0182bb00e1a7919e9e 0002-fix-unistd-for-musl.patch
5294cedd25ae607e9ccc941db1a080bc2e19484c98a72c3a8570aa2e35731a48fba60c3cfb652c0ad2c929ae85e187a017dbbf59d4e9f28a5b132c03698f3ba8 0003-tests-fix-addition-of-test-40.patch
e2338f5c3505b54d1c1d2e42ca269688fac4c0b62bd40fadf262d942bb134e722897b7d2767db5fd5c266a512a7c93ad00a2dd74fff619ae941ee1b9b5c0261b 0004-tests-use-better-Makefile-integration-of-test-runnin.patch
415c6b387a1f3b7061de4328a6d00280af735a31655b917f280172adc90ef0b1fd4228690ab3c6ba2f877cc50dd221efc099bd0c5854a32a2d548e79cfbae6eb gcc14.patch
2c0cee6b5bcd5a34eb9580c84881a58b48bd0fb21ea94b57f1936b1c7fae9f943edc69561e9df4c8b3c71347914a130ffb9a9cb8e71ccbdf970f55186c17e9e1 certmonger.initd
c6c819f5d153c24606ce4b888fde68afe8791e4fbadb08217a58ef6def680b6d44d6ff120da7279817f79d44372d0bec80dce6c68cd5abbbef164239bb6eb37f certmonger.confd
"
This diff is collapsed.
Click to expand it.
community/certmonger/gcc14.patch
0 → 100644
+
26
−
0
View file @
f653f0ad
diff --git a/src/tdbusm.c b/src/tdbusm.c
index 5e33411..fb48feb 100644
--- a/src/tdbusm.c
+++ b/src/tdbusm.c
@@ -241,7 +241,7 @@
cm_tdbusm_get_vn(DBusMessage *msg, void *parent, long *n)
dbus_message_iter_recurse(&iter, &sub_iter);
if (dbus_message_iter_get_arg_type(&sub_iter) == DBUS_TYPE_INT64) {
dbus_message_iter_get_basic(&sub_iter, &i64);
- *n = i64;
+ *n = (long int)i64;
return 0;
}
}
diff --git a/src/util-o.c b/src/util-o.c
index c05872c..7feecb9 100644
--- a/src/util-o.c
+++ b/src/util-o.c
@@ -551,7 +551,7 @@
util_NETSCAPE_SPKI_set_sig_alg(NETSCAPE_SPKI *spki, const X509_ALGOR *sig_alg)
static EVP_PKEY *
util_EVP_PKEY_dup(EVP_PKEY *pkey,
- int (*i2d)(EVP_PKEY *, unsigned char **),
+ int (*i2d)(const EVP_PKEY *, unsigned char **),
EVP_PKEY *(*d2i)(int, EVP_PKEY **, const unsigned char **, long))
{
EVP_PKEY *k;
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment