Skip to content
Snippets Groups Projects
Commit f3fcafb9 authored by Michał Polański's avatar Michał Polański
Browse files

community/committed: upgrade to 1.0.20

parent 53645d95
No related branches found
No related tags found
No related merge requests found
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=committed
pkgver=1.0.18
pkgrel=2
pkgver=1.0.20
pkgrel=0
pkgdesc="Nitpicking your commit history"
url="https://github.com/crate-ci/committed"
license="MIT OR Apache-2.0"
arch="all"
makedepends="cargo libgit2-dev cargo-auditable"
source="https://github.com/crate-ci/committed/archive/v$pkgver/committed-$pkgver.tar.gz
libgit2.patch
"
source="https://github.com/crate-ci/committed/archive/v$pkgver/committed-$pkgver.tar.gz"
options="net" # fetch dependencies
prepare() {
default_prepare
# Rust target triple.
# Rust target triple
local target=$(rustc -vV | sed -n 's/host: //p')
# Build against system-provided libs
......@@ -44,6 +42,5 @@ package() {
}
sha512sums="
79a441308ca763f3db768ef0f7a2df7eade79a90d769f06a16c75be9b9bda24762879d21cbb29ea59afce8700b197cdaf83beefb5fdc4cd15a7c0791d2bc2ea7 committed-1.0.18.tar.gz
58948cf7195c659d9c244c93b8f01a0c7e9e37053b4e7f0678d23722c5c9706b69961d6c0e6ab22209e20db98ec7d7b4d294aa8d85b0d031105eeecb0bcdedda libgit2.patch
d20072ef1d0f0da34379b43bc97de6491b38d7a19dc761ae084751da421e452c42208c73db6b322c29ec337a7158322c05f7dbefa6b3aa40275b50fdb0d6ac84 committed-1.0.20.tar.gz
"
diff --git a/Cargo.lock b/Cargo.lock
index 29463b4..9ece445 100644
--- a/Cargo.lock
+++ b/Cargo.lock
@@ -353,9 +353,9 @@ dependencies = [
[[package]]
name = "git2"
-version = "0.16.1"
+version = "0.17.2"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "ccf7f68c2995f392c49fffb4f95ae2c873297830eb25c6bc4c114ce8f4562acc"
+checksum = "7b989d6a7ca95a362cf2cfc5ad688b3a467be1f87e480b8dad07fee8c79b0044"
dependencies = [
"bitflags",
"libc",
@@ -533,9 +533,9 @@ checksum = "99227334921fae1a979cf0bfdfcc6b3e5ce376ef57e16fb6fb3ea2ed6095f80c"
[[package]]
name = "libgit2-sys"
-version = "0.14.2+1.5.1"
+version = "0.15.2+1.6.4"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "7f3d95f6b51075fe9810a7ae22c7095f12b98005ab364d8544797a825ce946a4"
+checksum = "a80df2e11fb4a61f4ba2ab42dbe7f74468da143f1a75c74e11dee7c813f694fa"
dependencies = [
"cc",
"libc",
diff --git a/crates/committed/Cargo.toml b/crates/committed/Cargo.toml
index 5ea24d2..be297cf 100644
--- a/crates/committed/Cargo.toml
+++ b/crates/committed/Cargo.toml
@@ -31,7 +31,7 @@ once_cell = "1.17.1"
git-conventional = "0.12"
unicase = "2.6.0"
anyhow = "1.0"
-git2 = { version = "0.16", default-features = false }
+git2 = { version = "0.17", default-features = false }
clap = { version = "4.2", features = ["derive"] }
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment