Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
f339c7bb
Commit
f339c7bb
authored
4 years ago
by
Leo
Browse files
Options
Downloads
Patches
Plain Diff
community/spacefm: fix build with -fno-common
parent
7e86cc7c
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/spacefm/APKBUILD
+5
-2
5 additions, 2 deletions
community/spacefm/APKBUILD
community/spacefm/gcc-10.patch
+88
-0
88 additions, 0 deletions
community/spacefm/gcc-10.patch
with
93 additions
and
2 deletions
community/spacefm/APKBUILD
+
5
−
2
View file @
f339c7bb
...
...
@@ -11,7 +11,9 @@ depends="bash"
makedepends
=
"intltool gettext-dev gtk+2.0-dev gtk+3.0-dev eudev-dev ffmpegthumbnailer-dev linux-headers"
subpackages
=
"
$pkgname
-lang
$pkgname
-doc
$pkgname
-gtk3
$pkgname
-gtk3-lang:lang3:noarch
$pkgname
-gtk3-doc:doc3:noarch"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/IgnorantGuru/spacefm/archive/
$pkgver
.tar.gz
spacefm-include-sysmacros.patch"
spacefm-include-sysmacros.patch
gcc-10.patch
"
builddir
=
"
$srcdir
"
/
$pkgname
-
$pkgver
...
...
@@ -60,4 +62,5 @@ package() {
}
sha512sums
=
"37fc0dd31f02158502f592415b4c375ee49560af6f03d75b035d7c6c45bdc47064bba1ae8987b4cc8be2e02b3dfcdc17ec760411975e7b5f74343a2293fb2c8c spacefm-1.0.6.tar.gz
d7b33441700141dc956df54f03393c02783fc5188b82883401d4781c52fb383089af5ed3b3645b686078a6ac06d3b3e269f7ee5ab3f4d1416ebb0141fbaa7b7e spacefm-include-sysmacros.patch"
d7b33441700141dc956df54f03393c02783fc5188b82883401d4781c52fb383089af5ed3b3645b686078a6ac06d3b3e269f7ee5ab3f4d1416ebb0141fbaa7b7e spacefm-include-sysmacros.patch
343f149b96655ffe930e2ea76e78fab407904a893669b6ca71ed1797292c81750782a91db589f87ef8951601b90179f7b83c900d0039276578624b64b2661dd1 gcc-10.patch"
This diff is collapsed.
Click to expand it.
community/spacefm/gcc-10.patch
0 → 100644
+
88
−
0
View file @
f339c7bb
Fixes build with -fno-common which is default under gcc-10
--- a/src/settings.c
+++ b/src/settings.c
@@ -52,6 +52,24 @@
/* Dirty hack: check whether we are under LXDE or not */
#define is_under_LXDE() (g_getenv( "_LXSESSION_PID" ) != NULL)
+char* settings_terminal_su = NULL;
+char* settings_graphical_su = NULL;
+GList* xset_cmd_history = NULL;
+XSet* evt_win_focus = NULL;
+XSet* evt_win_move = NULL;
+XSet* evt_win_click = NULL;
+XSet* evt_win_key = NULL;
+XSet* evt_win_close = NULL;
+XSet* evt_pnl_show = NULL;
+XSet* evt_pnl_focus = NULL;
+XSet* evt_pnl_sel = NULL;
+XSet* evt_tab_new = NULL;
+XSet* evt_tab_chdir = NULL;
+XSet* evt_tab_focus = NULL;
+XSet* evt_tab_close = NULL;
+XSet* evt_device = NULL;
+
+
AppSettings app_settings = {0};
/* const gboolean singleInstance_default = TRUE; */
const gboolean show_hidden_files_default = FALSE;
--- a/src/settings.h
+++ b/src/settings.h
@@ -120,7 +120,7 @@
const char* xset_get_user_tmp_dir();
///////////////////////////////////////////////////////////////////////////////
//MOD extra settings below
-GList* xsets;
+extern GList* xsets;
enum {
XSET_B_UNSET,
@@ -311,22 +311,22 @@
typedef struct
} XMenuItem;
// cache these for speed in event handlers
-XSet* evt_win_focus;
-XSet* evt_win_move;
-XSet* evt_win_click;
-XSet* evt_win_key;
-XSet* evt_win_close;
-XSet* evt_pnl_show;
-XSet* evt_pnl_focus;
-XSet* evt_pnl_sel;
-XSet* evt_tab_new;
-XSet* evt_tab_chdir;
-XSet* evt_tab_focus;
-XSet* evt_tab_close;
-XSet* evt_device;
+extern XSet* evt_win_focus;
+extern XSet* evt_win_move;
+extern XSet* evt_win_click;
+extern XSet* evt_win_key;
+extern XSet* evt_win_close;
+extern XSet* evt_pnl_show;
+extern XSet* evt_pnl_focus;
+extern XSet* evt_pnl_sel;
+extern XSet* evt_tab_new;
+extern XSet* evt_tab_chdir;
+extern XSet* evt_tab_focus;
+extern XSet* evt_tab_close;
+extern XSet* evt_device;
// instance-wide command history
-GList* xset_cmd_history;
+extern GList* xset_cmd_history;
static const char* terminal_programs[] = //for pref-dialog.c
{
@@ -374,8 +374,8 @@
static const char* gsu_commands[] = // order and contents must match prefdlg.ui
};
// These will contain the su and gsu settings from /etc/spacefm/spacefm.conf
-char* settings_terminal_su;
-char* settings_graphical_su;
+extern char* settings_terminal_su;
+extern char* settings_graphical_su;
typedef struct
{
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment