Skip to content
Snippets Groups Projects
Commit f2bc6ec4 authored by Kevin Daudt's avatar Kevin Daudt :computer:
Browse files

community/appstream: fix meson 0.58 compattiblity issue

parent f84922fc
No related branches found
No related tags found
No related merge requests found
...@@ -12,7 +12,9 @@ makedepends="meson yaml-dev libxml2-dev glib-dev lmdb-dev gobject-introspection- ...@@ -12,7 +12,9 @@ makedepends="meson yaml-dev libxml2-dev glib-dev lmdb-dev gobject-introspection-
triggers="$pkgname.trigger=/usr/share/app-info/*" triggers="$pkgname.trigger=/usr/share/app-info/*"
install="$pkgname.post-install $pkgname.post-upgrade" install="$pkgname.post-install $pkgname.post-upgrade"
subpackages="$pkgname-dev $pkgname-doc $pkgname-qt $pkgname-lang $pkgname-dbg" subpackages="$pkgname-dev $pkgname-doc $pkgname-qt $pkgname-lang $pkgname-dbg"
source="https://www.freedesktop.org/software/appstream/releases/AppStream-$pkgver.tar.xz" source="https://www.freedesktop.org/software/appstream/releases/AppStream-$pkgver.tar.xz
tests-meson-fix-nested-list.patch
"
builddir="$srcdir/AppStream-$pkgver" builddir="$srcdir/AppStream-$pkgver"
# librsvg doesn't exist on these arches # librsvg doesn't exist on these arches
...@@ -66,4 +68,7 @@ qt() { ...@@ -66,4 +68,7 @@ qt() {
} }
sha512sums="b4c41b44375091636cc46e2f7f5e0b86612474faa6d55010caee78cb9c9ac468d093cf261184d900be7aae8513dc72d2821ff9ee17786e123c86a928ce5e9135 AppStream-0.14.3.tar.xz" sha512sums="
b4c41b44375091636cc46e2f7f5e0b86612474faa6d55010caee78cb9c9ac468d093cf261184d900be7aae8513dc72d2821ff9ee17786e123c86a928ce5e9135 AppStream-0.14.3.tar.xz
f545d979f1a74cc4728b39bce8d5c04fed83f392c207cfa4620875fabc11ebee4c8bc6ee594428629bf673a9b051e596ff72f700aba6af566e43e9ce6b788372 tests-meson-fix-nested-list.patch
"
Description: meson 0.58 is more strict with mixed lists and will not
automatically flatten lists.
Results in:
> tests/meson.build:125:4: ERROR: List item must be one of <class 'str'>, not <class 'list'>
diff --git a/tests/meson.build b/tests/meson.build
index 4696b04..4e25079 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -125,8 +125,8 @@ if get_option('compose')
test ('as-test_compose',
as_test_compose_exe,
args: as_test_args,
- env: [as_test_env,
- 'LSAN_OPTIONS=suppressions=' +
+ env: as_test_env +
+ ['LSAN_OPTIONS=suppressions=' +
join_paths(meson.current_source_dir(), 'lsan-suppr.txt')]
)
endif
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment