Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
f0df1eee
Commit
f0df1eee
authored
4 years ago
by
Newbyte
Committed by
Rasmus Thomsen
4 years ago
Browse files
Options
Downloads
Patches
Plain Diff
community/appstream: upgrade to 0.13.1
parent
68a2239e
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!16471
community/appstream: upgrade to 0.13.1
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/appstream/1109c847b272be6b65ec3d2a4c58e91f0be369fc.patch
+0
-34
0 additions, 34 deletions
.../appstream/1109c847b272be6b65ec3d2a4c58e91f0be369fc.patch
community/appstream/APKBUILD
+4
-6
4 additions, 6 deletions
community/appstream/APKBUILD
with
4 additions
and
40 deletions
community/appstream/1109c847b272be6b65ec3d2a4c58e91f0be369fc.patch
deleted
100644 → 0
+
0
−
34
View file @
68a2239e
Upstream: Yes
From 1109c847b272be6b65ec3d2a4c58e91f0be369fc Mon Sep 17 00:00:00 2001
From: Matthias Klumpp <matthias@tenstral.net>
Date: Thu, 3 Sep 2020 00:07:48 +0200
Subject: [PATCH] validator: Don't pass NULL to vprintf, it's not an allowed
value
The format parameter is listed as non-nullable in the API documentation,
and crashes were reported indicating that this does cause real-world
issues. This likely fixes
https://github.com/ximion/appstream-generator/issues/83
---
src/as-validator.c | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)
diff --git a/src/as-validator.c b/src/as-validator.c
index 32704b70..53d87f8f 100644
--- a/src/as-validator.c
+++ b/src/as-validator.c
@@ -158,9 +158,11 @@
as_validator_add_issue (AsValidator *validator, xmlNode *node, const gchar *tag,
explanation = tag_data->explanation;
}
- va_start (args, format);
- buffer = g_strdup_vprintf (format, args);
- va_end (args);
+ if (format != NULL) {
+ va_start (args, format);
+ buffer = g_strdup_vprintf (format, args);
+ va_end (args);
+ }
issue = as_validator_issue_new ();
as_validator_issue_set_tag (issue, tag_final);
This diff is collapsed.
Click to expand it.
community/appstream/APKBUILD
+
4
−
6
View file @
f0df1eee
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname
=
appstream
pkgver
=
0.1
2
.1
1
pkgrel
=
2
pkgver
=
0.1
3
.1
pkgrel
=
0
pkgdesc
=
"Provides a standard for creating app stores across distributions"
url
=
"https://distributions.freedesktop.org/wiki/AppStream"
arch
=
"all"
...
...
@@ -12,8 +12,7 @@ makedepends="meson yaml-dev libxml2-dev glib-dev lmdb-dev gobject-introspection-
triggers
=
"
$pkgname
.trigger=/usr/share/app-info/*"
install
=
"
$pkgname
.post-install
$pkgname
.post-upgrade"
subpackages
=
"
$pkgname
-dev
$pkgname
-doc
$pkgname
-qt
$pkgname
-lang
$pkgname
-dbg"
source
=
"https://www.freedesktop.org/software/appstream/releases/AppStream-
$pkgver
.tar.xz
https://github.com/ximion/appstream/commit/1109c847b272be6b65ec3d2a4c58e91f0be369fc.patch"
source
=
"https://www.freedesktop.org/software/appstream/releases/AppStream-
$pkgver
.tar.xz"
builddir
=
"
$srcdir
/AppStream-
$pkgver
"
build
()
{
...
...
@@ -45,5 +44,4 @@ qt() {
mkdir
-p
"
$subpkgdir
"
/usr/lib
mv
"
$pkgdir
"
/usr/lib/libAppStreamQt.so.
*
"
$subpkgdir
"
/usr/lib
}
sha512sums
=
"6000f4e9f995b2d481374db2409f212da9d48893c4a757cb7287e2731117f50d0ed284dedc0e24e505b3b7c9c9f38dd9a5f855eeb6c7445eb7203e74d4a5f790 AppStream-0.12.11.tar.xz
5e7dff5eef8e82d61f451250218d85d46611e57e2480621aba178a84f1e143f78d69296b942abb4343b2fb94a917657d1e71f77b62b5a4be750e21c73a2bf6a6 1109c847b272be6b65ec3d2a4c58e91f0be369fc.patch"
sha512sums
=
"9cf469bf604bbdd63815a4b824f13555eb7a9465dbed9f67b41ee1c2704454efa80f7653733dd23d7f7ce759531b826f821b58a606591e57bc86fe03d7a94a9f AppStream-0.13.1.tar.xz"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment