Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
eee3f941
Commit
eee3f941
authored
7 years ago
by
Natanael Copa
Browse files
Options
Downloads
Patches
Plain Diff
main/aports-build: make error messages retained
and clear error on first successful build
parent
4cf3f5dd
Loading
Loading
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/aports-build/APKBUILD
+6
-6
6 additions, 6 deletions
main/aports-build/APKBUILD
main/aports-build/report-build-errors.lua
+5
-3
5 additions, 3 deletions
main/aports-build/report-build-errors.lua
with
11 additions
and
9 deletions
main/aports-build/APKBUILD
+
6
−
6
View file @
eee3f941
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
aports-build
pkgver
=
1.1
pkgrel
=
2
pkgrel
=
3
pkgdesc
=
"MQTT based build-on-git-push scripts for Alpine Linux"
url
=
"http://alpinelinux.org"
arch
=
"noarch"
...
...
@@ -19,10 +19,10 @@ source="aports-build
report-build-errors.lua
"
_
builddir
=
builddir
=
"
$srcdir
"
prepare
()
{
local
i
cd
"
$
_
builddir
"
cd
"
$builddir
"
for
i
in
$source
;
do
case
$i
in
*
.patch
)
msg
$i
;
patch
-p1
-i
"
$srcdir
"
/
$i
||
return
1
;;
...
...
@@ -31,11 +31,11 @@ prepare() {
}
build
()
{
cd
"
$
_
builddir
"
cd
"
$builddir
"
}
package
()
{
cd
"
$
_
builddir
"
cd
"
$builddir
"
install
-Dm755
"
$srcdir
"
/aports-build
\
"
$pkgdir
"
/usr/bin/aports-build
||
return
1
install
-d
"
$pkgdir
"
/etc/init.d
||
return
1
...
...
@@ -52,4 +52,4 @@ package() {
sha512sums
=
"62d12aa79e8d864e2e5a2a742bcd501de1339f9e00e425055fd3e9538f88492cdba406fb5fcb2621e46501cff2412ee91c90c52ad51098925000dae20c7a87ae aports-build
821035bda47152c341ec94bf960fa67e3377051826712ceb74f39103e6e422777b6e082231bfb87865653d2b93b7d3154cfc24abf65a52e3e66da69412dd7e41 aports-build.initd
93d26e2055dbb02e863bf76b64a549c100decec3fda612ce96ca1464e6d61befa9f57f202553a25cf323e67e266f532d19c7423ff070943a59b3973946d949fe mqtt-exec.aports-build.confd
3453e45cb687d2af6cd1c490fd5b7134f643570a84b354b57ba49295e5a0d01ef65abc0909aeb424cbe48aa280c19cc4f1dce5f4f10e5137a80395c3be00c733
report-build-errors.lua"
ded99f4c9474e4dc91605de71919deebbeb8e2e3ebcc9d61890f327bb6220d891a9f2a6c615929cc53bd8007b1a1dbd827bc55cd5cbdd1a6661fcdafa4912950
report-build-errors.lua"
This diff is collapsed.
Click to expand it.
main/aports-build/report-build-errors.lua
+
5
−
3
View file @
eee3f941
...
...
@@ -39,9 +39,11 @@ function m.postbuild(aport, success, repodest, arch, logfile)
run
{
"scp"
,
logfile
,
loghost
..
":"
..
logdir
}
end
local
topic
=
(
"build/%s/errors"
):
format
(
hostname
)
local
payload
=
nil
if
not
success
then
local
topic
=
(
"build/%s/errors"
):
format
(
hostname
)
local
payload
=
json
.
encode
{
payload
=
json
.
encode
{
pkgname
=
aport
.
pkgname
,
hostname
=
hostname
,
reponame
=
aport
:
get_repo_name
(),
...
...
@@ -51,8 +53,8 @@ function m.postbuild(aport, success, repodest, arch, logfile)
aport
.
pkgname
,
aport
.
pkgver
,
aport
.
pkgrel
),
status
=
success
}
publish
.
single
(
topic
,
payload
,
nil
,
nil
,
"msg.alpinelinux.org"
)
end
publish
.
single
(
topic
,
payload
,
nil
,
true
,
"msg.alpinelinux.org"
)
end
return
m
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment