Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
ee2df1dd
Commit
ee2df1dd
authored
8 months ago
by
Sertonix
Committed by
Natanael Copa
8 months ago
Browse files
Options
Downloads
Patches
Plain Diff
community/libnice: enable most tests
parent
62859c00
No related branches found
No related tags found
1 merge request
!68888
community/libnice: enable most tests
Pipeline
#246647
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/libnice/APKBUILD
+9
-3
9 additions, 3 deletions
community/libnice/APKBUILD
community/libnice/test-pseudotcp.patch
+22
-0
22 additions, 0 deletions
community/libnice/test-pseudotcp.patch
with
31 additions
and
3 deletions
community/libnice/APKBUILD
+
9
−
3
View file @
ee2df1dd
...
@@ -5,7 +5,6 @@ pkgname=libnice
...
@@ -5,7 +5,6 @@ pkgname=libnice
pkgver
=
0.1.22
pkgver
=
0.1.22
pkgrel
=
0
pkgrel
=
0
pkgdesc
=
"GLib ICE implementation"
pkgdesc
=
"GLib ICE implementation"
options
=
"!check"
# Testsuite fails
url
=
"https://libnice.freedesktop.org/"
url
=
"https://libnice.freedesktop.org/"
arch
=
"all"
arch
=
"all"
license
=
"LGPL-2.1-or-later AND MPL-1.1"
license
=
"LGPL-2.1-or-later AND MPL-1.1"
...
@@ -20,13 +19,15 @@ subpackages="
...
@@ -20,13 +19,15 @@ subpackages="
$pkgname
-dev
$pkgname
-dev
$pkgname
-gstreamer:_gst"
$pkgname
-gstreamer:_gst"
source
=
"https://nice.freedesktop.org/releases/libnice-
$pkgver
.tar.gz
source
=
"https://nice.freedesktop.org/releases/libnice-
$pkgver
.tar.gz
libnice-meson-0.58.patch "
libnice-meson-0.58.patch
test-pseudotcp.patch
"
build
()
{
build
()
{
abuild-meson
\
abuild-meson
\
-Db_lto
=
true
\
-Db_lto
=
true
\
-Dgtk_doc
=
disabled
\
-Dgtk_doc
=
disabled
\
-Dtests
=
disabled
\
-Dtests
=
"
$(
want_check
&&
echo
enabled
||
echo
disabled
)
"
\
-Dexamples
=
disabled
\
-Dexamples
=
disabled
\
-Dintrospection
=
enabled
\
-Dintrospection
=
enabled
\
-Dcrypto-library
=
gnutls
\
-Dcrypto-library
=
gnutls
\
...
@@ -35,6 +36,10 @@ build() {
...
@@ -35,6 +36,10 @@ build() {
meson compile
-C
builddir
meson compile
-C
builddir
}
}
check
()
{
meson
test
--no-rebuild
--print-errorlogs
-C
builddir
}
package
()
{
package
()
{
DESTDIR
=
"
$pkgdir
"
meson
install
--no-rebuild
-C
builddir
DESTDIR
=
"
$pkgdir
"
meson
install
--no-rebuild
-C
builddir
}
}
...
@@ -47,4 +52,5 @@ _gst() {
...
@@ -47,4 +52,5 @@ _gst() {
sha512sums
=
"
sha512sums
=
"
c3aae2d36d2cec8654b87ecc464296711a4a64335052dfc1477f43f59e90341f7a6a01ebd4edf91a72d9ec425440e6dd0bd8f817c77e03578854e70193b3306b libnice-0.1.22.tar.gz
c3aae2d36d2cec8654b87ecc464296711a4a64335052dfc1477f43f59e90341f7a6a01ebd4edf91a72d9ec425440e6dd0bd8f817c77e03578854e70193b3306b libnice-0.1.22.tar.gz
c59962a20d554da909a993f5d83d8d96da927d0ac94cfef2f699468326509f5715e8f7054badd25d07819b733dcea13c308b72aff170c013f7004dadba960dd7 libnice-meson-0.58.patch
c59962a20d554da909a993f5d83d8d96da927d0ac94cfef2f699468326509f5715e8f7054badd25d07819b733dcea13c308b72aff170c013f7004dadba960dd7 libnice-meson-0.58.patch
c2a7664e441a8f078e82a4557c015894007cf1f332af1055576924e6c5fc583b04bec01d652ae86f438b89ae200094bba391410523761a1911ff8aedf2488d94 test-pseudotcp.patch
"
"
This diff is collapsed.
Click to expand it.
community/libnice/test-pseudotcp.patch
0 → 100644
+
22
−
0
View file @
ee2df1dd
Test failing with 'Socket Closed : 104'
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -1,5 +1,4 @@
nice_tests = [
- 'test-pseudotcp',
# 'test-pseudotcp-fuzzy', FIXME: this test is not reliable, times out sometimes
'test-bsd',
'test',
@@ -89,11 +88,6 @@
if gst_dep.found() and not static_build
endif
endif
-if find_program('sh', required : false).found() and find_program('dd', required : false).found() and find_program('diff', required : false).found()
- test('test-pseudotcp-random', find_program('test-pseudotcp-random.sh'),
- args: test_pseudotcp)
-endif
-
debugenv = environment()
#debugenv.set('G_MESSAGES_DEBUG', 'libnice')
debugenv.set('NICE_DEBUG', 'all')
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment