Skip to content
Snippets Groups Projects
Commit ed1f1e5d authored by alice's avatar alice
Browse files

testing/py3-pygpgme: fix py3.11 build

parent 10631277
No related branches found
No related tags found
No related merge requests found
......@@ -10,7 +10,9 @@ arch="all"
license="LGPL-2.1-or-later"
depends="python3"
makedepends="gpgme-dev python3-dev"
source="$_pkgname-$pkgver.tar.gz::https://github.com/rshk/pygpgme/archive/v$pkgver.tar.gz"
source="$_pkgname-$pkgver.tar.gz::https://github.com/rshk/pygpgme/archive/v$pkgver.tar.gz
py3.11.patch
"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
......@@ -21,4 +23,7 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="f3c9de92956917f5e55c3a8d49be354d845e4f99b3a5173601841afcdd7b9ad270be0dea50468425c517328ceba46f1252685587bcf011287d1ed3a07b7ba8ab pygpgme-0.3.1.tar.gz"
sha512sums="
f3c9de92956917f5e55c3a8d49be354d845e4f99b3a5173601841afcdd7b9ad270be0dea50468425c517328ceba46f1252685587bcf011287d1ed3a07b7ba8ab pygpgme-0.3.1.tar.gz
6e34c4b3001348cc0763f1ad2174244518f36a209bcb7ecdfbf271b9ee9b64014ad1726ce7467ec650f17f05f45730c88241e7a838dd080fc3c8f99209201b06 py3.11.patch
"
diff --git a/src/gpgme.c b/src/gpgme.c
index 7b80c95..8bfe3e9 100644
--- a/src/gpgme.c
+++ b/src/gpgme.c
@@ -46,7 +46,7 @@ create_module(void)
#define INIT_TYPE(type) \
if (!Py_TYPE(&type)) \
- Py_TYPE(&type) = &PyType_Type; \
+ Py_SET_TYPE(&type, &PyType_Type); \
if (!type.tp_alloc) \
type.tp_alloc = PyType_GenericAlloc; \
if (!type.tp_new) \
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment