Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
ecea54f6
Commit
ecea54f6
authored
3 years ago
by
David Demelier
Committed by
Leo
3 years ago
Browse files
Options
Downloads
Patches
Plain Diff
testing/libretro-blastem: remove bundled deps
parent
ef9bb9f5
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!21953
testing/libretro-blastem: remove bundled deps
Pipeline
#83607
passed
3 years ago
Stage: lint
Stage: build
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/libretro-blastem/APKBUILD
+9
-5
9 additions, 5 deletions
testing/libretro-blastem/APKBUILD
testing/libretro-blastem/patch-unbundle.patch
+92
-0
92 additions, 0 deletions
testing/libretro-blastem/patch-unbundle.patch
with
101 additions
and
5 deletions
testing/libretro-blastem/APKBUILD
+
9
−
5
View file @
ecea54f6
...
@@ -2,23 +2,27 @@
...
@@ -2,23 +2,27 @@
# Maintainer: David Demelier <markand@malikania.fr>
# Maintainer: David Demelier <markand@malikania.fr>
pkgname
=
libretro-blastem
pkgname
=
libretro-blastem
pkgver
=
0_git20210312
pkgver
=
0_git20210312
pkgrel
=
0
pkgrel
=
1
_commit
=
"e70b05bf5b5954140cba227fc996ab24c064d494"
_commit
=
"e70b05bf5b5954140cba227fc996ab24c064d494"
pkgdesc
=
"fast and accurate Genesis emulator"
pkgdesc
=
"fast and accurate Genesis emulator"
url
=
"https://github.com/libretro/blastem"
url
=
"https://github.com/libretro/blastem"
arch
=
"all !aarch64 !armv7 !armhf !x86 !mips !mips64"
arch
=
"all !aarch64 !armv7 !armhf !x86 !mips !mips64"
license
=
"GPL-3.0-only"
license
=
"GPL-3.0-only"
makedepends
=
"mesa-dev"
makedepends
=
"mesa-dev zlib-dev"
source
=
"
$pkgname
-
$_commit
.tar.gz::https://github.com/libretro/blastem/archive/
$_commit
.tar.gz"
source
=
"
$pkgname
-
$_commit
.tar.gz::https://github.com/libretro/blastem/archive/
$_commit
.tar.gz
patch-unbundle.patch
"
builddir
=
"
$srcdir
/blastem-
$_commit
"
builddir
=
"
$srcdir
/blastem-
$_commit
"
options
=
"!check"
# No tests
options
=
"!check"
# No tests
build
()
{
build
()
{
make
-f
Makefile.libretro
GIT_VERSION
=
"
$_SCOMMIT
"
rm
-rf
zlib
make
-f
Makefile.libretro
HOST_ZLIB
=
1
}
}
package
()
{
package
()
{
install
-Dm644
"
$builddir
"
/blastem_libretro.so
"
$pkgdir
"
/usr/lib/libretro/blastem_libretro.so
install
-Dm644
"
$builddir
"
/blastem_libretro.so
"
$pkgdir
"
/usr/lib/libretro/blastem_libretro.so
}
}
sha512sums
=
"6b8a47c8eaad455a027a6558be50a6df5414c4c92e87edb5326487e6be5b248b6bfb398ae8c2ff73f535ba20ca1dec1661cceaee23ae50b3676a666758879fb3 libretro-blastem-e70b05bf5b5954140cba227fc996ab24c064d494.tar.gz"
sha512sums
=
"6b8a47c8eaad455a027a6558be50a6df5414c4c92e87edb5326487e6be5b248b6bfb398ae8c2ff73f535ba20ca1dec1661cceaee23ae50b3676a666758879fb3 libretro-blastem-e70b05bf5b5954140cba227fc996ab24c064d494.tar.gz
0ffdbdb9aadc147e971589b162c444ecffa72b297351538ab5546b28088e7e345d61268f9feb143f5620202c6dad4bc4ac5b1ffcd330c99aa8b54065f09cb960 patch-unbundle.patch"
This diff is collapsed.
Click to expand it.
testing/libretro-blastem/patch-unbundle.patch
0 → 100644
+
92
−
0
View file @
ecea54f6
Remove bundled zlib.
--- a/Makefile
+++ b/Makefile
@@ -6,9 +6,6 @@
endif
FIXUP:=true
-BUNDLED_LIBZ:=zlib/adler32.o zlib/compress.o zlib/crc32.o zlib/deflate.o zlib/gzclose.o zlib/gzlib.o zlib/gzread.o\
- zlib/gzwrite.o zlib/infback.o zlib/inffast.o zlib/inflate.o zlib/inftrees.o zlib/trees.o zlib/uncompr.o zlib/zutil.o
-
ifeq ($(OS),Windows)
GLEW_PREFIX:=glew
@@ -74,7 +71,7 @@
endif #Darwin
ifdef HOST_ZLIB
-LIBS+= zlib
+LIBS+= -lz
LIBZOBJS=
else
LIBZOBJS=$(BUNDLED_LIBZ)
--- a/blastem.c
+++ b/blastem.c
@@ -65,7 +65,7 @@
#define romgetc fgetc
#define romclose fclose
#else
-#include "zlib/zlib.h"
+#include <zlib.h>
#define ROMFILE gzFile
#define romopen gzopen
#define romread gzfread
--- a/event_log.c
+++ b/event_log.c
@@ -13,11 +13,13 @@
#include <stdlib.h>
#include <string.h>
#include <errno.h>
+
+#include <zlib.h>
+
#include "event_log.h"
#include "util.h"
#include "blastem.h"
#include "saves.h"
-#include "zlib/zlib.h"
enum {
CMD_GAMEPAD_DOWN,
--- a/event_log.h
+++ b/event_log.h
@@ -1,6 +1,8 @@
#ifndef EVENT_LOG_H_
#define EVENT_LOG_H_
+#include <zlib.h>
+
enum {
EVENT_FLUSH = 0,
EVENT_ADJUST = 1,
@@ -20,7 +22,6 @@
};
#include "serialize.h"
-#include "zlib/zlib.h"
typedef struct {
size_t storage;
uint8_t *socket_buffer;
--- a/png.c
+++ b/png.c
@@ -2,7 +2,8 @@
#include <stdlib.h>
#include <stdio.h>
#include <string.h>
-#include "zlib/zlib.h"
+
+#include <zlib.h>
static const char png_magic[] = {0x89, 'P', 'N', 'G', '\r', '\n', 0x1A, '\n'};
static const char ihdr[] = {'I', 'H', 'D', 'R'};
--- a/zip.c
+++ b/zip.c
@@ -5,7 +5,7 @@
#include "util.h"
#include "zip.h"
#ifndef DISABLE_ZLIB
-#include "zlib/zlib.h"
+#include <zlib.h>
#endif
static const char cdfd_magic[4] = {'P', 'K', 1, 2};
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment