Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
e56dec2e
Commit
e56dec2e
authored
4 years ago
by
TBK
Committed by
Natanael Copa
4 years ago
Browse files
Options
Downloads
Patches
Plain Diff
community/snappy-java: upgrade to 1.1.8.2
parent
8c1b793f
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!16160
community/snappy-java: upgrade to 1.1.8.2
Pipeline
#66298
failed
4 years ago
Stage: lint
Stage: build
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/java-snappy/APKBUILD
+4
-8
4 additions, 8 deletions
community/java-snappy/APKBUILD
community/java-snappy/unbundle-snappy.patch
+8
-8
8 additions, 8 deletions
community/java-snappy/unbundle-snappy.patch
with
12 additions
and
16 deletions
community/java-snappy/APKBUILD
+
4
−
8
View file @
e56dec2e
...
...
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname
=
java-snappy
_pkgname
=
snappy-java
pkgver
=
1.1.
7.3
pkgver
=
1.1.
8.2
_libver
=
${
pkgver
%.*
}
pkgrel
=
0
pkgdesc
=
"Snappy compressor/decompressor for Java"
...
...
@@ -13,7 +13,7 @@ options="!check" # Tests does not work correctly
depends
=
"openjdk8-jre-base"
makedepends
=
"bash openjdk8 perl snappy-dev>=
$_libver
"
subpackages
=
"
$pkgname
-native"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/xerial/
$_pkgname
/archive/
$pkgver
.tar.gz
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/xerial/
snappy-java
/archive/
$pkgver
.tar.gz
unbundle-snappy.patch
"
builddir
=
"
$srcdir
/
$_pkgname
-
$pkgver
"
...
...
@@ -21,8 +21,6 @@ builddir="$srcdir/$_pkgname-$pkgver"
prepare
()
{
default_prepare
cd
"
$builddir
"
# Get rid of bundled native binaries.
rm
-r
src/main/resources/org/xerial/snappy/native
...
...
@@ -33,8 +31,6 @@ prepare() {
}
build
()
{
cd
"
$builddir
"
JAVA_HOME
=
"/usr/lib/jvm/default-jvm"
make
msg
"Downloading SBT and then building JAR (this will take few minutes)..."
...
...
@@ -58,5 +54,5 @@ native() {
ln
-sf
$soname
.
$_libver
"
$subpkgdir
"
/usr/lib/
$soname
}
sha512sums
=
"
ece8d388c62e3c405eba2c9458c6c3d5996c6570189825b02108f87f4c05723161bb6db0ca91dbd509e58fd1830f31c4546a4c211d31fa0efd5b46065e1156a8
java-snappy-1.1.
7.3
.tar.gz
3
53
3a62aefa0f2b9943fa7a360c38c468eb6917fc709ad8ae3de597e91ae8ebe935697a24a7fdbba6ecebe2e416806e35db66cce42570c62f2c880c59c0c6e62
unbundle-snappy.patch"
sha512sums
=
"
28560918927dffe54db7dc0a4cb85b2c585b169faaf4e51f6eb27189f1e67ffde369302527c8cb370b1950e9222295ecb63288f0325601ca41324d5d02088be7
java-snappy-1.1.
8.2
.tar.gz
6
53
1908df96e41b3c31cf6096164803223a81d6eec411b7b98e04ba9c033d387bd3cb00b1d830e923ccbb76492014946055d6fd1651afce2b7df136cfa5acf6c
unbundle-snappy.patch"
This diff is collapsed.
Click to expand it.
community/java-snappy/unbundle-snappy.patch
+
8
−
8
View file @
e56dec2e
...
...
@@ -7,16 +7,16 @@ snappy from the upstream.
--- a/Makefile
+++ b/Makefile
@@ -
8
,7 +
8
,7 @@
@@ -
10
,7 +
10
,7 @@
SNAPPY_OUT:=$(TARGET)/snappy-$(SNAPPY_VERSION)-$(os_arch)
SNAPPY_ARCHIVE:=$(TARGET)/snappy-$(SNAPPY_VERSION).tar.gz
-SNAPPY_CC:=snappy-sinksource.cc snappy-stubs-internal.cc snappy.cc
-SNAPPY_CC:=snappy-sinksource.cc snappy-stubs-internal.cc
snappy-c.cc
snappy.cc
+SNAPPY_CC:=
SNAPPY_SRC_DIR:=$(TARGET)/snappy-$(SNAPPY_VERSION)
SNAPPY_SRC:=$(addprefix $(SNAPPY_SRC_DIR)/,$(SNAPPY_CC))
SNAPPY_GIT_REPO_URL:=https://github.com/google/snappy
@@ -8
4
,9 +8
4
,9 @@
@@ -8
6
,9 +8
6
,9 @@
cd $(SNAPPY_OUT) && cmake $(SNAPPY_CMAKE_OPTS) ../../$(SNAPPY_SRC_DIR)
touch $@
...
...
@@ -29,15 +29,15 @@ snappy from the upstream.
$(TARGET)/jni-classes/org/xerial/snappy/SnappyNative.class: $(SRC)/org/xerial/snappy/SnappyNative.java
@mkdir -p $(TARGET)/jni-classes
@@ -102,7 +102,7 @@
$(SRC)/org/xerial/snappy/BitShuffleNative.h: $(TARGET)/jni-classes/org/xerial/snappy/BitShuffleNative.class
$(JAVAH) -force -classpath $(TARGET)/jni-classes -o $@ org.xerial.snappy.BitShuffleNative
-$(SNAPPY_SRC): $(SNAPPY_GIT_UNPACKED)
+$(SNAPPY_SRC):
# aarch64 can use big-endian optimzied code
ifeq ($(OS_ARCH),aarch64)
@@ -12
2
,7 +12
2
,7 @@
@@ -12
4
,7 +12
4
,7 @@
$(CXX) $(CXXFLAGS) -c $< -o $@
$(SNAPPY_OUT)/$(LIBNAME): $(SNAPPY_OBJ)
...
...
@@ -46,16 +46,16 @@ snappy from the upstream.
# Workaround for strip Protocol error when using VirtualBox on Mac
cp $@ /tmp/$(@F)
$(STRIP) /tmp/$(@F)
@@ -14
2
,7 +14
2
,7 @@
@@ -14
4
,7 +14
4
,7 @@
native: jni-header snappy-header $(NATIVE_DLL)
native-nocmake: jni-header $(NATIVE_DLL)
-snappy: native $(TARGET)/$(snappy-jar-version).jar
+snappy: native
native-all: win32 win64
mac64
native-arm linux32 linux64 linux-ppc64le
linux-aarch64
native-all:
native mac64
win32 win64 native-arm linux32 linux64 linux-ppc64le
@@ -15
1
,6 +15
1
,7 @@
@@ -15
3
,6 +15
3
,7 @@
cp $(SNAPPY_OUT)/$(LIBNAME) $@
@mkdir -p $(NATIVE_TARGET_DIR)
cp $(SNAPPY_OUT)/$(LIBNAME) $(NATIVE_TARGET_DIR)/$(LIBNAME)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment