Skip to content
Snippets Groups Projects
Commit e5115a33 authored by Simon F's avatar Simon F Committed by Leo
Browse files

testing/multimc: use java-provides abstractions

parent 3fa7ce94
No related branches found
No related tags found
1 merge request!20809testing/multimc: use java-provides abstractions
Pipeline #100693 passed
Author: Simon Frankenberger <simon-alpine@fraho.eu>
Subject: Patch to compile for java 8 as java 6 is no longer supported
in modern compilers
--- old/libraries/javacheck/CMakeLists.txt
+++ new/libraries/javacheck/CMakeLists.txt
@@ -4,7 +4,7 @@
include(UseJava)
set(CMAKE_JAVA_JAR_ENTRY_POINT JavaCheck)
-set(CMAKE_JAVA_COMPILE_FLAGS -target 1.6 -source 1.6 -Xlint:deprecation -Xlint:unchecked)
+set(CMAKE_JAVA_COMPILE_FLAGS -target 8 -source 8 -Xlint:deprecation -Xlint:unchecked)
set(SRC
JavaCheck.java
--- old/libraries/launcher/CMakeLists.txt
+++ new/libraries/launcher/CMakeLists.txt
@@ -4,7 +4,7 @@
include(UseJava)
set(CMAKE_JAVA_JAR_ENTRY_POINT org.multimc.EntryPoint)
-set(CMAKE_JAVA_COMPILE_FLAGS -target 1.6 -source 1.6 -Xlint:deprecation -Xlint:unchecked)
+set(CMAKE_JAVA_COMPILE_FLAGS -target 8 -source 8 -Xlint:deprecation -Xlint:unchecked)
set(SRC
org/multimc/EntryPoint.java
......@@ -2,18 +2,18 @@
# Maintainer: Alex Denes <caskd@redxen.eu>
pkgname=multimc
pkgver=0.6.12
pkgrel=2
pkgrel=3
pkgdesc="Custom minecraft launcher that manages parallel installations"
url="https://github.com/MultiMC/MultiMC5"
arch="x86 x86_64" # Officially supported
license="MIT AND LGPL-2.0-or-later AND LGPL-2.1-only AND LGPL-2.1-or-later AND LGPL-3.0-or-later AND BSD-3-Clause-Clear AND OFL-1.0-RFN AND GPL-2.0 WITH Classpath-exception-2.0 AND Apache-2.0"
depends="qt5-qtx11extras qt5-qtsvg openjdk8-jre libxcursor"
depends="qt5-qtx11extras qt5-qtsvg java-jre libxcursor"
makedepends="
cmake
qt5-qtbase-dev
qt5-qtx11extras-dev
zlib-dev
openjdk8
java-jdk
"
_libnbtpluscommit="dc72a20b7efd304d12af2025223fad07b4b78464"
_quazipcommit="3691d57d3af13f49b2be2b62accddefee3c26b9c"
......@@ -22,11 +22,14 @@ source="
libnbtplus-$_libnbtpluscommit.zip::https://github.com/MultiMC/libnbtplusplus/archive/$_libnbtpluscommit.zip
quazip-$_quazipcommit.zip::https://github.com/MultiMC/quazip/archive/$_quazipcommit.zip
01-patch-jar-path.patch
02-java-version-to-8.patch
"
builddir="$srcdir/MultiMC5-$pkgver"
builddir="$srcdir/Launcher-$pkgver"
build() {
export JAVA_HOME=/usr/lib/jvm/java-1.8-openjdk
if [ "$CARCH" = "x86" ]; then
export JAVA_HOME=/usr/lib/jvm/java-1.8-openjdk
fi
mv ../libnbtplusplus-"$_libnbtpluscommit"/* libraries/libnbtplusplus
mv ../quazip-"$_quazipcommit"/* libraries/quazip
if [ "$CBUILD" != "$CHOST" ]; then
......@@ -52,8 +55,9 @@ package() {
make install -C build
}
sha512sums="
2e6a88954f1feac094e1ccecffeb842dfcdbfb99b77647b637f81fe213b7f206d7d76ffc87d52bf7b16f9712048d1196f177f2b5263d9a5bf718e9ce26d9f208 multimc-0.6.12.zip
ddc3adb20cdd9250c773c875bdd2bf5a613ddc7ba5f05e5f9d1e94e1d9b3db3407640c7488624bd378e694956d5c0781ac229f95f7e2047edc4dbd4f6bbc8fd7 multimc-0.6.12.zip
225f18b7cd7b56fbc9914b3e7db652ff98d8af44879cc82ad3ad511ee95d0d05b2b9efd572dea33bcbd8638d0dd80c8bf80c965a3580bc2de2b08cb6db783fd1 libnbtplus-dc72a20b7efd304d12af2025223fad07b4b78464.zip
a00c120fd0e8ad5d72ab261170bc84dc6f2a0eb656af1645ba5aa9087d13d45e623c08cc578afc6f30e6d701524653da0ab619a095e0414949fb2e1fcbcd1413 quazip-3691d57d3af13f49b2be2b62accddefee3c26b9c.zip
b928177fea7d0585facb82c5f40fa12a116a539b909dad47f14b4aaee7c31480475ef2370ea4a2a50ef585f96530a45c3735c082dda0bb33ed24aada4f48b33d 01-patch-jar-path.patch
94073ed0f1f336b66a62e80f75a943c1ecc868041761a051daf12447096b95f6945a29b852414b7b508dbc09fa1572c63b82033f2f119b1416e69551f30b4c1f 02-java-version-to-8.patch
"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment