Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
e130c271
Commit
e130c271
authored
5 months ago
by
Michał Polański
Browse files
Options
Downloads
Patches
Plain Diff
community/py3-passlib: fix for new bcrypt
parent
ae4c51c9
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/py3-passlib/APKBUILD
+8
-3
8 additions, 3 deletions
community/py3-passlib/APKBUILD
community/py3-passlib/bcrypt.patch
+13
-0
13 additions, 0 deletions
community/py3-passlib/bcrypt.patch
with
21 additions
and
3 deletions
community/py3-passlib/APKBUILD
+
8
−
3
View file @
e130c271
...
@@ -2,7 +2,7 @@
...
@@ -2,7 +2,7 @@
# Maintainer: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname
=
py3-passlib
pkgname
=
py3-passlib
pkgver
=
1.7.4
pkgver
=
1.7.4
pkgrel
=
5
pkgrel
=
6
pkgdesc
=
"Password hashing library supporting over 30 schemes"
pkgdesc
=
"Password hashing library supporting over 30 schemes"
url
=
"https://foss.heptapod.net/python-libs/passlib/wikis/home"
url
=
"https://foss.heptapod.net/python-libs/passlib/wikis/home"
arch
=
"noarch"
arch
=
"noarch"
...
@@ -11,7 +11,9 @@ depends="python3"
...
@@ -11,7 +11,9 @@ depends="python3"
makedepends
=
"py3-setuptools"
makedepends
=
"py3-setuptools"
checkdepends
=
"py3-nose py3-scrypt"
checkdepends
=
"py3-nose py3-scrypt"
subpackages
=
"
$pkgname
-pyc"
subpackages
=
"
$pkgname
-pyc"
source
=
"https://files.pythonhosted.org/packages/source/p/passlib/passlib-
$pkgver
.tar.gz"
source
=
"https://files.pythonhosted.org/packages/source/p/passlib/passlib-
$pkgver
.tar.gz
bcrypt.patch
"
builddir
=
"
$srcdir
"
/passlib-
$pkgver
builddir
=
"
$srcdir
"
/passlib-
$pkgver
replaces
=
"py-passlib"
# Backwards compatibility
replaces
=
"py-passlib"
# Backwards compatibility
...
@@ -29,4 +31,7 @@ package() {
...
@@ -29,4 +31,7 @@ package() {
python3 setup.py
install
--skip-build
--root
=
"
$pkgdir
"
python3 setup.py
install
--skip-build
--root
=
"
$pkgdir
"
}
}
sha512sums
=
"350bd6da5ac57e6c266ffe8bf9684c8c2cce3fc6b513eb6c7bc1b302d2d8a1b701e9c01c953782520a2ac37b7ec1f6d7bd5855f99f6ee0e2dbbf33f2d49a9530 passlib-1.7.4.tar.gz"
sha512sums
=
"
350bd6da5ac57e6c266ffe8bf9684c8c2cce3fc6b513eb6c7bc1b302d2d8a1b701e9c01c953782520a2ac37b7ec1f6d7bd5855f99f6ee0e2dbbf33f2d49a9530 passlib-1.7.4.tar.gz
ce9adb6484ab10adc676a76497692e0d20367b13aa5074675c847432e1ea69955e556e81c49486594011cfc90eff5da8515a3d40d6333edbbac4f5d3d5cbfe8e bcrypt.patch
"
This diff is collapsed.
Click to expand it.
community/py3-passlib/bcrypt.patch
0 → 100644
+
13
−
0
View file @
e130c271
See: https://foss.heptapod.net/python-libs/passlib/-/issues/190
--- a/passlib/handlers/bcrypt.py
+++ b/passlib/handlers/bcrypt.py
@@ -617,7 +617,7 @@
except ImportError: # pragma: no cover
return False
try:
- version = _bcrypt.__about__.__version__
+ version = _bcrypt.__version__
except:
log.warning("(trapped) error reading bcrypt version", exc_info=True)
version = '<unknown>'
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment