Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
e11c43c9
Commit
e11c43c9
authored
2 years ago
by
Bart Ribbers
Browse files
Options
Downloads
Patches
Plain Diff
community/plasma-workspace: backport upstream requested patch
Fixes
https://bugs.kde.org/show_bug.cgi?id=453348
parent
9242ed5b
No related branches found
No related tags found
1 merge request
!34539
community/plasma-workspace: backport upstream requested patch
Pipeline
#122673
passed
2 years ago
Stage: lint
Stage: build
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/plasma-workspace/0001-applets-appmenu-fix-top-level-menu-text-coloration.patch
+40
-0
40 additions, 0 deletions
...-applets-appmenu-fix-top-level-menu-text-coloration.patch
community/plasma-workspace/APKBUILD
+5
-2
5 additions, 2 deletions
community/plasma-workspace/APKBUILD
with
45 additions
and
2 deletions
community/plasma-workspace/0001-applets-appmenu-fix-top-level-menu-text-coloration.patch
0 → 100644
+
40
−
0
View file @
e11c43c9
From 4d3f99558cff95259590e70dfbf854a479f772ce Mon Sep 17 00:00:00 2001
From: Nate Graham <nate@kde.org>
Date: Wed, 4 May 2022 10:45:52 -0600
Subject: [PATCH] applets/appmenu: fix top-level menu text coloration
28537cf3ff3cd9210f7568f40334ac3a2c9bed18 made the color dynamic, but
neglected to respect the Plasma color scheme, if any. This causes
problems with Plasma themes that have their own colors and don't
respect the systemwide color scheme, such as Breeze Twilight.
Fix it by using the appropriate colors from the PlasmaCore color scheme
object, not the systemwide object provided by Qt.
BUG: 453348
FIXED-IN: 5.24.6
(cherry picked from commit 19d9bc7e395d8c6e007afdc3b3b5c11a7d02190e)
---
applets/appmenu/package/contents/ui/MenuDelegate.qml | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/applets/appmenu/package/contents/ui/MenuDelegate.qml b/applets/appmenu/package/contents/ui/MenuDelegate.qml
index 441e99016..afb37589a 100644
--- a/applets/appmenu/package/contents/ui/MenuDelegate.qml
+++ b/applets/appmenu/package/contents/ui/MenuDelegate.qml
@@ -66,9 +66,6 @@
AbstractButton {
contentItem: PC3.Label {
text: controlRoot.Kirigami.MnemonicData.richTextLabel
- // Kirigami.Theme.highlightedTextColor returns different colors
- // depending on window focus, which does not apply to this applet
- // instead, we use palette.highlightedText here, which returns consistent result
- color: background.state == MenuDelegate.State.Rest ? palette.windowText : palette.highlightedText
+ color: background.state == MenuDelegate.State.Rest ? PlasmaCore.Theme.textColor : PlasmaCore.Theme.highlightedTextColor
}
}
--
GitLab
This diff is collapsed.
Click to expand it.
community/plasma-workspace/APKBUILD
+
5
−
2
View file @
e11c43c9
...
@@ -2,7 +2,7 @@
...
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname
=
plasma-workspace
pkgname
=
plasma-workspace
pkgver
=
5.24.5
pkgver
=
5.24.5
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"KDE Plasma Workspace"
pkgdesc
=
"KDE Plasma Workspace"
# armhf blocked by kirigami2
# armhf blocked by kirigami2
# s390x and riscv64 blocked by polkit -> kio-extras
# s390x and riscv64 blocked by polkit -> kio-extras
...
@@ -80,7 +80,9 @@ case "$pkgver" in
...
@@ -80,7 +80,9 @@ case "$pkgver" in
*
.90
*
)
_rel
=
unstable
;;
*
.90
*
)
_rel
=
unstable
;;
*
)
_rel
=
stable
;;
*
)
_rel
=
stable
;;
esac
esac
source
=
"https://download.kde.org/
$_rel
/plasma/
$pkgver
/plasma-workspace-
$pkgver
.tar.xz"
source
=
"https://download.kde.org/
$_rel
/plasma/
$pkgver
/plasma-workspace-
$pkgver
.tar.xz
0001-applets-appmenu-fix-top-level-menu-text-coloration.patch
"
subpackages
=
"
$pkgname
-dev
$pkgname
-libs
$pkgname
-doc
$pkgname
-lang
$pkgname
-dbg"
subpackages
=
"
$pkgname
-dev
$pkgname
-libs
$pkgname
-doc
$pkgname
-lang
$pkgname
-dbg"
replaces
=
"plasma-desktop<5.24 breeze<5.22.90"
replaces
=
"plasma-desktop<5.24 breeze<5.22.90"
...
@@ -129,4 +131,5 @@ package() {
...
@@ -129,4 +131,5 @@ package() {
sha512sums
=
"
sha512sums
=
"
ae40fe545b03e42e9f8fe2e8885d3853f4b52d4fd2ed3ecf7d24fa59b4924b8f8b389e8713ec6a3a875bc66df3952de9157d4a5631b283105a9329a1a1825996 plasma-workspace-5.24.5.tar.xz
ae40fe545b03e42e9f8fe2e8885d3853f4b52d4fd2ed3ecf7d24fa59b4924b8f8b389e8713ec6a3a875bc66df3952de9157d4a5631b283105a9329a1a1825996 plasma-workspace-5.24.5.tar.xz
022f1407c538f396cdd1fd9c228a56450ed868e0f16e42333cd10fca238fb5e12b38596f65b06159b573628c290f86d8af8dca136b1acafe4042d4c0d91e8a63 0001-applets-appmenu-fix-top-level-menu-text-coloration.patch
"
"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment