Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
e0dfa9eb
Commit
e0dfa9eb
authored
2 years ago
by
Michał Polański
Browse files
Options
Downloads
Patches
Plain Diff
testing/esptool: upgrade to 4.0
and build with py3-build
parent
a5b31268
No related branches found
No related tags found
1 merge request
!34592
testing/esptool: upgrade to 4.0
Pipeline
#122856
passed
2 years ago
Stage: lint
Stage: build
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/esptool/APKBUILD
+16
-13
16 additions, 13 deletions
testing/esptool/APKBUILD
testing/esptool/remove-py-wheel-requirement.patch
+0
-14
0 additions, 14 deletions
testing/esptool/remove-py-wheel-requirement.patch
with
16 additions
and
27 deletions
testing/esptool/APKBUILD
+
16
−
13
View file @
e0dfa9eb
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname
=
esptool
pkgname
=
esptool
pkgver
=
3.3.1
pkgver
=
4.0
pkgrel
=
0
pkgrel
=
0
pkgdesc
=
"ESP8266 and ESP32 serial bootloader utility"
pkgdesc
=
"ESP8266 and ESP32 serial bootloader utility"
url
=
"https://docs.espressif.com/projects/esptool"
url
=
"https://docs.espressif.com/projects/esptool"
license
=
"GPL-2.0-or-later"
license
=
"GPL-2.0-or-later"
arch
=
"noarch"
arch
=
"noarch"
depends
=
"python3 py3-cryptography py3-ecdsa py3-pyserial py3-bitstring py3-reedsolo"
depends
=
"python3 py3-cryptography py3-ecdsa py3-pyserial py3-bitstring py3-reedsolo"
makedepends
=
"py3-
setuptools
"
makedepends
=
"py3-
build py3-installer py3-setuptools py3-wheel
"
checkdepends
=
"py3-elftools"
checkdepends
=
"py3-elftools"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/espressif/esptool/archive/v
$pkgver
.tar.gz
source
=
"https://github.com/espressif/esptool/archive/v
$pkgver
/esptool-
$pkgver
.tar.gz"
remove-py-wheel-requirement.patch
"
build
()
{
build
()
{
python3
setup.py build
python3
-m
build
--no-isolation
--wheel
}
}
check
()
{
check
()
{
python3
test
/test_imagegen.py
python3
-m
installer
-d
testenv
\
python3
test
/test_espsecure.py
dist/esptool-
$pkgver
-py3-none-any
.whl
python3
test
/test_merge_bin.py
python3
test
/test_modules.py
local
sitedir
=
"
$(
python3
-c
'import site;print(site.getsitepackages()[0])'
)
"
for
test
in
imagegen espsecure merge_bin modules
;
do
PYTHONPATH
=
"
$PWD
/testenv/
$sitedir
"
python3
test
/test_
$test
.py
done
}
}
package
()
{
package
()
{
python3 setup.py
install
--root
=
"
$pkgdir
"
--skip-build
python3
-m
installer
-d
"
$pkgdir
"
\
dist/esptool-
$pkgver
-py3-none-any
.whl
}
}
sha512sums
=
"
sha512sums
=
"
8da34f7b555513d499141ce403f19c3e77b6944eecde440c757faf3bbf5e915e44ff0bcabf1b2cb7f5fe26caa717bb47104ad808c46feaf1dea254d548048095 esptool-3.3.1.tar.gz
79964c42b812af58cdcb4ddf67fd9f54645d5027bb0c48da545e759465201d14e9b87558e2424aace063b1db37ac6af57b414752b10864adc9d611a5c9b337ea esptool-4.0.tar.gz
3474afb4b455c93d705334ea81450b21f2ff29858d266a9a4c157857cc7cc35ef7e8fe36758b64679f93d02b3d6647c32b36926051f2b8afa7dfeb0de82b3c4a remove-py-wheel-requirement.patch
"
"
This diff is collapsed.
Click to expand it.
testing/esptool/remove-py-wheel-requirement.patch
deleted
100644 → 0
+
0
−
14
View file @
a5b31268
--- a/setup.py
+++ b/setup.py
@@ -110,11 +110,6 @@
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
],
- setup_requires=(
- ['wheel']
- if 'bdist_wheel' in sys.argv and sys.version_info[0:2] not in [(3, 4), (3, 5)] else
- []
- ),
extras_require={
"dev": [
'flake8>=3.2.0',
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment