Skip to content
Snippets Groups Projects
Commit dfd33d0f authored by Oliver Smith's avatar Oliver Smith Committed by Leo
Browse files

community/calls: upgrade to 0.2.0

Calls is broken since its dependency libcallaudio-0 has been upgraded to
libcallaudio-0.1. Upgrade to latest version and add patches from
upstream MR on top to build against libcallaudio-0.1.

Fixes:
  / # apk add calls
  ERROR: unable to select packages:
    so:libcallaudio-0.so.0 (no such package):
      required by: calls-0.1.9-r0[so:libcallaudio-0.so.0]

Related: https://source.puri.sm/Librem5/calls/-/merge_requests/230
parent 5a1af549
No related branches found
No related tags found
1 merge request!17034community/calls: upgrade to 0.2.0
Upstream: https://source.puri.sm/Librem5/calls/-/merge_requests/230
From 1b1588eb00fb716250c4875e82bc6d5f4e11bf58 Mon Sep 17 00:00:00 2001
From: Arnaud Ferraris <arnaud.ferraris@collabora.com>
Date: Tue, 12 Jan 2021 18:40:12 +0100
Subject: [PATCH 1/2] call-display: update libcallaudio API calls
Upstream modified the async API, make sure we use it.
---
src/calls-call-display.c | 10 +++++++---
1 file changed, 7 insertions(+), 3 deletions(-)
diff --git a/src/calls-call-display.c b/src/calls-call-display.c
index 7d17772..2bfb8fc 100644
--- a/src/calls-call-display.c
+++ b/src/calls-call-display.c
@@ -211,7 +211,7 @@ stop_timeout (CallsCallDisplay *self)
static void
-select_mode_complete (gboolean success, GError *error)
+select_mode_complete (gboolean success, GError *error, gpointer data)
{
if (error)
{
@@ -261,11 +261,15 @@ call_state_changed_cb (CallsCallDisplay *self,
state != CALLS_CALL_STATE_DIALING
&& state != CALLS_CALL_STATE_ALERTING);
- call_audio_select_mode_async (CALL_AUDIO_MODE_CALL, select_mode_complete);
+ call_audio_select_mode_async (CALL_AUDIO_MODE_CALL,
+ select_mode_complete,
+ NULL);
break;
case CALLS_CALL_STATE_DISCONNECTED:
- call_audio_select_mode_async (CALL_AUDIO_MODE_DEFAULT, select_mode_complete);
+ call_audio_select_mode_async (CALL_AUDIO_MODE_DEFAULT,
+ select_mode_complete,
+ NULL);
break;
}
--
2.26.2
Upstream: https://source.puri.sm/Librem5/calls/-/merge_requests/230
From 26dd9427d4625c8d86f739447267521cd9ff787a Mon Sep 17 00:00:00 2001
From: Arnaud Ferraris <arnaud.ferraris@collabora.com>
Date: Tue, 12 Jan 2021 18:42:29 +0100
Subject: [PATCH 2/2] src: meson.build: update libcallaudio dependency
---
src/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/meson.build b/src/meson.build
index 6222432..9be8cd8 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -36,7 +36,7 @@ calls_deps = [ dependency('gobject-2.0', version: '>= 2.58'),
dependency('gom-1.0'),
dependency('libebook-contacts-1.2'),
dependency('folks'),
- dependency('libcallaudio-0'),
+ dependency('libcallaudio-0.1'),
]
if wl_scanner.found()
--
2.26.2
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=calls
pkgver=0.1.9
pkgver=0.2.0
pkgrel=0
pkgdesc="A phone dialer and call handler"
arch="all !s390x !mips !mips64" # Blocked by libhandy
......@@ -13,7 +13,9 @@ makedepends="meson ninja vala gettext-dev gobject-introspection-dev gtk+3.0-dev
feedbackd-dev callaudiod-dev"
subpackages="$pkgname-lang"
source="https://source.puri.sm/Librem5/calls/-/archive/v$pkgver/calls-v$pkgver.tar.gz
fix-meson.patch"
0001-call-display-update-libcallaudio-API-calls.patch
0002-src-meson.build-update-libcallaudio-dependency.patch
"
options="!check" # Requires running Wayland compositor
builddir="$srcdir/$pkgname-v$pkgver"
......@@ -29,5 +31,6 @@ check() {
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
sha512sums="89a5063159593094e3d6e19c14258abe682edf7331ddbc4585baf4043763fca2a3a89322ee72285d644ad9420e5848f8ca6dc89225a726a5524abbe6d5ec3d57 calls-v0.1.9.tar.gz
6cf822b0bc9a6c63c21436cfde3b3a07d1d4dde34eb385a8a2c21fc04337371f4ecd4f6f83113a7bb7c50bc79c146ef840ea4b15308054a12496eb1dbf7f35cd fix-meson.patch"
sha512sums="d89c725294779e294d53b51af7b1f63029f1dc44bc6fb28fa2e866bccbb49e1e42cb7c6870957d4bfc23ae61d265e0bebda0eaf33339c4a6701851af7d28ea08 calls-v0.2.0.tar.gz
ef324847f01ad2dec6961f6df1a6a9d41b2bd6532a9785d836b00aa1ed9ee5b8cca0bb9c2013cf8bf307eda0bbf8502b9781c6eeacf0ef14ad58b591a89d9985 0001-call-display-update-libcallaudio-API-calls.patch
84de4fa9ce4f28ec985ca4e0052b9e80fd7367fbd661ba3b0f12f2bc453f6520ac36309058981deeefb73b9d3802f468a0e9b9ec67a21365ba717ab03c8b980d 0002-src-meson.build-update-libcallaudio-dependency.patch"
--- a/meson.build 2020-11-04 12:08:29.000000000 -0500
+++ b/meson.build 2020-11-09 10:08:52.042651725 -0500
@@ -22,7 +22,7 @@
project(
'calls',
'c', 'vala',
- version: '0.1.8',
+ version: '0.1.9',
license: 'GPLv3+',
meson_version: '>= 0.47.0',
default_options: [
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment