Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
df80a9ed
Commit
df80a9ed
authored
7 months ago
by
mio
Committed by
omni
7 months ago
Browse files
Options
Downloads
Patches
Plain Diff
community/scanssh: fix build with gcc 14
parent
7d885ba7
No related branches found
No related tags found
1 merge request
!71572
community/scanssh: fix build with gcc 14
Pipeline
#257270
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/scanssh/APKBUILD
+5
-2
5 additions, 2 deletions
community/scanssh/APKBUILD
community/scanssh/gcc14.patch
+20
-0
20 additions, 0 deletions
community/scanssh/gcc14.patch
with
25 additions
and
2 deletions
community/scanssh/APKBUILD
+
5
−
2
View file @
df80a9ed
...
...
@@ -2,7 +2,7 @@
# Maintainer: fossdd <fossdd@pwned.life>
pkgname
=
scanssh
pkgver
=
2.1.3.1
pkgrel
=
2
pkgrel
=
3
pkgdesc
=
"Fast SSH server and open proxy scanner"
url
=
"https://github.com/ofalk/scanssh"
arch
=
"all"
...
...
@@ -10,7 +10,9 @@ license="BSD-3-Clause"
options
=
"!check"
# no testsuite
makedepends
=
"autoconf automake libpcap-dev libevent-dev libdnet-dev"
subpackages
=
"
$pkgname
-doc"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/ofalk/scanssh/archive/
$pkgver
.tar.gz"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/ofalk/scanssh/archive/
$pkgver
.tar.gz
gcc14.patch
"
prepare
()
{
default_prepare
...
...
@@ -33,4 +35,5 @@ package() {
sha512sums
=
"
970cbb03aa44fcef62aa03132335e6ecedb083cee98a360b3d781efc8c2d3c169f70c17837b1faaf9ceaa2691a7c619174a9bb185146af50188eaceda5d14adb scanssh-2.1.3.1.tar.gz
72b136f29ce041a7111be2896a5471469eab90c8c8fdfd4eb05fd294796afd9804adc3dc07c894a559cbf16679184ce00b713b0394e9a9a399b587d7f6daa231 gcc14.patch
"
This diff is collapsed.
Click to expand it.
community/scanssh/gcc14.patch
0 → 100644
+
20
−
0
View file @
df80a9ed
Fix -Wimplicit-function-declaration error with gcc 14.
Error:
```
arc4random.c:19:25: error: implicit declaration of function 'time'
[-Wimplicit-function-declaration]
19 | srandom(time(NULL));
| ^~~~
```
--- scanssh-2.1.3.1-origin/arc4random.c
+++ scanssh-2.1.3.1/arc4random.c
@@ -1,5 +1,6 @@
#include <sys/types.h>
#include <stdlib.h>
+#include <time.h>
#include "config.h"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment