Skip to content
Snippets Groups Projects
Commit d8de85d6 authored by Leo's avatar Leo
Browse files

community/collectd: fix linking with python3.8

fixes #12393
parent 3d657543
No related branches found
No related tags found
6 merge requests!202783.13 vala,!192543.13 gptfdisk,!191533.13 privoxy,!190083.13 openjpeg,!183543.13 webkit2gtk,!17862community/collectd: fix linking with python3.8
......@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=collectd
pkgver=5.9.2
pkgrel=2
pkgrel=3
pkgdesc="The system statistics collection daemon"
options="!check" # test_common fails
url="https://collectd.org/"
......@@ -28,6 +28,7 @@ install="$pkgname.pre-install"
source="https://github.com/collectd/collectd/releases/download/collectd-$pkgver/collectd-$pkgver.tar.bz2
collectd.initd
gnu_source.patch
fix-python38.patch
"
# secfixes:
......@@ -129,4 +130,5 @@ dns() { _plugin dns; }
sha512sums="5386e4d0b9c350a0719924bf440f53bf3cdedefefe6bc7b154501dfdf7d2d98fa5dd31341cbed41023f7a129f68bda694e9d06f2da69ea2e61372d1b237b64a7 collectd-5.9.2.tar.bz2
a286c2164af196154d017658d6e5aa3cc4f76dadf90b68c3021418979d9f0377776bb990d737ae5c916c04475725365aea8b78e3bc5e2f3679d5a99f8b9af13e collectd.initd
3078e43fc1aa5e5d5f7042472f465cc3b077c59f43a9867ade038e59bb210f26f53bb9a1e1e8a198ca53939a4b2e03a1f05628aa54f826746f970faa36acff6a gnu_source.patch"
3078e43fc1aa5e5d5f7042472f465cc3b077c59f43a9867ade038e59bb210f26f53bb9a1e1e8a198ca53939a4b2e03a1f05628aa54f826746f970faa36acff6a gnu_source.patch
ea82c65277ec8c153de63f3c3567f5b21577cedc368b33b0b109a73b63a7137ffd09f9520b5b67a9794bba66ed6f9a84099d1af536bd445f08a8c373ea33c6f1 fix-python38.patch"
From 071af20ddcde3b58ddceacfd6eb95b6756af4323 Mon Sep 17 00:00:00 2001
From: Alexander Meshcheryakov <Self-Perfection@users.noreply.github.com>
Date: Sat, 16 Nov 2019 17:53:32 +0300
Subject: [PATCH] Fix linking with Python 3.8
Since Python 3.8 --embed flag needs to be provided to python-config to embed python.
Reference: https://bugs.python.org/issue36721
This was partially addressed in #3170 but only fixed building and not linking with python.
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 9fc40b17df..00e1f6a53e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4711,7 +4711,7 @@ if test "$PYTHON_CONFIG" != ""; then
if test $? -ne 0; then
with_libpython="no"
fi
- LIBPYTHON_LDFLAGS="`${PYTHON_CONFIG} --ldflags`"
+ LIBPYTHON_LDFLAGS="`${PYTHON_CONFIG} --ldflags --embed`" || LIBPYTHON_LDFLAGS="`${PYTHON_CONFIG} --ldflags`"
if test $? -ne 0; then
with_libpython="no"
fi
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment