Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
d5954824
Commit
d5954824
authored
2 months ago
by
Kaarle Ritvanen
Browse files
Options
Downloads
Patches
Plain Diff
main/awall: upgrade to 1.13.0
parent
d1bff4aa
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/awall/0001-iptables-fix-compat-with-legacy.patch
+0
-46
0 additions, 46 deletions
main/awall/0001-iptables-fix-compat-with-legacy.patch
main/awall/APKBUILD
+2
-4
2 additions, 4 deletions
main/awall/APKBUILD
with
2 additions
and
50 deletions
main/awall/0001-iptables-fix-compat-with-legacy.patch
deleted
100644 → 0
+
0
−
46
View file @
d1bff4aa
From c9ddcc6866f55956bf4b39715e237f45d1a533b3 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Mon, 15 Jul 2024 17:58:33 +0200
Subject: [PATCH] iptables: fix compat with legacy
Fix case where iptables binary uses nft backend in LXC container.
iptables-save may not output anything at all, while
/proc/net/ip_tables_names exists, so we check for both before concluding
that firewall is not enabled in kernel. More importantly, it prevents
awall activate --force to exit with failure.
fixes commit 49e6185321fc (iptables: fix to work with nft backend)
---
awall/iptables.lua | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/awall/iptables.lua b/awall/iptables.lua
index 754f076..d41553b 100644
--- a/awall/iptables.lua
+++ b/awall/iptables.lua
@@ -23,10 +23,10 @@
local M = {}
local families = {
inet={
- cmd='iptables', file='rules-save'
+ cmd='iptables', file='rules-save', procfile='/proc/net/ip_tables_names'
},
inet6={
- cmd='ip6tables', file='rules6-save'
+ cmd='ip6tables', file='rules6-save', procfile='/proc/net/ip6_tables_names'
}
}
@@ -64,7 +64,7 @@
local function actfamilies()
if _actfamilies then return _actfamilies end
_actfamilies = {}
for _, family in ipairs(ACTIVE) do
- if #acttables(family) > 0 then
+ if posix.stat(families[family].procfile) or #acttables(family) > 0 then
table.insert(_actfamilies, family)
else printmsg('Warning: firewall not enabled for '..family) end
end
--
2.45.2
This diff is collapsed.
Click to expand it.
main/awall/APKBUILD
+
2
−
4
View file @
d5954824
# Contributor: Kaarle Ritvanen <kunkku@alpinelinux.org>
# Maintainer: Kaarle Ritvanen <kunkku@alpinelinux.org>
pkgname
=
awall
pkgver
=
1.1
2.4
pkgver
=
1.1
3.0
pkgrel
=
0
pkgdesc
=
"Alpine Wall"
url
=
"https://gitlab.alpinelinux.org/alpine/awall"
...
...
@@ -15,7 +15,6 @@ depends="drill ipset iptables lua$_luaver lua$_luaver-alt-getopt
subpackages
=
"
$pkgname
-masquerade
$pkgname
-policies"
triggers
=
"
$pkgname
.trigger=/usr/share/awall"
source
=
"https://gitlab.alpinelinux.org/alpine/awall/-/archive/v
$pkgver
/awall-v
$pkgver
.tar.bz2
0001-iptables-fix-compat-with-legacy.patch
awall-init
setup-firewall
"
...
...
@@ -52,8 +51,7 @@ policies() {
}
sha512sums
=
"
647c766098db44a22ee55a91fed56f26c31ebd64c2daf6c00d6c1b73d9158e71ed4280baf0c2361e3c3a60edb9182d26dda7efde6b7db62635ec280acb8d930a awall-v1.12.4.tar.bz2
deef6a4f62cd345d4f76cd53de98f1a6ecf18f81e89a7d528afc36b8e45aac9f2fc0370c2a3ffe6cb4aaab48a698088f9b8334d241d014ec2c29943bfecf066d 0001-iptables-fix-compat-with-legacy.patch
b25c704e6cc83d9ea0fa01007dfb39310887d23bcda96533c21708cdd30043ccbd788e18e8b0c0cc39b7e1f606ca9c924ebc1fcdbf4114ae8c4b4fbc31509bce awall-v1.13.0.tar.bz2
e83ea3281c298092530e45fa5b62f6f85b9e5109b11e109799465ea832608294c7d9c4c3f5b0f321dfc0e82040daf3a17d066e9dea65cb0dbae2c453ea9e62cd awall-init
ab67a2b31ee3d232620c9f8679292c6d6d9885cde80feaafc0eaf480a3bf75eca588a62a30e0e6152a689e35b1283e94c8710aa7e4cd3728ffaca88a1d064028 setup-firewall
"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment