Skip to content
Snippets Groups Projects
Commit d30a2b9e authored by Leonardo Arena's avatar Leonardo Arena Committed by Leonardo Arena
Browse files

main/multipath-tools: add upstream patch for fixing ppc64le and s390x builds

parent 5e8bc0df
No related branches found
No related tags found
1 merge request!79782main/multipath-tools: add upstream patch for fixing ppc64le and s390x builds
Pipeline #298127 skipped
From 9e5eb152f9140b63e4f567e9b80063c8c6d4e368 Mon Sep 17 00:00:00 2001
From: Leonardo Arena <rnalrd@alpinelinux.org>
Date: Thu, 6 Feb 2025 10:10:06 +0000
Subject: [PATCH] disable Werror-implicit-function-declaration
fix s390x and ppc64le builds
---
Makefile.inc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.inc b/Makefile.inc
index 729618b..f0fbd6f 100644
--- a/Makefile.inc
+++ b/Makefile.inc
@@ -106,7 +106,7 @@ WARN_ONLY :=
ERROR := $(if $(WARN_ONLY),,error=)
WERROR := $(if $(WARN_ONLY),,-Werror)
WARNFLAGS := $(WERROR) -Wall -Wextra -Wformat=2 $(WFORMATOVERFLOW) -W$(ERROR)implicit-int \
- -W$(ERROR)implicit-function-declaration -W$(ERROR)format-security \
+ -Wno-error=implicit-function-declaration -W$(ERROR)format-security \
$(WNOCLOBBERED) -W$(ERROR)cast-qual $(ERROR_DISCARDED_QUALIFIERS) $(W_URCU_TYPE_LIMITS)
CPPFLAGS := $(FORTIFY_OPT) $(CPPFLAGS) $(D_URCU_VERSION) \
--
2.47.1
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=multipath-tools
pkgver=0.11.1
pkgrel=0
pkgrel=1
pkgdesc="Device Mapper Multipathing Driver"
url="http://christophe.varoqui.free.fr/"
arch="all"
......@@ -26,7 +26,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/opensvc/multipath-tools/arch
multipathd.initd
multipathd.confd
0001-Disable-O2.patch
0002-disable-Werror-implicit-function-declaration.patch
fix-implicit-function-declaration-error.patch
fix-basename.patch
"
......@@ -67,6 +67,6 @@ e81462b22c0cbc92ea935d7544b9f9a0c4ccbcf13f3bc03dadf6de96407c9cf49964c9bbf02f12a1
17853ca127259e129bbd61f24a830777d5b6d69f6500313fa62a0e0773de73387ce2c3a58a93a6182ee3d4891d1ec5fc2322cb674e787b326ef9cd8dcff5cbab multipathd.initd
2adc2b8322645fec8763a662614b5682294f81dc0f1b9cacace5e5ea62125aa80f4874c1b10f11619e79871087846a946f7a383c22953ca1fbaeb9ea021c5114 multipathd.confd
12efc27a7fd492834dd1d86d67faa1a6884142779f5452ada5373d893cd441572e07f9f9ea441dd92d49274ccc21a53d70f2af8a49c63060ff7490b93e3cb58d 0001-Disable-O2.patch
749aba944316eeeb3d3be84ef597a0f2fb631efa3cb3641f543d1a9196a892b4ad39d0532db9594b5dda89543d4fd1d7dda4a2d59827332cb9a736a72a1dd24c 0002-disable-Werror-implicit-function-declaration.patch
b4ef63f5cde2ff700fa5933280c4017056f0d04660889620ed215b23c35e79daf9e0330bd946109c410f33b718d0503e1a1189c12cbdc299e7721b59aff56cf8 fix-implicit-function-declaration-error.patch
3f65a2006c03ba168eb3fcec537042ae9e0ddbcab48a051970fcc477bd88b2eeb16db79c9f06d4fc7b7e06411d46e159b7d13d2fe9613ba5be1ed68d9e66e54c fix-basename.patch
"
From: Benjamin Marzinski @ 2025-02-11 18:11 UTC (permalink / raw)
To: Christophe Varoqui; +Cc: device-mapper development, Martin Wilck
urcu/atomic.h requires some header files included by urcu.h. Make sure
to include it first.
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
---
libmultipath/checkers/tur.c | 1 +
libmultipath/lock.h | 1 +
2 files changed, 2 insertions(+)
diff --git a/libmultipath/checkers/tur.c b/libmultipath/checkers/tur.c
index e70a2e11..0010acf8 100644
--- a/libmultipath/checkers/tur.c
+++ b/libmultipath/checkers/tur.c
@@ -15,6 +15,7 @@
#include <errno.h>
#include <sys/time.h>
#include <pthread.h>
+#include <urcu.h>
#include <urcu/uatomic.h>
#include "checkers.h"
diff --git a/libmultipath/lock.h b/libmultipath/lock.h
index 38473a8c..5f323055 100644
--- a/libmultipath/lock.h
+++ b/libmultipath/lock.h
@@ -2,6 +2,7 @@
#define LOCK_H_INCLUDED
#include <pthread.h>
+#include <urcu.h>
#include <urcu/uatomic.h>
#include <stdbool.h>
--
2.48.1
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment