Skip to content
Snippets Groups Projects
Commit cd373a5b authored by mio's avatar mio Committed by omni
Browse files

community/torsocks: fix build with gcc 14

parent 603580e0
No related branches found
No related tags found
1 merge request!71617community/torsocks: fix build with gcc 14
Pipeline #257453 skipped
......@@ -2,7 +2,7 @@
# Maintainer: omni <omni+alpine@hack.org>
pkgname=torsocks
pkgver=2.4.0
pkgrel=0
pkgrel=1
pkgdesc="Wrapper to safely torify applications"
url="https://gitlab.torproject.org/tpo/core/torsocks"
arch="all"
......@@ -10,6 +10,7 @@ license="GPL-2.0"
makedepends="$depends_dev autoconf automake libtool"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://gitlab.torproject.org/tpo/core/torsocks/-/archive/v$pkgver/torsocks-v$pkgver.tar.gz
gcc14-fix-compatibility-with-c99.patch
configure.ac-update-version-to-2.4.0.patch
"
builddir="$srcdir/$pkgname-v$pkgver"
......@@ -36,5 +37,6 @@ package() {
sha512sums="
7d625ce3a4600f87b86ae9ac79dfd206e7709cb0bafe0b7afcf33a6f1825f968cc63ad3e23c584582b244647bdeafbfdbfc54f7c81e521b0a3d278a1483ce86e torsocks-2.4.0.tar.gz
fa9d1a2c2e9a0ce60d4cd449cd529e8949a5ad3b4923f74708e43a316b797eec88c1f198558e357e72eec59b76e73570e4b867923f695afe25219c8606303b7e gcc14-fix-compatibility-with-c99.patch
840ee977ed9459a921b082d408314c6f8e24efe83b140cdb2448e60aaf1b398d5535830c73bf9007c513e5a14dc47ae23f7dad6d726563be52b5cf0cd57b634f configure.ac-update-version-to-2.4.0.patch
"
Source: https://gitlab.torproject.org/tpo/core/torsocks/-/merge_requests/9.patch
--
From 1171bf2fd4e7a0cab02cf5fca59090b65af9cd29 Mon Sep 17 00:00:00 2001
From: Florian Weimer <fw@deneb.enyo.de>
Date: Wed, 20 Sep 2023 18:28:32 +0200
Subject: [PATCH] fix compatibility with C99
---
src/common/config-file.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/common/config-file.h b/src/common/config-file.h
index 23e1c89..e710c20 100644
--- a/src/common/config-file.h
+++ b/src/common/config-file.h
@@ -109,6 +109,7 @@ int conf_file_set_allow_inbound(const char *val, struct configuration *config);
int conf_file_set_allow_outbound_localhost(const char *val, struct
configuration *config);
int conf_file_set_isolate_pid(const char *val, struct configuration *config);
+int conf_file_set_enable_ipv6(const char *val, struct configuration *config);
int conf_apply_socks_auth(struct configuration *config);
--
GitLab
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment