Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
c96e25eb
Commit
c96e25eb
authored
7 years ago
by
A. Wilcox
Committed by
Ariadne Conill
7 years ago
Browse files
Options
Downloads
Patches
Plain Diff
main/automake: add check
parent
8b871635
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
main/alsa-lib/APKBUILD
+11
-4
11 additions, 4 deletions
main/alsa-lib/APKBUILD
main/alsa-lib/remove-test.patch
+80
-0
80 additions, 0 deletions
main/alsa-lib/remove-test.patch
main/automake/APKBUILD
+7
-1
7 additions, 1 deletion
main/automake/APKBUILD
with
98 additions
and
5 deletions
main/alsa-lib/APKBUILD
+
11
−
4
View file @
c96e25eb
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
alsa-lib
pkgver
=
1.1.4.1
pkgrel
=
2
pkgrel
=
3
pkgdesc
=
"An alternative implementation of Linux sound support"
url
=
"http://www.alsa-project.org"
arch
=
"all"
...
...
@@ -13,12 +13,13 @@ source="ftp://ftp.alsa-project.org/pub/lib/$pkgname-$pkgver.tar.bz2
alsa-lib-stdint.patch
ucm_add_limits_h.patch
0001-snd_user_file-avoid-use-wordexp.patch
remove-test.patch
"
builddir
=
"
$srcdir
/
$pkgname
-
$pkgver
"
prepare
()
{
cd
"
$builddir
"
update_config_sub
||
return
1
update_config_sub
rm
src/compat/hsearch_r.c
&&
touch
src/compat/hsearch_r.c
default_prepare
}
...
...
@@ -40,8 +41,13 @@ build() {
make
}
check
()
{
cd
"
$builddir
"
make check
}
package
()
{
cd
"
$
srcdir
/
$pkgname
-
$pkgve
r
"
cd
"
$
builddi
r
"
make
-j1
DESTDIR
=
"
$pkgdir
"
install
}
...
...
@@ -49,4 +55,5 @@ sha512sums="7b548c4ee29c4a1230a0edcd5d19219831290f96a214180a6530628acc05278d1348
bdf86a1b76b2e6e9b43af33989fe51e4900fa0c6f317d8d746f30c540df647dbe0f6d41ec35b36b1cf7e46cc5e910e0a62bc39c765f849356ecd6e98d1de5885 alsa-lib-poll.patch
2351262dade9a3c1a3de1b7d1a3a53a634a438b9b8aae7cc69e2b981500051f039e6381359b81392114ec6236e3d513b577bd4bf12c3d2ce1f871cd7651b2cab alsa-lib-stdint.patch
3b37652d50809443b5f8e80f8d447108195b0cd66fd917805bb393fc091584b6f3dad4414f568742b61745617e7a695862058a0a0f93dcc31e4c97177a520352 ucm_add_limits_h.patch
e6baeee549533ea4b113bacfa772c183456ce51e6c84b378b82a6735159e43a11ff30c0a4a15207110c42dbd7be5e67bc5e2f593cdc99bd8b079204df7498ceb 0001-snd_user_file-avoid-use-wordexp.patch"
e6baeee549533ea4b113bacfa772c183456ce51e6c84b378b82a6735159e43a11ff30c0a4a15207110c42dbd7be5e67bc5e2f593cdc99bd8b079204df7498ceb 0001-snd_user_file-avoid-use-wordexp.patch
8ef518517647b702da7f3573f4f3f10be8bbac3f092834b38c59521f7236acae258a9afe65eebfa415828135ac8a1836e3dce83ee3f0eaf4403158a48802144d remove-test.patch"
This diff is collapsed.
Click to expand it.
main/alsa-lib/remove-test.patch
0 → 100644
+
80
−
0
View file @
c96e25eb
--- alsa-lib-1.1.4.1/test/Makefile.am.old 2017-06-01 01:27:36.000000000 -0500
+++ alsa-lib-1.1.4.1/test/Makefile.am 2017-09-27 00:55:12.925058726 -0500
@@ -2,7 +2,7 @@
check_PROGRAMS=control pcm pcm_min latency seq \
playmidi1 timer rawmidi midiloop \
- oldapi queue_timer namehint client_event_filter \
+ queue_timer namehint client_event_filter \
chmap audio_time user-ctl-element-set pcm-multi-thread
control_LDADD=../src/libasound.la
@@ -16,7 +16,6 @@
timer_LDADD=../src/libasound.la
rawmidi_LDADD=../src/libasound.la
midiloop_LDADD=../src/libasound.la
-oldapi_LDADD=../src/libasound.la
queue_timer_LDADD=../src/libasound.la
namehint_LDADD=../src/libasound.la
client_event_filter_LDADD=../src/libasound.la
--- alsa-lib-1.1.4.1/test/Makefile.in.old 2017-06-01 01:28:25.000000000 -0500
+++ alsa-lib-1.1.4.1/test/Makefile.in 2017-09-27 00:58:29.668332253 -0500
@@ -52,7 +52,7 @@
check_PROGRAMS = control$(EXEEXT) pcm$(EXEEXT) pcm_min$(EXEEXT) \
latency$(EXEEXT) seq$(EXEEXT) playmidi1$(EXEEXT) \
timer$(EXEEXT) rawmidi$(EXEEXT) midiloop$(EXEEXT) \
- oldapi$(EXEEXT) queue_timer$(EXEEXT) namehint$(EXEEXT) \
+ queue_timer$(EXEEXT) namehint$(EXEEXT) \
client_event_filter$(EXEEXT) chmap$(EXEEXT) \
audio_time$(EXEEXT) user-ctl-element-set$(EXEEXT) \
pcm-multi-thread$(EXEEXT)
@@ -96,9 +96,6 @@
namehint_SOURCES = namehint.c
namehint_OBJECTS = namehint.$(OBJEXT)
namehint_DEPENDENCIES = ../src/libasound.la
-oldapi_SOURCES = oldapi.c
-oldapi_OBJECTS = oldapi.$(OBJEXT)
-oldapi_DEPENDENCIES = ../src/libasound.la
pcm_SOURCES = pcm.c
pcm_OBJECTS = pcm.$(OBJEXT)
pcm_DEPENDENCIES = ../src/libasound.la
@@ -173,11 +170,11 @@
am__v_CCLD_0 = @echo " CCLD " $@;
am__v_CCLD_1 =
SOURCES = audio_time.c chmap.c client_event_filter.c control.c \
- latency.c midiloop.c namehint.c oldapi.c pcm.c \
+ latency.c midiloop.c namehint.c pcm.c \
pcm-multi-thread.c pcm_min.c playmidi1.c queue_timer.c \
rawmidi.c seq.c timer.c user-ctl-element-set.c
DIST_SOURCES = audio_time.c chmap.c client_event_filter.c control.c \
- latency.c midiloop.c namehint.c oldapi.c pcm.c \
+ latency.c midiloop.c namehint.c pcm.c \
pcm-multi-thread.c pcm_min.c playmidi1.c queue_timer.c \
rawmidi.c seq.c timer.c user-ctl-element-set.c
RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
@@ -366,7 +363,6 @@
timer_LDADD = ../src/libasound.la
rawmidi_LDADD = ../src/libasound.la
midiloop_LDADD = ../src/libasound.la
-oldapi_LDADD = ../src/libasound.la
queue_timer_LDADD = ../src/libasound.la
namehint_LDADD = ../src/libasound.la
client_event_filter_LDADD = ../src/libasound.la
@@ -444,9 +440,6 @@
namehint$(EXEEXT): $(namehint_OBJECTS) $(namehint_DEPENDENCIES) $(EXTRA_namehint_DEPENDENCIES)
@rm -f namehint$(EXEEXT)
$(AM_V_CCLD)$(LINK) $(namehint_OBJECTS) $(namehint_LDADD) $(LIBS)
-oldapi$(EXEEXT): $(oldapi_OBJECTS) $(oldapi_DEPENDENCIES) $(EXTRA_oldapi_DEPENDENCIES)
- @rm -f oldapi$(EXEEXT)
- $(AM_V_CCLD)$(LINK) $(oldapi_OBJECTS) $(oldapi_LDADD) $(LIBS)
pcm$(EXEEXT): $(pcm_OBJECTS) $(pcm_DEPENDENCIES) $(EXTRA_pcm_DEPENDENCIES)
@rm -f pcm$(EXEEXT)
$(AM_V_CCLD)$(pcm_LINK) $(pcm_OBJECTS) $(pcm_LDADD) $(LIBS)
@@ -488,7 +481,6 @@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/latency.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/midiloop.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/namehint.Po@am__quote@
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/oldapi.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/pcm-multi-thread.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/pcm.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/pcm_min.Po@am__quote@
This diff is collapsed.
Click to expand it.
main/automake/APKBUILD
+
7
−
1
View file @
c96e25eb
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
automake
pkgver
=
1.15.1
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"A GNU tool for automatically creating Makefiles"
url
=
"https://www.gnu.org/software/automake"
arch
=
"noarch"
license
=
"GPL-2.0-or-later MIT Public-Domain"
depends
=
"perl"
makedepends
=
"autoconf"
checkdepends
=
"bash gzip"
subpackages
=
"
$pkgname
-doc"
source
=
"ftp://ftp.gnu.org/gnu/
$pkgname
/
$pkgname
-
$pkgver
.tar.gz"
builddir
=
"
$srcdir
/
$pkgname
-
$pkgver
"
...
...
@@ -21,6 +22,11 @@ build() {
make
}
check
()
{
cd
"
$builddir
"
make check
}
package
()
{
cd
"
$builddir
"
make
DESTDIR
=
$pkgdir
install
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment