Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
c8783418
Commit
c8783418
authored
1 year ago
by
alice
Browse files
Options
Downloads
Patches
Plain Diff
main/cdparanoia: fix werror=format-security
parent
7f401834
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/cdparanoia/APKBUILD
+3
-1
3 additions, 1 deletion
main/cdparanoia/APKBUILD
main/cdparanoia/format-security.patch
+17
-0
17 additions, 0 deletions
main/cdparanoia/format-security.patch
with
20 additions
and
1 deletion
main/cdparanoia/APKBUILD
+
3
−
1
View file @
c8783418
...
...
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
cdparanoia
pkgver
=
10.2
pkgrel
=
1
3
pkgrel
=
1
4
pkgdesc
=
"An audio CD extraction application"
url
=
"https://www.xiph.org/paranoia"
arch
=
"all"
...
...
@@ -11,6 +11,7 @@ license="GPL-2.0-or-later"
makedepends
=
"libtool autoconf automake linux-headers"
subpackages
=
"
$pkgname
-dev
$pkgname
-doc
$pkgname
-libs"
source
=
"https://downloads.xiph.org/releases/cdparanoia/cdparanoia-III-
$pkgver
.src.tgz
format-security.patch
gcc.patch
fix-includes.patch"
builddir
=
"
$srcdir
/
$pkgname
-III-
$pkgver
"
...
...
@@ -50,6 +51,7 @@ libs() {
sha512sums
=
"
4ab0a0f5ef44d56c1af72d1fc1035566a1a89c4eeddb9e8baea675fe51c06138d913342afc8bed167d9fa55672fa25a2763ce21f7e24c1232e4739aff20733a7 cdparanoia-III-10.2.src.tgz
be88cbe9fb611e56eb180de15422b31436226728246397f8460ea56444ea59537efdcde39ffee170ea8d6cf1784ec71df98c1a65c436f7e59a1057e952384a1c format-security.patch
27bf216e8b5b9d6971e3999166544025f166587df06065b89657dac62d0d53c01b76f53146c1e9a400dd71460567fadb8fd4ce00576836f972914d69e8855909 gcc.patch
e8a5ef0f5bcdba697d2d49e31346832bfa2460e6f6cac9256420f57c74a5da2945bdc664368c91365a880ba76e638f58773468d8e8bd16e7afcaff955a1a82ce fix-includes.patch
"
This diff is collapsed.
Click to expand it.
main/cdparanoia/format-security.patch
0 → 100644
+
17
−
0
View file @
c8783418
diff --git a/main.c b/main.c
index 664acac..d568fb1 100644
--- a/main.c
+++ b/main.c
@@ -588,10 +588,10 @@
static void callback(long inpos, int function){
buffer[aheadposition+19]='>';
}
- fprintf(stderr,buffer);
+ fprintf(stderr, "%s", buffer);
if (logfile != NULL && function==-1) {
- fprintf(logfile,buffer+1);
+ fprintf(logfile, "%s", buffer+1);
fprintf(logfile,"\n\n");
fflush(logfile);
}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment