Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
c607f4a5
Commit
c607f4a5
authored
11 months ago
by
achill (fossdd)
Committed by
Michał Polański
10 months ago
Browse files
Options
Downloads
Patches
Plain Diff
community/yambar: upgrade to 1.11.0
parent
29e24116
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!64422
community/yambar: upgrade to 1.11.0
Pipeline
#231905
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/yambar/APKBUILD
+7
-4
7 additions, 4 deletions
community/yambar/APKBUILD
community/yambar/fix-missing-break-in-switch-statement.patch
+14
-0
14 additions, 0 deletions
community/yambar/fix-missing-break-in-switch-statement.patch
with
21 additions
and
4 deletions
community/yambar/APKBUILD
+
7
−
4
View file @
c607f4a5
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname
=
yambar
pkgver
=
1.1
0
.0
pkgrel
=
1
pkgver
=
1.1
1
.0
pkgrel
=
0
pkgdesc
=
"Modular status panel for X11 and Wayland, inspired by Polybar"
url
=
"https://codeberg.org/dnkl/yambar"
license
=
"MIT"
...
...
@@ -29,7 +29,9 @@ makedepends="
"
checkdepends
=
"font-dejavu"
subpackages
=
"
$pkgname
-doc
$pkgname
-dev
$pkgname
-zsh-completion"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://codeberg.org/dnkl/yambar/archive/
$pkgver
.tar.gz"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://codeberg.org/dnkl/yambar/archive/
$pkgver
.tar.gz
fix-missing-break-in-switch-statement.patch
"
builddir
=
"
$srcdir
/
$pkgname
"
build
()
{
...
...
@@ -46,5 +48,6 @@ package() {
}
sha512sums
=
"
c8d1e807017f62886cba65dab9933913f473eeeae8cbf8d44ddd4953754a55c81def9a02506b28a7ea7264325748db0a0ca4cdff39ba74a06f531e6e55878b35 yambar-1.10.0.tar.gz
af932799916316b152767be2ba57b53d4eba38ab295731a96a29ca20d70e3df30163ebe55981a98b540cef43412ac635d55d477fdf2d9b5a47f7dc5c34985272 yambar-1.11.0.tar.gz
8fe81e384d3442ea4b9b6ebf375c229f455314a04a8ba78b4dc34080dd48ea58e1f0f0c5695fe718977bcb52b0af054412c1f49423124a1cae6aa10e360b7b33 fix-missing-break-in-switch-statement.patch
"
This diff is collapsed.
Click to expand it.
community/yambar/fix-missing-break-in-switch-statement.patch
0 → 100644
+
14
−
0
View file @
c607f4a5
https://codeberg.org/dnkl/yambar/pulls/378
---
diff --git a/modules/network.c b/modules/network.c
index 4bb0fb2..adb8f68 100644
--- a/modules/network.c
+++ b/modules/network.c
@@ -595,6 +595,7 @@
handle_link(struct module *mod, uint16_t type, const struct ifinfomsg *msg, size
iface->name = strdup((const char *)RTA_DATA(attr));
LOG_DBG("%s: index=%d", iface->name, iface->index);
mtx_unlock(&mod->lock);
+ break;
case IFLA_OPERSTATE: {
uint8_t operstate = *(const uint8_t *)RTA_DATA(attr);
if (iface->state == operstate)
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment