Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
c4dd51f1
Commit
c4dd51f1
authored
7 years ago
by
Jakub Jirutka
Browse files
Options
Downloads
Patches
Plain Diff
testing/ameba: new aport
https://github.com/veelenga/ameba
parent
ec1d62b2
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/ameba/APKBUILD
+33
-0
33 additions, 0 deletions
testing/ameba/APKBUILD
testing/ameba/fix-makefile.patch
+27
-0
27 additions, 0 deletions
testing/ameba/fix-makefile.patch
with
60 additions
and
0 deletions
testing/ameba/APKBUILD
0 → 100644
+
33
−
0
View file @
c4dd51f1
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname
=
ameba
pkgver
=
0.5.0
pkgrel
=
0
pkgdesc
=
"A static code analysis tool for Crystal"
url
=
"https://github.com/veelenga/ameba"
arch
=
"x86_64 aarch64"
# limited by crystal
license
=
"MIT"
makedepends
=
"crystal libxml2-dev shards yaml-dev"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/veelenga/
$pkgname
/archive/v
$pkgver
.tar.gz
fix-makefile.patch"
builddir
=
"
$srcdir
/
$pkgname
-
$pkgver
"
export
CRYSTAL_CACHE_DIR
=
"
$srcdir
/.cache"
build
()
{
cd
"
$builddir
"
make
CRFLAGS
=
"--release"
}
check
()
{
cd
"
$builddir
"
make
test
SPEC_FLAGS
=
"--no-color"
}
package
()
{
cd
"
$builddir
"
make
install
PREFIX
=
"
$pkgdir
/usr"
}
sha512sums
=
"12498c3ea90ee1c31ce7f45b3addf7bc1fb192223eaca4fb1e80483272f4695175cec40be6c6d3d3b8b61113c0e625e65ac0845b7ea14de2bab51f91473d7522 ameba-0.5.0.tar.gz
dde379039eebda0ea67e5a95d74af0980b316b77ca7ac426e307578358030702488a6e1e7ba70b490a5aa1eb53e144ad348cb4d75717b3601f8e8ea73b36a5fa fix-makefile.patch"
This diff is collapsed.
Click to expand it.
testing/ameba/fix-makefile.patch
0 → 100644
+
27
−
0
View file @
c4dd51f1
--- a/Makefile
+++ b/Makefile
@@ -2,16 +2,19 @@
PREFIX ?= /usr/local
SHARD_BIN ?= ../../bin
-build:
+.PHONY: build
+build: bin/ameba
+
+bin/ameba:
$(CRYSTAL_BIN) build --no-debug -o bin/ameba src/cli.cr $(CRFLAGS)
clean:
rm -f ./bin/ameba
-install: build
+install: bin/ameba
mkdir -p $(PREFIX)/bin
cp ./bin/ameba $(PREFIX)/bin
-bin: build
+bin: bin/ameba
mkdir -p $(SHARD_BIN)
cp ./bin/ameba $(SHARD_BIN)
-test: build
- $(CRYSTAL_BIN) spec
+test: bin/ameba
+ $(CRYSTAL_BIN) spec $(SPEC_FLAGS)
./bin/ameba
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment