Skip to content
Snippets Groups Projects
Commit bf848751 authored by mio's avatar mio Committed by Natanael Copa
Browse files

community/moreutils: fix docbook-xsl stylesheets path

`_docbookpath` contained multiple directory paths from a recent change
to docbook-xsl subpackages. This led to an error with generating the man
pages and caused some executables to not be output from the same `make`
option. Since some executables could not be found during `make install`,
the build failed during the package stage. Restoring a valid
`_docbookpath` value enabled the man pages to be successfully generated.

```
make: Nothing to be done for '/usr/share/xml/docbook/xsl-stylesheets-1.79.2-nons'.
make: Nothing to be done for '/usr/share/xml/docbook/xsl-stylesheets-nons'.
[...]
install -s isutf8 ifdata ifne pee sponge mispipe lckdo parallel errno
/home/buildozer/aports/community/moreutils/pkg/moreutils/usr/bin
install: can't stat 'ifdata': No such file or directory
install: can't stat 'ifne': No such file or directory
install: can't stat 'pee': No such file or directory
install: can't stat 'sponge': No such file or directory
install: can't stat 'mispipe': No such file or directory
install: can't stat 'lckdo': No such file or directory
install: can't stat 'parallel': No such file or directory
install: can't stat 'errno': No such file or directory
make: *** [Makefile:23: install] Error 1
```
parent 812c442b
No related branches found
No related tags found
1 merge request!74771community/moreutils: fix docbook-xsl stylesheets path
Pipeline #272842 skipped
......@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=moreutils
pkgver=0.69
pkgrel=1
pkgrel=2
pkgdesc="A growing collection of the unix tools that nobody thought to write thirty years ago"
url="https://joeyh.name/code/moreutils/"
arch="all"
......@@ -11,11 +11,11 @@ depends="perl perl-timedate perl-ipc-run"
checkdepends="bash"
makedepends="perl-dev docbook-xsl docbook-xml perl-xml-sax libxslt-dev linux-headers"
subpackages="$pkgname-doc"
source="https://git.joeyh.name/index.cgi/moreutils.git/snapshot/moreutils-$pkgver.tar.gz
docbook-xsl.patch"
source="https://git.joeyh.name/index.cgi/moreutils.git/snapshot/moreutils-$pkgver.tar.gz"
build() {
_docbookpath="$(echo /usr/share/xml/docbook/xsl-stylesheets-*)"
_docbookpath="$(echo /usr/share/xml/docbook/xsl-stylesheets-* | \
awk '{print $1}')"
if [ -z "$_docbookpath" ]; then
error "Couldn't get $_docbookpath, you need docbook-xsl installed"
fi
......@@ -36,5 +36,4 @@ package() {
sha512sums="
0f9033a860bbbc72d50331809c94e7d29c1125339b68434d68d95039ec075b46daff642ad4a08303444fa7873f04a894c4f2010b6ce74e92f868cfc246e39a6f moreutils-0.69.tar.gz
4e55b2f45443c71dcf3ff99f233119b997e52d4979985ff5269c07d98bb6ddcee74658a6006165d50757beb0054a2a2cc91d46ad60b943fbd0310b318e72de99 docbook-xsl.patch
"
diff --git a/Makefile b/Makefile
index 1e92f61..2df0af9 100644
--- a/Makefile
+++ b/Makefile
@@ -5,12 +5,6 @@ CFLAGS?=-O2 -g -Wall
INSTALL_BIN?=install -s
PREFIX?=/usr
-ifneq (,$(findstring CYGWIN,$(shell uname)))
- DOCBOOKXSL?=/usr/share/sgml/docbook/xsl-stylesheets
-else
- DOCBOOKXSL?=/usr/share/xml/docbook/stylesheet/docbook-xsl
-endif
-
DOCBOOK2XMAN=xsltproc --param man.authors.section.enabled 0 $(DOCBOOKXSL)/manpages/docbook.xsl
all: $(BINS) $(MANS)
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment