Skip to content
Snippets Groups Projects
Commit be4601f0 authored by rubicon's avatar rubicon
Browse files

community/es-shell: fix build with gcc14

parent 40b6961c
No related branches found
No related tags found
1 merge request!70243community/es-shell: fix build with gcc14
......@@ -3,7 +3,7 @@
pkgname=es-shell
pkgver=0.9.2_git20220315
_gitrev=0993c96404973c70888696c23a9d7cb016871fd0
pkgrel=0
pkgrel=1
pkgdesc="Shell with higher-order functions"
url="https://wryun.github.io/es-shell/"
arch="all !ppc64le" # error: expected expression at end of input
......@@ -48,5 +48,5 @@ package() {
sha512sums="
20c92cc99669c2cc5ea9767545e1c749d38143d166e3e5b4b1940b8c551bc65d012bd47aa60dc8e97697c693e31ba462f0d08fc38df52adb64e76c62fc3ccc04 es-shell-0.9.2_git20220315.tar.gz
3c6a022097b9d269beef43a8cba6319c34c8711bdf67e7d24069c22a9e2924723a15eaf592a7cb7e714c4b882d2e6395673fa12e88cc7af71561d0c35b074e87 configure.ac.patch
3d51fdfa2ea196d3e6b1dff79b1efadb5254566942ea61dba4a9792aae417c0ca05d1681a334a2c81ee674e8f63971dd6e7bcdbe56e6fa41fe7d7081928f578b configure.ac.patch
"
......@@ -16,3 +16,13 @@
AC_FUNC_MMAP
AC_FUNC_WAIT3
@@ -103,7 +111,9 @@
char *foov[] = { "-a", "-bfoo", "bar" };
int fooc = (sizeof(foov) / sizeof(foov[0]));
+_Noreturn void exit (int);
int getenv() { return *foo; }
+int getopt(int, char * const [], const char *);
int main() { while (-1 != getopt(fooc, foov, "ab:")); exit(0); }
changequote([,])
]])],[es_cv_abused_getenv=no],[es_cv_abused_getenv=yes
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment